Crystal  - Shared vairable capture wile printing

Posted on 2016-08-09
Medium Priority
Last Modified: 2016-08-09
Attached is a sample report where I am trying to capture the TOTAL netagive value for that ship date.  Curretnly the formuals are written to capture the First Negative date which is working but in the event there are multiple orders on the same day it does not work as desired.

Product: 323600-69
Total negative amount:  164   (this is the value I want to capture as that is the sum of the total negative amount for the 8/9/2016 ship date.  Currently the vairable is only capturing the -32 value since that is the first negative amount.
Question by:kelsanit
1 Comment
LVL 101

Accepted Solution

mlmcc earned 2000 total points
ID: 41748866
Try changing your calculation formula zCalc_Qty_OnHand_AfterOrder to

SHARED NumberVar Qty_OnHand;
SHARED DateVar First_Negative_Date;
SHARED NumberVar First_Negative_Qty;

Qty_OnHand := Qty_OnHand - {ORDER_TRL.Quantity-Open};
If Qty_OnHand < 0 AND First_Negative_Date = Date(1900,1,1) then
    First_Negative_Date := {ORDER_HDR.Ship-Date};
    First_Negative_Qty := Qty_OnHand*-1;
Else If Qty_OnHand < 0 AND First_Negative_Date = {ORDER_HDR.Ship-Date} then
    First_Negative_Qty := Qty_OnHand*-1;


Open in new window


Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Crystal Reports: 5 Tests for Top Performance It is complete, your masterpiece report.  Not only does it meet your customer’s expectations, it blows them out the water, all they want is beautifully summarised and displayed in a myriad of ways. …
Hot fix for .Net Crystal Reports 10.2.3600.0 to fix problems with sub reports running on 64 bit operating systems ISSUE: Reports which contain subreports fail with error "Missing Parameter Value" DEPLOYMENT SERVER OS: Windows 2008 with 64 bi…
In response to a need for security and privacy, and to continue fostering an environment members can turn to for support, solutions, and education, Experts Exchange has created anonymous question capabilities. This new feature is available to our Pr…
How to fix display issue, screen flickering issue when I plug in power cord to the machine. Before I start explaining the solution lets check out once the issue how it looks like after I connect the power cord. most of you also have faced this…

624 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question