• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 118
  • Last Modified:

Problem registering SIP phone from outside the network

We moved our Asterisk server version 1.4.31 from one network to another.  When my phones are on the new LAN, they register to the server just as I would expect.  When I try to connect from outside the network, the phones will not register.  I am using x-lite to test my connectivity.
The firewall in the new LAN is a Cisco 5505 and these are the settings are as follows.  I believe this to be a firewall issue because everything was working perfectly in the old LAN.

Firewall settings

object-group service VoIP_SIP udp
 description All ports pertaining to VoIP using SIP
 port-object eq sip
 port-object range 10000 20000
 port-object eq 4569

access-list outside_acl remark Web access to VoIP server to provide XML services to phones outside the LAN
access-list outside_acl extended permit tcp any host (public IP Address) eq www
access-list outside_acl remark VoIP SIP Mapping for SIP-based phones
access-list outside_acl extended permit udp any host (public IP Address) eq sip
access-list outside_acl remark VoIP TFTP Server for phone configurations.
access-list outside_acl extended permit udp any host (public IP Address) eq tftp
access-list outside_acl remark VoIP media port mapping.
access-list outside_acl extended permit udp any host (public IP Address) object-group VoIP_SIP


static (outsideif,insideif) 10.1.30.20 (public IP Address) netmask 255.255.255.255
static (insideif,outsideif) (public IP Address) 10.1.30.20 netmask 255.255.255.255

route outsideif 0.0.0.0 0.0.0.0 (public IP Address) 1


policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect netbios
  inspect tftp
  inspect ip-options
  inspect icmp
  inspect pptp
  inspect sip

Open in new window

0
Mike Orther
Asked:
Mike Orther
  • 7
  • 7
1 Solution
 
Gareth Tomlinson CISSPNetwork and Security ManagerCommented:
SIP is normally port 5060 and up, I don't see that?
Did you have a firewall in the old setup?  If so, do you have a copy of that config?
0
 
Mike OrtherSystems EngineerAuthor Commented:
we are using IAX2 traffic over the default port (4569).
The settings above are the same as my previous firewall.
Port 5060 in not configured in any of my other sites, only port 4569.
0
 
Gareth Tomlinson CISSPNetwork and Security ManagerCommented:
sorry, not familiar with IAX2
Aren't your NAT statements the wrong way round? ASA is normally source first, then destination
0
Get Certified for a Job in Cybersecurity

Want an exciting career in an emerging field? Earn your MS in Cybersecurity and get certified in ethical hacking or computer forensic investigation. WGU’s MSCSIA degree program was designed to meet the most recent U.S. Department of Homeland Security (DHS) and NSA guidelines.  

 
Gareth Tomlinson CISSPNetwork and Security ManagerCommented:
By which I mean the outsideif  NAT lists the legal IP frst, then actual
Insideif nAT lists actual first, then legal NAT
0
 
Gareth Tomlinson CISSPNetwork and Security ManagerCommented:
0
 
Mike OrtherSystems EngineerAuthor Commented:
you can see when I create this static route in asdm how it shows from the command line.  If I change this then nothing works, including phone registration from inside the network.  When I change it back then I can register phone from inside but still nothing outside.
asdm.JPG
0
 
Gareth Tomlinson CISSPNetwork and Security ManagerCommented:
What is the voiceif network? Is this where the internal phones sit?
0
 
Mike OrtherSystems EngineerAuthor Commented:
voiceif is a different phone system.  Those phone reside on the 10.1.35.x network.
0
 
Mike OrtherSystems EngineerAuthor Commented:
My phones are registering from inside the network without issue.  It is from outside the network that is the problem.
0
 
Gareth Tomlinson CISSPNetwork and Security ManagerCommented:
This is a silly question, but what license do you have on the ASA 5505? I seem to recall you have to have the SEC-PLUS license to use 3 interfaces, and escape the license restrictions.
0
 
Mike OrtherSystems EngineerAuthor Commented:
Hi Gareth.  We must have an open license on this FW because we have been using 4 of the 7 ports for years.  Way before my time, hahaha.
0
 
Mike OrtherSystems EngineerAuthor Commented:
Garith, do you think it would help if I changed the public IP Address to something different?  The one I am using seems to be routing to 0.0.0.0
0
 
Gareth Tomlinson CISSPNetwork and Security ManagerCommented:
The route to 0.0.0.0 is the default route for the firewall, i.e. the internet.
Can I clarify - you have 2 different phone systems in your network?>
0
 
Mike OrtherSystems EngineerAuthor Commented:
Thank you for you help Gareth, you were super helpful
0

Featured Post

Get Certified for a Job in Cybersecurity

Want an exciting career in an emerging field? Earn your MS in Cybersecurity and get certified in ethical hacking or computer forensic investigation. WGU’s MSCSIA degree program was designed to meet the most recent U.S. Department of Homeland Security (DHS) and NSA guidelines.  

  • 7
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now