hyper-v vm will not start

Posted on 2016-08-10
Last Modified: 2016-08-17
I have one hyper-v vm which I cannot power on, the problem is that files in the following directory:

C:\ClusterStorage\StorageVolume\VM01\Virtual Machines\90DA46CE-0620-4074-97D9-6E16BCBFD86C


Something has happened to the permissions on these files, noone has access, not even administrators.  I have tried to take ownership of the files using the GUI and using command line "takeown" and "icacls" but I keep getting access denied.

I am running Server 2012 on Hyper-V hosts.
Question by:carbonbase
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
  • 2
  • +1
LVL 12

Accepted Solution

Benjamin Voglar earned 500 total points
ID: 41750247
The fastest way to repair this is to copy the vhdx to new folder, create new VM and add the vhdx as a disk drive.
LVL 12

Expert Comment

by:Benjamin Voglar
ID: 41750248
It is possible that a backup sw, do not allow you to take the ownership.
LVL 37

Expert Comment

ID: 41750258
ever tried simply rebooting the host? this will ultimately unlock the files and folders, if the VM is not autostart enabled.
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

LVL 16

Expert Comment

by:Shaik M. Sajid
ID: 41750317

Author Comment

ID: 41750673
Thanks for the comments.

I'm not sure rebooting the host will help, I removed the .lock file and also removed the vm from inventory but this hasn't help.  

I've run computer manager and process explorer and can't see any locks on the files

Can't see any backup software running on the host but I'll check with the backup guy

Not sure what implications of creating a new vm are, not sure if this will change the Windows SID and I'd have to re-create the config like memory and network settings etc.  I have re-imported the vm, and will try exporting it to a new folder then see if i can take ownership/modify permissions on the .bin and .vsv files.

Author Comment

ID: 41750683
the other thing, i have three hosts, i import the vm on one host (doesn't matter which one) and after a while it seems to move to a different host to the one i've registered it on, not sure why this is.

Author Comment

ID: 41750688
can't do an export of the vm, not enough space to duplicate the vhd's :-(
LVL 37

Expert Comment

ID: 41750700
is it a production server?
LVL 12

Expert Comment

by:Benjamin Voglar
ID: 41751594
I had the same problem and i simple created a new VM like i said. (it was a product server, no rejoin to domain needed.)

But you can try this:

Like i see, you have a hyper-v cluster. If your critical VM is on node1, move all others VM's on node2. Restart nod1 and try aggain. It will run again.


Author Comment

ID: 41753914

yes it's a production server


i restarted the host on which the vm was currently registered by that hasnt helped.

Author Closing Comment

ID: 41759150
I've taken Benjamin's suggestion of re-creating the vm and attaching the original hard disks.  I now have a working vm.  Thanks!

I still have the old state files from the original vm <guid.bin> and <guid.vsv>

I cannot delete or modify these files.  I've tried takeown command, process explorer and handle.exe but no luck so far.  Anyone got any suggestions for deleting the files?

Featured Post

Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

First I will try to share a design of a Veeam Backup Infrastructure without Direct NFS Access backup. Note: Direct NFS Access backup transport mechanism is only available in Veeam v9 In above I try to design the Veeam Backup flow between i…
You might have come across a situation when you have Exchange 2013 server in two different sites (Production and DR). After adding the Database copy in ECP console it displays Database copy status unknown for the DR exchange server. Issue is strange…
This tutorial will walk an individual through the process of configuring basic necessities in order to use the 2010 version of Data Protection Manager. These include storage, agents, and protection jobs. Launch Data Protection Manager from the deskt…
This tutorial will walk an individual through the process of installing of Data Protection Manager on a server running Windows Server 2012 R2, including the prerequisites. Microsoft .Net 3.5 is required. To install this feature, go to Server Manager…

624 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question