Solved

Toshiba Laptop Drivers...

Posted on 2016-08-10
32
174 Views
Last Modified: 2016-08-12
Does anyone have experience with their support page? I've got a Satellite C55-B5202, that owner did not create recovery media for & the HD crashed. I reinstalled Win 8.1 from retail copy, but when trying to find drivers, I'm getting messages like system doesn't meet minimum requirements, or no drivers found, when installing manually. I'd really like to install just the drivers needed & not all the extra crap that usually comes on a retail boxed computer for home.
0
Comment
Question by:gromack
  • 15
  • 8
  • 7
  • +2
32 Comments
 
LVL 53

Expert Comment

by:McKnife
Comment Utility
These http://support.toshiba.com/support/modelHome?freeText=1200008359 look pretty new, they should work on win8.1
0
 
LVL 35

Expert Comment

by:Kimputer
Comment Utility
Seems their support page is well updated.

http://support.toshiba.com/support/modelHome?freeText=1200008359

Select Win8.1 (64 bits, I assume?) from the left lower pane, then the driver you need. Download, install. I don't see what troubles you're having? Can you be more specific and more detailed?
0
 

Author Comment

by:gromack
Comment Utility
Yes, I'm at that page. Let's start with LAN driver. It shows one available, when applying the filter for 64 bit Win 8.1, it shows one, RealTek LAN Driver. I save to a USB, try to install on laptop, files uncompress, but install never starts. I've unzipped files to a folder & tried to manually install & get message that windows could not find a driver...  Under wifi, I see about 9 different files, by 3 different vendors.
0
 
LVL 35

Expert Comment

by:Kimputer
Comment Utility
I see now that Toshiba is somewhat lacking in updating their drivers.

For the LAN:

http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=13&PFid=4&Level=5&Conn=4&DownTypeID=3&GetDown=false&Downloads=true

Select Win8.1 near the top. These will work.

The Wifi is just a guess, you can try them all. I'd start with the Intel one on top. That one seems to be the newest (i.e., LAN wasn't updated properly, but somehow wifi was)
Since it won't install if it's the wrong one, you don't harm your laptop. Go the Atheros if Intel doesn't work.
0
 
LVL 87

Expert Comment

by:rindi
Comment Utility
Have you checked in Device manager whether drivers are even needed? If If there is no exclamation mark or other problem there you shouldn't need extra drivers. Windows 8.1 has a lot of them built-in already. If there are problems in device manager, first try installing the chipset drivers. That will often take care of most others too, or at least allow you to install those other drivers after that.
0
 

Author Comment

by:gromack
Comment Utility
Yes, I have checked device manager & I was hoping most of the drivers would be included with Windows. I have network controller, PCI device, PCI encryption/decryption controller & last but not least, the Unknown device, all with exclamation points, and I have no network adapters showing. I thought insstalling chipset first might help, but was presented with the message 'thw computer does not meet the minimum requirements for installing the software. setup will exit', and there was only ONE choice for chipset software! Trying the LAN software from RealTek site had the same end results, too.
I'm thinking someone's gonna have to shell out an additional $40 for the USB restore drive from Toshiba...
0
 
LVL 35

Accepted Solution

by:
Kimputer earned 500 total points
Comment Utility
That shouldn't be necessary. Just go to all the hardware you need to install, and give us the hardware id's (Device manager, pick your hardware, right mouse click Properties, tab Details, dropdwon Hardware ids)
You'll get there for free. Just needs a bit of time.
0
 

Author Comment

by:gromack
Comment Utility
Ok, here's what I've got -

Network Controller;
PCI\VEN_168C&DEV_0036&SUBSYS_183211AD&REV_01
PCI\VEN_168C&DEV_0036&SUBSYS_183211AD
PCI\VEN_168C&DEV_0036&CC_028000
PCI\VEN_168C&DEV_0036&CC_0280

PCI Device;
PCI\VEN_10EC&DEV_5229&SUBSYS_F91B1179&REV_01
PCI\VEN_10EC&DEV_5229&SUBSYS_F91B1179
PCI\VEN_10EC&DEV_5229&CC_FF0000
PCI\VEN_10EC&DEV_5229&CC_FF00

PCI Encryption/Decryption Controller;
PCI\VEN_8086&DEV_0F18&SUBSYS_F91B1179&REV_0E
PCI\VEN_8086&DEV_0F18&SUBSYS_F91B1179
PCI\VEN_8086&DEV_0F18&CC_108000
PCI\VEN_8086&DEV_0F18&CC_1080

Unknown Device;
ACPI\VEN_TOS&DEV_6205
ACPI\TOS6205
*TOS6205
0
 

Author Comment

by:gromack
Comment Utility
Ok, punching a few of these into Google & I'm usually directed to some type of driver download site.
Are these safe to DL from there, or will they come with extra add on crap?
In cases where they are ID'd with a name, like Atheros, Intel, etc., I'll go back to Toshiba's site.
Since most of these have 4 IDs, does that mean that there are 4 different components in that category?
0
 
LVL 91

Expert Comment

by:nobus
Comment Utility
for the lan i found this :


Chip Description: Qualcomm Atheros AR956x Wireless Network Adapter
Notes: https://www.atheros.cz/atheros-wireless-download.php?chipset=83

that's a wireless driver

personally i Always use a wired lan for setting up a new pc - much faster
0
 

Author Comment

by:gromack
Comment Utility
I've got wifi, Ethernet doesn't seem to want to install. Their drivers page shows LAN (Realtek) driver, but it's not installing. It is currently downloading 200+ updates, hopefully Windows has some of the drivers.
0
 
LVL 35

Expert Comment

by:Kimputer
Comment Utility
Right now, it seems like Windows doesn't see your LAN hardware at all. Of all the hardware id's you provided, Network Controller is indeed the wifi chip.
Can you check your BIOS if LAN can be enabled/disabled?
As long as you don't have LAN in your device manager with a correct hardware id, driver download and installation will do zero/nada/nitch.
You can double check if your LAN is working properly by downloading a newer Linux Live CD (Ubuntu: http://www.ubuntu.com/download/desktop)
Those live cd's usually have no problems with your LAN. If Linux also doesn't see your LAN hardware, you definitely a hardware problem.

The rest of your hardware, you figured out by now I think (a card reader, and some very unimportant other hardware, not needed for proper operation of your laptop).

Just blindly downloading everything you come across is never a good idea. Mostly, you'll catch malware. Even if not worst case, you'll end up with ads on your PC (forcing you to buy their "excellent" driver identifier/installer). Always find out what the hardware is, and download only from reputable sites, mainly, the hardware manufacturer (only their official site), or from a competing brand that you know uses the same hardware (Asus, HP, Dell, MSI, Gigabyte, but again, only from their official sites).
0
 
LVL 91

Expert Comment

by:nobus
Comment Utility
post a screenshot of device manager, and expand the lan - if it shows
0
 

Author Comment

by:gromack
Comment Utility
Created the Ubuntu USB drive & have booted from that - where do I go to see network connections, hardware, etc?

BIOS has option to enable or disable LAN, tried both & nothing. Tried manually installing & at end of installation got the following message:
The Realtek Network Controller was not found, If deep sleep mode is enabled please plug the cable. Plugging in cable did nothing.
0
 
LVL 35

Expert Comment

by:Kimputer
Comment Utility
Ubuntu will auto detect LAN. Just plug in network cable, start browser and see if it works. If it doesn't, it's 99% chance hardware fault (1% that Ubuntu didn't correctly see it, it's such a low percentage, as it coincides with Windows not seeing it)
0
 

Author Comment

by:gromack
Comment Utility
Ok, well it looks like there is a hardware fault, as I'm not getting an Internet connection.
0
Get up to 2TB FREE CLOUD per backup license!

An exclusive Black Friday offer just for Expert Exchange audience! Buy any of our top-rated backup solutions & get up to 2TB free cloud per system! Perform local & cloud backup in the same step, and restore instantly—anytime, anywhere. Grab this deal now before it disappears!

 
LVL 91

Expert Comment

by:nobus
Comment Utility
post the dm screenshot as asked
did you read my comment? you do not have a Realtek, but atheros wifi
0
 

Author Comment

by:gromack
Comment Utility
Here you go
0
 

Author Comment

by:gromack
Comment Utility
Any suggestions on that PCI Encryption/Decryption Controller?
0
 
LVL 35

Expert Comment

by:Kimputer
Comment Utility
0
 
LVL 91

Expert Comment

by:nobus
Comment Utility
no, but if you don't see the lan card, it can be disabled in the bios - did you check that?
here they say you have lan + wifi :  http://www.cnet.com/products/toshiba-satellite-c55-b5202-15-6-celeron-n2830-4-gb-ram-500-gb-hdd-us/specs/
0
 

Author Comment

by:gromack
Comment Utility
Platform not supported - F*** it!

Yes, there was an option to enable/disable LAN in BIOS. It was enabled, I even tried disabling & then enabling to see if that would do anything. I believe they use wifi, so I'm gonna just go with that
0
 

Author Comment

by:gromack
Comment Utility
I had someone on the toshiba forum tell me I had to install EVERYTHING listed on laptop's drivers page or else things might not install or work right. Have you taken a look at that?!? I think he was trying to give me the hard sell on the recovery disk, which I may have considerd, had it been available for downloading. This is why I only recommend Dell computers to anyone who aks, the tech support, drivers, etc., are miles beyond the others.
0
 
LVL 91

Expert Comment

by:nobus
Comment Utility
what bios version do you have?  maybe you need to update it
i usually start with chipset, video, - then other drivers; but sometimes a utility is required too
0
 
LVL 35

Expert Comment

by:Kimputer
Comment Utility
Sorry, it's total BS. I've never seen a LAN hardware appear ONLY after you install xxx driver for xxx (and I've been doing this from Win3.1). Sure, chipset drivers are recommended and all, but it's not a necessity to see the LAN hardware in your device manager (not even if the hardware is tied with a chipset like nVidia was).
Both Windows and Linux not seeing your hardware makes the conclusion quite easy.
0
 
LVL 91

Expert Comment

by:nobus
Comment Utility
>>  I've never seen a LAN hardware appear ONLY after you install xxx driver for xxx (and I've been doing this from Win3.1).    <<<  i installed several also, and it happened to me a couple of times  - so it CAN happen

the ubuntu solution should be fine also - but if the LAN is not enabled for some reason, it won't work there also (you can look in settings, or system - it's been some time i had a ubuntu system)

maybe you need to update the bios ?
0
 

Author Comment

by:gromack
Comment Utility
Since Ubuntu didn't see it weither, I'm gonna assume it's broke. Wifi is working, so it should be ok. BIOS was current version & LAN was enabled in BIOS.
0
 
LVL 91

Expert Comment

by:nobus
Comment Utility
do you have the latest bios?
0
 

Author Comment

by:gromack
Comment Utility
Yes, BIOS is the latest version.
0
 

Author Closing Comment

by:gromack
Comment Utility
That seemd to do the trick in finding missing drivers. Thanks!
0
 
LVL 91

Expert Comment

by:nobus
Comment Utility
what seemed to do the trick ? ok i see
0
 

Author Comment

by:gromack
Comment Utility
Using hardware IDs to track them down.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Suggested Solutions

With Windows evolving further, the built-in protective mechanisms get better and better. Still, Microsoft is not very good at introducing those to the technical community. This article is about a new bitlocker functionality that could revolutionize …
OfficeMate Freezes on login or does not load after login credentials are input.
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
In this Micro Tutorial viewers will learn how to use Boot Corrector from Paragon Rescue Kit Free to identify and fix the boot problems of Windows 7/8/2012R2 etc. As an example is used Windows 2012R2 which lost its active partition flag (often happen…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now