How to run mscorfcfg.msc

Posted on 2016-08-10
Last Modified: 2016-08-17
How can I run the Microsoft .NET Framework Configuration in Windows 2012 R2. It is not under administrative tools


Question by:toronto2456
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
LVL 28

Expert Comment

by:Dan McFadden
ID: 41751651
I'll assume that you are using the .NET Framework v4+...  MS has removed the utility from the v4 framework.

MSDN Link:

What is it that you are looking to configure?


Author Comment

ID: 41752055
the site code is under UNC share. and I need to ceate this groups using caspol.

But There is no definitive way to create this groups,I have tried fucking all the switch with CASPOL ( Drive:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\caspol.exe -m -ag 1 -url "file:////\\computername\sharename\*" FullTrust -exclusive on )

but I couldn't make it work. It made it worse as now I can not remove the ones I created. why is there no documentation about this IIS stuff. It is like hell.

It is not anyway to make IIS worked for all remote shares without having have to create this groups.

Author Comment

ID: 41752078
isn't there any way to make IIS work with all remote shares without having have to create this.  or what the fuck is the right switch for this, or how do we delete the groups we created. Nothing works .
PeopleSoft Has Never Been Easier

PeopleSoft Adoption Made Smooth & Simple!

On-The-Job Training Is made Intuitive & Easy With WalkMe's On-Screen Guidance Tool.  Claim Your Free WalkMe Account Now

LVL 28

Expert Comment

by:Dan McFadden
ID: 41752092
You are trying to modify a .NET4+ application with a .NET 2 utility?  That will not work.

BTW, here is a link to a GUI for caspol:

Maybe that will help out a bit.

And a somewhat backward question... Why is the code on an UNC share and not locally stored on the server?

Can you explain more about the application setup?

LVL 28

Accepted Solution

Dan McFadden earned 500 total points
ID: 41752147
Have you tried to reset the policies?

caspol.exe -all -reset

Open in new window


Author Comment

ID: 41759723
Hi Dan,

Problem was that caspol command was wrong from the microsoft site. I had been trying to make it work then I tried the another swtiched that worked

It was about caspol problem.

content are on the UNC share as it was the design.



Author Comment

ID: 41759730
caspol.exe -m -ag 1 -url "\\xxxxxxxxxxx\xxxxxxxxxx\www\*" FullTrust -exclusive on

this is the one I have used not this one that is wrong

caspol.exe -m -ag 1 -url "file:////\\computername\sharename\*" FullTrust -exclusive on

Featured Post

Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

First of all, clustering IIS is something you should rarely consider doing. In almost all cases, Microsoft Network Load Balancing (NLB) ( is a much better solution when you need to p…
When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…
Add bar graphs to Access queries using Unicode block characters. Graphs appear on every record in the color you want. Give life to numbers. Hopes this gives you ideas on visualizing your data in new ways ~ Create a calculated field in a query: …

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question