Link to home
Start Free TrialLog in
Avatar of Gordon_Atherley
Gordon_Atherley

asked on

Udate problem with Realtek in a W10 machine

The audio on my Windows 10 computer no longer works with a Logitech headset.

Realtek's website indicates a recent update for W 10 audio. But installing the update is beyond my competence.

Help, Experts, please.

Gordon
Avatar of REIT
REIT

I would say open the device manager with the head phones plugged, once done post a screenshot of the device manager as that will show the issue.

The issue does sound driver/update related.
Please provide more details about your computer and the driver that you're trying to install.
Avatar of Gordon_Atherley

ASKER

Thanks, both

I'll respond to you both.

Gordon
I tried headphones. These didn't work, front or back.

Then I started work on the screenshot. This involved my attempting to buy SNAGIT, which I have on two other computers.

Despite having purchased SNAGIT, even with the help of SNAGIT support, I could not download it.

Now I am looking for another way to generate a screenshot. Any suggestions, please?

Gordon
You can use PrintScreen Key to take a screenshot, Paste it in MS Paint and save it!
I'm still low on the W10 learning curve. Where do I find the PrintScreen Key, please?
Hi Gordon,
There are many free ways to do what you want. No need to buy Snagit, although it is a very good product. An excellent free, open source product is Greenshot, published at SourceForge:
http://sourceforge.net/projects/greenshot/

And here is its own website:
http://getgreenshot.org/

You can create screenshots of a selected region, a window, or screen. You can annotate, highlight, and redact screenshots.

Another free one is the Snipping Tool, which is built into Vista, W7, W8, and W10. You can set it up to launch on a hotkey by right-clicking on its shortcut in Accessories, then clicking the Shortcut tab, then enter the hotkey you want in the "Shortcut key:" box. I configured mine for the numeric keypad minus sign. That key is in the upper right on my keyboard and being able to tap that and have it bring up the Snipping Tool is really convenient. The Snipping Tool places the image on the clipboard and also has a Save As feature that lets you save it in several formats, including JPG and PNG.

Another idea is to use the PrintScreen key, as mentioned already. Some keyboards call it PrntScrn, PrtSc, PS, etc. — it is typically located in the upper right of the keyboard, such as this:

User generated image
Support for it is built into Windows. If you hit PrintScreen, it captures the entire screen; if you hit Alt-PrintScreen, it captures the focus (active) Window. Then you simply Paste (Ctrl-V) into any imaging program to crop it. IrfanView is excellent, free imaging software that I've been using for many years to do this (as mentioned in my EE article, How To Embed Screenshots in Posts).

After using PrintScreen or Alt-PrintScreen to capture what you want, run IrfanView, hit Ctrl-V, then use the mouse to select the portion of the image you want, and click Edit>Crop Selection. Do a Save As to a JPG, BMP, PNG, or whatever format you prefer — IrfanView supports a wide range of graphics file formats.

In addition to the non-free Snagit, TechSmith also has a free product called Jing:
https://www.techsmith.com/jing.html

It doesn't have all the functionality of Snagit, but it's good — and it's free.

Btw, here's a very interesting EE thread on the subject that I participated in — definitely worth a read:
https://www.experts-exchange.com/questions/28345802/Screen-shot-freeware-on-Windows-7-Windows-2008-R2-x64.html

Regards, Joe
I tried PrintScreen and discovered that MS has recently changed it.

It now uses Snipping Tool, which is accessed as follows.

From the Start area
1. Call up All Apps
2. Scroll down to "W"
3. Select Windows Accessories
4. Scroll down to Snipping Tool

I'm now going to use it to try to build jpg files for attaching to my Question, as requested.
> I tried PrintScreen and discovered that MS has recently changed it.

MS has not recently changed it. PrintScreen (captures everything) and Alt-PrintScreen (captures just the active/focus window) work in W10 the same way as they do in prior versions of Windows.

> It now uses Snipping Tool

The Snipping Tool was introduced in Vista and is in W7, W8, W8.1, and W10, as mentioned in my article, How To Embed Screenshots in Posts, which also has instructions on how to use it. The article also explains how to capture a drop-down menu with the Snipping Tool, which is a bit tricky (it's easy with the PrintScreen key — just tap it as usual — but that won't work with Alt-PrintScreen, as it will close the drop-down menu). Regards, Joe
Thanks for the clarification about the absence of change.

On two W10 machines I use the FN Print Screen button, top right, calls up nothing.

So, obviously, I'm going to depend on the Snipping Tool, at least for the time being.
FN (or Fn) is a special key, usually on laptops with limited keyboard space, that allows another key to be used for an additional purpose. So when you hit FN-PrtSc, you are probably not hitting PrtSc. You are hitting whatever key your laptop manufacturer decided to put on that key to be activated with FN. That said, it's possible that your keyboard has PrtSc associated with the FN key, but that's rare. What model laptop is it? I'd like to look at its keyboard.

Here's a typical laptop keyboard:

User generated image
Notice that PrtSc is not in blue and, hence, does not require the Fn key.

Here's a laptop keyboard that does require Fn to activate PrtSc, as a normal press of that key is Insert:

User generated image
Anyway, try hitting PrtSc without FN and then do a Paste in Paint, Word, or any program that will accept an image off the clipboard. It should work. Please let me know if it doesn't. Of course, using the Snipping Tool is fine. Thanks, Joe
My Logitech keyboard associates 'Print Screen' with an FN key.

N times have I unsuccessfully tried the Print Screen with and without the FN key.

With the Snipping Tool now at my disposal, I'll now move on.
> With the Snipping Tool now at my disposal, I'll now move on.

Fair enough! I hope my article helped you with it.

Forgetting about the keyboard and going back to your real question, when I first installed W10 a year ago (the very first Technical Preview), there were only two drivers that it missed — Realtek audio and Synaptics touchpad. Neither site had W10 drivers at the time, so I tried their W8.1 drivers and they worked fine. I never went back to look for updated drivers from Realtek and Synaptics, and continued to use the W8.1 drivers successfully the whole time. But I just checked in Control Panel and W10 has updated them — the install date for Realtek HD Audio is 20-Jul-16 and the install date for Synaptics Pointing Device is 18-Jul-16.

Are you on a recent release of W10? That should fix your Realtek audio. For me, the so-called Anniversary Update installed on 10-Aug (via automatic updates). It is KB3176931, Version 1607, Build 14393.67. If you have that and it still doesn't work, then downloading and installing the W10 driver from the Realtek site is a possibility. When I did it a year ago, I downloaded a file named 64bit_Win7_Win8_Win81_R275.exe and simply ran it. Now they have W10 drivers as you can see here:
http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=24&PFid=24&Level=4&Conn=3&DownTypeID=3&GetDown=false

There are both 32-bit and 64-bit drivers:

32bits Vista, Windows7, Windows8, Windows8.1, Windows10 Driver only (Executable file) R2.79 2015/6/25

64bits Vista, Windows7, Windows8, Windows8.1, Windows10 Driver only (Executable file) R2.79 2015/6/25

Each will download when you click its Global button at the link above. Simply run the downloaded EXE file by double-clicking it in File Explorer and it should install the driver. But note this comment at the site:
Audio drivers available for download from the Realtek website are general drivers for our audio ICs, and may not offer the customizations made by your system/motherboard manufacturer. To be sure you obtain the full features/customizations provided in your original audio product, please download the latest drivers from your system/motherboard manufacturer's website.
So a better approach is to go to your computer manufacturer's website and see if they have a W10 driver. If so, use that; if not, use the one from the Realtek site. Regards, Joe
Joe

This is very helpful, thanks. It relates closely to my experience.

More after I've tested some things.

Gordon
To start with the problematic computer, I used headphones without a microphone to plug into the green audio socket. This opened the Realtek Audio manager, which was fully audible. With the Snipping tool I could see the audio plugs front and back.

Using headphones with a microphone and USB connector produced nothing.

So I presume that I have driver problem of some type.

But for the problematic computer, I cannot figure out how to identify, download and install the driver.

Any suggestions, please?

Gordon
> the green audio socket

Is there also a separate pink mic socket or is the audio socket a combo, i.e., one socket for both speakers and mic?

> With the Snipping tool I could see the audio plugs front and back.

Don't know what you mean by that — the Snipping Tool is a screen capture utility.

> USB connector

Completely different beast from using the 3.5mm audio jacks. It may or may not require its own driver, depending on the particular USB device that you have.
There is a separate pink socket, with the microphone symbol, front and back.

My audio devices, mic plus earphones, are Logitech.

And yes I could see Realtek's diagram of the audio sockets, front and back.

Drivers?
Have you installed the driver of your headphones? I think USB headphones require a driver.
Please verify if your USB headphones are supported by Windows 10 here:
http://support.logitech.com/en_sg/article/32426
Gordon,
The Realtek audio driver supports the 3.5mm speaker (green) and microphone (pink) jacks. If either jack is not working, the Realtek driver is the problem. If the jacks are working, then any headset with standard 3.5mm speaker and mic jacks should work.

As I said earlier, USB audio devices are different beasts, some requiring their own drivers, others not. If a USB-connected headset is not working, then it's almost surely a driver problem.

So let's summarize. If I'm understanding you right, you have a headset with a 3.5mm jack for audio out, but it does not have a mic. When you plug that into the speaker (green) jack, it works — you hear audio.

You also have a headset with a mic, but it connects to a USB port, not to 3.5mm jacks. That one is not working — neither audio in (mic) nor audio out (speaker).

Is this a correct summary? If not, please clarify. Regards, Joe
For summary, I'm a step forward. I plug the headphones into the green jack. I use a USB to connect a desktop microphone, I engage Voice Recorder and record my own voice. On playback, I can hear my own voice.

I verified my Logitech H530 headset. The information indicates that no new driver is required.

What's next, I wonder?
What's not working?
My Logitech headset which has a microphone and a USB connector to the computer is not working.
So the USB mic is working and the Logitech USB headset (with mic and speakers) is not working. That means that the driver for the former is working and the driver for the latter is not. What is the exact model number of the Logitech headset?
H530
ASKER CERTIFIED SOLUTION
Avatar of Joe Winograd
Joe Winograd
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Joe, thanks

I'll test out the USB port options.

I'll also follow up with the compatibilities in the link you provide.

Gordon
Sounds good, Gordon. Regards, Joe
Thank you, Joe, the Logitech link was very helpful.
You're welcome, Gordon. Glad to hear that was helpful. Regards, Joe