Install Visual Studio 2008 on Windows 10 - Error 1603 installing dot Net Framework 3.5

I need to get VS 2008 studio working on my Win 10 PC.  I have an old dot.net 3.5 Windows CE app I need to debug.

Actually it was working fine on Win 8.1 before I upgraded to Win 10.

I get this 1603 error message after approx 60 minute install - Repair/Rebuild of VS 2008.  

[08/11/16,13:00:00] Microsoft .NET Compact Framework 3.5: [2] Error: Installation failed for component Microsoft .NET Compact Framework 3.5. MSI returned error code 1603

See also attached error log


Error screendd_error_vs_procore_90.txt
LVL 1
enigmasolutionsAsked:
Who is Participating?
 
ecarboneConnect With a Mentor Commented:
Try this:

Part 1:
1. in Windows 10, right-click on the Start menu and select Control Panel
2. Click on Programs
3. Click on 'Turn Windows features on or off'
4. Make sure '.NET Framework 3.5 (includes .NET 2.0 and 3.0)' is checked

If it was unchecked, continue with the installation


Part 2:
Download and install the .NET Compact Framework 3.5 Redistributable
https://www.microsoft.com/en-us/download/details.aspx?id=65


Part 3:
If Part 2 did not solve your problem, download and run the .NET Framework Repair Tool from Microsoft:
https://www.microsoft.com/en-us/download/details.aspx?id=30135
0
 
enigmasolutionsAuthor Commented:
Hooray!  Thank you ecarbone!!! That worked.

But now I can't find the icon to start VS 2008.

My start menu
0
 
ecarboneCommented:
If you click on the Start menu and just type in '2008', does the icon appear in the search results?

If the app is still installed and you just need to add it back to the start menu, you can do that.
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
ecarboneCommented:
Sometimes the app is there in the start menu, but it's not under the folder like you would expect. For example, with Visual Studio 2015 on my computer, in the Start menu there is a FOLDER called 'Visual Studio 2015' but the icon to launch the app is NOT in that folder. It's outside of any folder, as a separate icon.

Start Menu Windows 10
You could manually place a shortcut into the Start menu if you needed to:
1. Go to C:\ProgramData\Microsoft\Windows\Start Menu\Programs
2. Copy a shortcut to Visual Studio into this folder


Another option (although probably overkill) is to do a repair install of VS and see if the icon magically reappears.
0
 
enigmasolutionsAuthor Commented:
I don't see it... when I type 2008 in my start menu

Actually I did the Repair/Install of VS 2008 (because I assumed it was still installed from when my PC was win 8.1).

I used this ISO... (I have an SP1 ISO as well but didn't try it yet)

                                   SW_DVD9_Visual_Studio_Pro_2008_English_Core_MLF_X14-26326.ISO

my search for 2008
0
 
ecarboneCommented:
reinstalling makes sense now that you mention it. In your original post you stated you were getting an error message about 60 minutes into the installation. So that means the installation did not complete. Glad you got it all resolved and you were able to get .net working.
0
 
ecarboneCommented:
definitely install the SP1 and all other updates.
0
 
it_saigeConnect With a Mentor DeveloperCommented:
You should be able to find your associated shortcut here:

C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Microsoft Visual Studio 2008

I would recommend either pinning it to the start menu or task bar.

-saige-
0
 
enigmasolutionsAuthor Commented:
it_saige another awesome little tip.  Thank you.  I was struggling to find the short cut.

I don't get why it is so complex to pin or get a shortcut into the start menu.  

I tried to copy or drag the VS 2008 shortcut to the start menu, and a little message popped up saying "Pin to start".  But when I let go of the mouse button nothing happened.  To me - that is just dumb.

Anyway, I did a bit of research - googled "Windows 10 pin to start not working" and found this tip.  http://superuser.com/questions/947985/cant-pin-some-applications-to-start-menu-in-windows-10.  This tip told me that:

The issue I think arises due to that shortcut not being in the Programs links directory first.
Follow this:
1. Copy the shortcut to %AppData%\Microsoft\Windows\Start Menu\Programs
2. It should now show up in the start menu under Recently added
3. Pin it now

So I copied the short cut to this folder and then... Viola!  It worked.  I can now Pin VS 2008 to the start menu.

Hmm... Well that was complex.  

Anyone know why MS decided to make it so hard to add programs to their menu / groovy tiles?

Anyway I have finally got my VS 2008 running from my start menu - Woo Hoo!  Thank you all!
0
 
enigmasolutionsAuthor Commented:
Awesome tips - thank you
0
All Courses

From novice to tech pro — start learning today.