Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Cisco SG300 VLAN problem

Posted on 2016-08-11
8
Medium Priority
?
85 Views
Last Modified: 2016-08-14
In order to avoid running additional cables which is a monumental challenge we have added a Cisco SG300 switch at one end of the building.  Initially, it has been configured with two VLAN's, WLAN and IP Cameras.
VLAN 30 - Cameras
VLAN 40 - WLAN
Internetworked as follows:                                   2                   3                   4      
Sonicwall -------------- Cisco 3750G ------------------ Cisco SG300 ----------------- Cisco SG300 ------------- Cisco SG300 (New switch)  ----------- WAP
                     Trunk                                Trunk                                    Trunk                                  Trunk                                                   Access
There are two separate cable runs between the 3rd and 4th switches.  Using both as trunks one for cameras and the other for WLAN AP's.  The cameras are working fine.  The WLAN VLAN is not, can connect a laptop to the patch panel just before the 4th switch and have connectivity.  It's just when I patch into the 4th switch (new switch) that I can't get it to work.  Tried just an access port from the 3rd to 4th switch as well instead of a trunk port.   Also, tried different ports.  

Thanks
0
Comment
Question by:Webcc
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
8 Comments
 
LVL 2

Expert Comment

by:Swapnil Ashokkumar Patel
ID: 41752813
Do we have Layer 2 VLAN on last switch ? and TRUNK Port which is coming from second SG300 Switch to Last Switch, Do we have allowed all VLANS on that trunk port configuration ?

Trunk Port Configuration :
[This two commands should be there on BOTH TRUNK ports - one is on Last switch and one port from second last SG300 switch]
conf t
interface [PORT NUMBER]
switchport mode trunk
switchport trunk encap dot1q

These commands will make Layer 2 VLAN on both Cisco switches. [Tese commands should be there on All SG300]
 
conf t
vlan 30
vlan 40
exit

Try it, if still not working, lets dig deep. Dont forget to save config :) "wr"

Thank you.

Swapnil
0
 

Author Comment

by:Webcc
ID: 41752889
Last switch is set to L2, double and triple checked trunk port configuration on all the switches (allowed VLANs, etc).  VLAN 30 is working fine.  Was thinking of adding 40 to VLAN 30 trunk and see if it works that way.

??
0
 
LVL 2

Expert Comment

by:Swapnil Ashokkumar Patel
ID: 41752893
If you can share configuration of last switch and second last switch as attachment, i will quick check it and confirm.

Also please share output of below command.

Show vlan
Show int trunk


Thank you

Swapnil
0
Building an interactive eFuture classroom

Watch and learn how ATEN provided a total control system solution including seamless switching matrix switch, HDBaseT extenders, PDU, lighting control to build an interactive eFuture classroom.

 

Author Comment

by:Webcc
ID: 41752924
Ok, will be back onsite over the weekend.  Will post at that time.

Thanks.
0
 

Author Comment

by:Webcc
ID: 41755594
Here is the config's of the last switch and the second to last switch.

Can set an access port to VLAN 40 on the second to last switch and it works fine.  Tested the cable all the way back to last switch, which I'm using right now and no problems.

VLAN 30 works on the last switch fine.
Tried setting VLAN 40 trunk and access ports to different switchports on the last switch to no avail.

The interconnections between these two switches are correct.
Second to last switchport Gi26 ------------------  Last switch switchport Gi28  (VLAN 40)
Last-switch.txt
Second-to-last-switch.txt
0
 
LVL 2

Accepted Solution

by:
Swapnil Ashokkumar Patel earned 2000 total points
ID: 41755639
Set default gateway ip address of second last switch ip address on last switch.

Ip default-gateway "second last switch ip address"

And also,

U create only vlan on last switch but you also have L3 interface vlan 40 and 30.

Try this command on last switxh,

No int vlan 30
No int vlan 40
No int vlan 75
Vlan 30
Vlan 40

Exit

Wr

Let me know if that helps.
0
 

Author Comment

by:Webcc
ID: 41755763
I think it's actually a cable issue.  I added VLAN 40 to the trunk config of VLAN 30 on both switches and it works.
The cable tests fine, however - strange.
0
 
LVL 2

Expert Comment

by:Swapnil Ashokkumar Patel
ID: 41755764
Yea but if its cable then  it should not work for one vlan either.
Anyways, ping if you got any other issue.

Thank you

Swapnil
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

On Feb. 28, Amazon’s Simple Storage Service (S3) went down after an employee issued the wrong command during a debugging exercise. Among those affected were big names like Netflix, Spotify and Expedia.
This article will show how Aten was able to supply easy management and control for Artear's video walls and wide range display configurations of their newsroom.
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question