Problem with WiFi setting on a Fortinet wifi router

Hi Experts

I'll be happy to make this a Live Gig

A new client of mine has a Fortinet Fortiwifi 60c set up by previous IT company
The WiFi has been set in a different subnet.
i.e. LAN, server, router = 10.0.0.x /255.255.255.0
Wifi = 10.0.1.x / 255.255.255.0

Interface setting
Wifi settings 1
Wifi settings 2
I have 2 issues with this setup
1. speed through the WiFi is soooo slow. e.g. copying a 30MB file from the server on the same site takes several minutes trhough Wifi and a few sec on the wired network
2. Name resolution is not working, i.e. wifi devices cannot ping by name even though I set up the Windows server to be the DNS server in the DHCP config of the Wifi

I have been looking for ways to
1. change the WiFi setting to
   - either get its IP from the Windows server DHCP
   - or to define an IP range which I can exclude from the Windows DHCP server
2. find out why this Wifi access point seems so slow.

Debug so far:
1. Restart router; No difference to speed
2. Change WiFi IP & IP range for Wifi on router : Wifi stops working altogether

Any suggestions ?
LVL 4
Alexandre MichelManager; IT ConsultantAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
I have been looking for ways to ... get its IP from the Windows server DHCP

Connect a LAN port on the Wi-Fi router to your network.
Give the Wi-Fi router a static IP on your network.
Turn DHCP OFF on the Wi-Fi router.

Now your Wi-Fi router is an extension of your network and the speed of a Wi-Fi device will only be limited by the Wi-Fi NIC speed.
0
myramuCommented:
Hi,

From your description I could feel, issue is with the Fortigate resources/settings.
To isolate the issue,
1) Upgrade the Fortigate OS to latest version 5.2.8
2) Use public DNS on clients (A firewall policy is required to allow DNS traffic)
3) Verify the Fortgate resource usage (CPU, memory , sessions and Bandwidth) Refer http://kb.fortinet.com/kb/microsites/search.do?cmd=displayKC&docType=kc&externalId=FD30084
4) Optimize the device configuration
Refer: http://kb.fortinet.com/kb/microsites/search.do?cmd=displayKC&docType=kc&externalId=FD35126
http://kb.fortinet.com/kb/documentLink.do?popup=true&externalID=FD33078

Update us after the above fine-tuning.

Good Luck!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Alexandre MichelManager; IT ConsultantAuthor Commented:
Hi myranu & John

I am going onsite at the end of the week and will follow your advises
Will update this question with the results

Alexandre
0
myramuCommented:
Hi,

Also check the wifi signal strength and try by changing the channel with non-conflicting one.
You may use built windows and MAC wireless debug tool or this one http://www.netspotapp.com/

Good Luck!
0
Alexandre MichelManager; IT ConsultantAuthor Commented:
Upgrading the firmware fixed the issues
Thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.