Solved

Office 365 SSL Issues

Posted on 2016-08-12
5
80 Views
Last Modified: 2016-08-31
Hi Experts,

I have an interesting issue one that Microsoft was not able to assist me with. We are running Office 365 but when we connect outlook clients it looks to the SSL certificate of our DNS hosting server. I don't know why it does this & why it doesn't get the SSL info from Office 365.

Is this by design, if so why?

Look forward to your feedback.
0
Comment
Question by:isdd2000
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 
LVL 41

Expert Comment

by:Vasil Michev (MVP)
ID: 41754595
CPanel? There's some "feature" that basically responds to autodiscover requests, so you should turn it off. If not possible to turn it off on the "server" side, you can deploy the reg keys mentioned in this article to "instruct" Outlook to bypass it: http://support.microsoft.com/kb/2212902

All you need working for O365 is the HTTP redirect method (CNAME).
0
 
LVL 40

Expert Comment

by:Adam Brown
ID: 41754894
Specifically, the Outlook autodiscover lookup pattern goes like this:
1. Check the AD SCP for autodiscover
2. Check domain.com for autodiscover
3. Check autodiscover.domain.com for autodiscover
4. check SRV record for autodiscover

If there is a web server located at domain.com that gives anything other than a 404 response when someone attempts to connect to https://domain.com/autodiscover/autodiscover.xml
Outlook will give a certificate warning when it runs that lookup. Since the domain.com lookup happens before autodiscover.domain.com in the process by default, it will give the certificate warning when it receives the non-404 response from the server. As Vasil mentioned, that portion of the lookup can be skipped to prevent the error from happening. A more appropriate fix would be to reconfigure the webserver at domain.com so it doesn't respond with redirects or other "valid" server responses when attempting to access URLs that don't exist on it.
0
 

Author Comment

by:isdd2000
ID: 41766212
Hi Guys,

Apparently the feature to turn off response to auto discover is disabled but it still pops up??
0
 
LVL 41

Accepted Solution

by:
Vasil Michev (MVP) earned 500 total points
ID: 41766351
Well if you cannot control it server-side, use the Outlook reg keys detailed in the article I linked above.
0
 

Author Closing Comment

by:isdd2000
ID: 41779324
The issue is an inherent issue with Microsoft auto discover process, only solution is to add registry keys.
0

Featured Post

SuperAntiSpyware Licenses Discounted by 25% !

Exclusive offer to Experts Exchange Members!
Buy SuperAntiSpyware License(s) from us and save 25% on the regular purchase price.
- Includes Full SuperAntiSpyware Vendor Support Entitlements
- Your Subscription does not begin until you activate your license
- Buy for your friends

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Read this checklist to learn more about the 15 things you should never include in an email signature.
In-place Upgrading Dirsync to Azure AD Connect
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
A company’s greatest vulnerability is their email. CEO fraud, ransomware and spear phishing attacks are the no1 threat to a company’s security. Cybercrime is responsible for the largest loss of money to companies today with losses projected to r…

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question