Remote Desktop Service Gateway Problem

Hi,
I have installed Remote Desktop Service Role and configure it but when i try to login in Remote Desktop Connection it generate this error:
"Your computer can't connect to the remote computer because the Remote Desktop Gateway server is temporarily unavailable. Try reconnecting later or contact your administrator for assistence"
I have not idea how to troublehoot this problem.
I use windows server 2012 r2
LVL 1
chipruleAsked:
Who is Participating?
 
chipruleAuthor Commented:
Update:
it was a lan mistake that i resolved.
The action that I do was:
-put different name on RD Gateway (not equal to server)
-put a dns entry on my router so that pc out of domain can reach the page
-after that when i try to run a remote desktop from my Remote App it appared a security issue. I import the certificate and than it finally works!!!!
Now I try to publish this on internet
0
 
Davis McCarnOwnerCommented:
Are you local to the server or remote?
If you are remote, you'll need to open the ports in your router/firewall device.
If you are local, you probably need to change your security/antivirus software to allow the traffic.
1
 
chipruleAuthor Commented:
I'm local, on the server the firewall is disabled.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
Davis McCarnOwnerCommented:
What is your antivirus software (its exact, full name, please)?
1
 
chipruleAuthor Commented:
None antivitus, only windows firewall that I disabled, it lab environment.
0
 
Davis McCarnOwnerCommented:
1
 
chipruleAuthor Commented:
I have
type: http
port: 80
ip address: *

type: https
port 443
ip adress: *

I think it's correct.
0
 
Davis McCarnOwnerCommented:
So no invalid bindings were listed by opening IIS manager, Navigating to Default Web Site > Open Site Bindings on the right hand menu?
1
 
chipruleAuthor Commented:
Here is the screen of the Default Web Site
bindings
If can be helpful this is error that is generate when i try to use remote desktop
error remote app
0
 
Davis McCarnOwnerCommented:
Its about halfway down this page:
http://www.petenetlive.com/KB/Article/0001132
1
 
chipruleAuthor Commented:
I change the DefaultTSGateway and it works on pc in domain.
If i use a pc not in domain, but in the same subnet the error isa the same.
In configuration of Remote Desktop Services I put the RD Gateway the same name of server where I installed the service. Is correct or I must put a different name?
0
 
chipruleAuthor Commented:
Update:
from the outside (internet) when i try to launch remote desktop app it generate this error
english version of error
 error_eng
I can't understand, it works in lan. In wan in can access to web page, login correctly but when i launch the remote app it gives error
0
 
Davis McCarnOwnerCommented:
Its really a new question; but, you have to forward port 3389 to the server from the router for RDP to work.
1
 
chipruleAuthor Commented:
I open the 3389 but I have the same error
"Your computer can't connect to the remote computer because an error occurred on the remote computer that you want to connect to. Contact your network administrator for assistance."
But if i launch a remote desktop to public ip I can reach the server without problems.
0
 
chipruleAuthor Commented:
Update:
when I put in my broswer https://PUBLIC-IP/rdweb it gives me error
 err_cert1.pngI correctly install self-signed cert in the root, and I can log in in the web site, the error when launch Remote Desktop or other app remain.
I remind if I launch the Remote Desktop and put public IP i can login without problems.
0
 
Davis McCarnOwnerCommented:
He solved his own problem and then found another one.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.