Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 43
  • Last Modified:

Exchange 2010: Outlook anywhere/Outlook 20XX/ and OWA certificate error

Running Exchange 2010 SP3 on windows server 2008 R2 SP1
This is a single server exchange environment.
Exchange server name:  exchange.gpr.com
Default website:  webmail.grandpacificresorts.com


I recently renewed our exchange SSL certificate, because although Outlook Anywhere is configured there was no SAN for autodiscover.  The new certificate request was created using the EMC and installed the same way.  Lastly IMAP, POP, IIS, and SMTP services were assigned to the certificate.  FYI no virtual directories have been set/changed via powershell since installing the new certificate and IIS has not been reset.  Finally the website defined in the certificate is webmail.grandpacificresorts.com with a SAN of autodiscover.grandpacificresorts.com.

Since installing the new certificate running Outlook Connectivity and Outlook Autodiscover tests on https://testconnectivity.microsoft.com/ now pass, but internal outlook clients and OWA generate the following error:

gpresorts.com  The name on the security certificate is invalid or does not match the name of the site

I can't figure out why Outlook would be referencing gpresorts.com and not grandpacificresorts.com.  I also can't figure out if this an autodiscover virtual directory configuration problem, a DNS issue, or other.

Autodiscover:  see attached results for get-autodiscovervirtual directory | fl

DNS:  below are the exchange related entries in each scope
         
               -Scope gpresorts.com
  • (same as parent folder)               Mail Exchanger (MX)                    gprmail1.gpr.com
  •        webmail                                         Host(A)                                           webmail
             -Scope grandpacificresorts.com
  • (same as parent folder)              Mail Exchanger (MX)                    gprmail1.gpr.com
  •        autodiscover                                Host(A)                                           192.168.0.37
  •        webmail                                        Host(A)                                           192.168.0.37
autodiscover.png
0
Ryan Mignosa
Asked:
Ryan Mignosa
2 Solutions
 
Scott CSenior Systems EnginerCommented:
Check your cert.

Get-ExchangeCertificate | fl

Look through this list and get rid of any certs that are expired.  Also look for any "pending" certs.  I've come across before where a pending wasn't showing up in the GUI, but it did show up in the PS command.  Once I got rid of it, everything started working.
0
 
MASTechnical Department HeadCommented:
0
 
Ryan MignosaAuthor Commented:
Scott,

I actually have 3 SSL certs listed.  I have my new cert with IMAP,POP,IIS,SMTP.  I have the one that I just replaced, but is still active with IMAP,POP,SMTP.  Lastly I have an expired SSL cert.

Are you saying that you've seen a bug in exchange that if you have multiple certificates you can have some certificate errors in your environment?  I ask because when I get security alert and view the certificate it's the correct certificate.

Thank you
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
Ryan MignosaAuthor Commented:
MAS,

I checked your article and a couple items stood out.  The part that keeps bothering me is why is the security alert for gpresorts.com?  The certificate is for grandpacificresorts.com.

Items 1-4: I have 2 forward lookup zones containing the common name webmail.  Why does a client choose one or the other?  Only 1 has an autodiscover entry.

Item 5: I'm wondering if the below address needs to be changed.  The autodiscover address in the exchange certificate is autodiscover.grandpacificresorts.com not webmail...

[PS] C:\Windows\system32>get-clientaccessserver | fl name,autodiscoverserviceinternaluri


Name                           : EXCHANGE
AutoDiscoverServiceInternalUri : https://webmail.grandpacificresorts.com/autodiscover/autodiscover.xml
0
 
Adam BrownSr Solutions ArchitectCommented:
Two questions:

1. What is the email address you are using when configuring Outlook?
2. Is GPResorts.com your internal domain name?

If #1, configure a SRV record in DNS for gpresorts.com that points to mail.grandpacificresorst.com. Instructions here: http://wp.me/pUCB5-l

If #2 is true, then you need to change your Exchange Autodiscover SCP to accurately reflect the server address. http://wp.me/pUCB5-7X has instructions.
0
 
Ryan MignosaAuthor Commented:
Adam,

Both 1+2 are true.

I implemented the SRV record in DNS and I checked the autodiscover SCP.  The SCP was accurate, but the SRV record appears to have fixed my problem.  I've configured a number of outlook clients tested Email Auto-configuration.  I'm not receiving the security alert anymore when previously it happened with every test.  I still have some testing to do with Outlook Anywhere, but right now things look great.

Thank you
0
 
MASTechnical Department HeadCommented:
I believe Adam's comment helped to resolve the issue the same can be done on the article in my post.
0

Featured Post

 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

Tackle projects and never again get stuck behind a technical roadblock.
Join Now