[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 122
  • Last Modified:

VMWare Virtual Machine Loss of Network on Reboot

I am running VMWare 5.5, my windows hosts will periodically on reboot fail to properly setup their network cards.  All the machines are assigned static IP addresses, however on reboot the machine will boot with a 169 IP address, like it it failed to receive DHCP.  Simply rebooting the machine or even just disabling the NIC and re-enabling corrects the issue.

I've seen it happen with all my MS operating systems Windows Server 2008 R2, Windows Server 2012 R2, Windows 7, etc...

Ideas?  This is getting rather annoying.

Thanks in advance!
0
Railroad
Asked:
Railroad
  • 3
  • 2
2 Solutions
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
There is no MAC Address or IP Address conflict ?

Are you using the VMXNET3 interface and VMware Tools installed.
0
 
RailroadAuthor Commented:
There are no IP or MAC conflicts.  Using E1000.  Yes VMware tools are installed.

Guessing I should switch them all to VMXNET3?  What's the best way to do this?

What is the difference?  I always just used the default, which is E1000.

Thanks.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Remove and replace the network interface.

If you switch to DHCP does it get an IP Address ?

E1000 is a legacy interface which should just be used to install the OS, because Microsoft will not include the VMware driver in the OS.

VMXNET3 is a highly virtualized aware adaptor, which also runs at 10GBe, E1000 is an emulated adaptor, which also adds high overhead on the VM.

Best Practice is always to use the VMXNET3 after you've installed VMware Tools which always contains the drivers and software for it.
0
 
RailroadAuthor Commented:
Thank you for the help.  No real way to test until it reboots on its own for updates.
0
 
RailroadAuthor Commented:
So I finally figured this out.  It's a Windows OS issue, adding the below registry key to the system will fix the issue.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
"IPAutoconfigurationEnabled"=dword:00000000

Open in new window

0

Featured Post

 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now