OCS Inventory NG Agent HTTP Status Code 500

Hello,

I recently implemented OCS and can't seem to get the windows agent to communicate with the OCS server.

optional server credentials
I installed OCS on a windows server 2008 r2 box. At the step where I asked for credentials(optional) I have entered all the credentials i have documented. Yet below is the output of the ocsinventory.log file

Starting OCS Inventory NG Agent on Tuesday, August 16, 2016 12:50:08.
AGENT => Running OCS Inventory NG Agent Version 2.1.1.3
AGENT => Using OCS Inventory NG FrameWork Version 2.1.1.3
AGENT => Loading plug-in(s)
AGENT => Using network connection with Communication Server
AGENT => Using Communication Provider <OCS Inventory NG cURL Communication Provider> Version <2.1.1.3>
AGENT => Sending Prolog
ERROR *** AGENT => Failed to send Prolog <HTTP Status Code #500>
AGENT => Unloading communication provider
AGENT => Unloading plug-in(s)
AGENT => Execution duration: 00:00:00.


I have also left the credentials prompt blank. What credentials am I suppose to use here?

I have used the mysql root, web ui user/pass, and ocs db user and password with no luck.

lastly, I modified the ocsinventory.ini file as recommended on their wiki documentation:

Solution: OCS engine can't comunicate with mysql server. Probably due to a wrong mysql account. You have to check z-ocsinventory-server.conf (ocsinventory-server.conf on Windows Server), exactly theses few lines
# Master Database settings
  # Replace localhost by hostname or ip of MySQL server for WRITE
  PerlSetEnv OCS_DB_HOST localhost
  # Replace 3306 by port where running MySQL server, generally 3306
  PerlSetEnv OCS_DB_PORT 3306
  # Name of database
  PerlSetEnv OCS_DB_NAME ocsweb
  PerlSetEnv OCS_DB_LOCAL ocsweb
  # User allowed to connect to database
  PerlSetEnv OCS_DB_USER ocs
  # Password for user
  PerlSetVar OCS_DB_PWD ocs

Modify OCS_DB_USER and OCS_DB_PWD with your own account, restart apache, and finaly launch an inventory.
--


Thanks in advance

t
Robert Perez-CoronaSystems AdministratorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

KaffiendCommented:
Are you using a port other than port 80?  I see that you did not specify a non-default port in the server URL
Robert Perez-CoronaSystems AdministratorAuthor Commented:
using port 80

the image above is a screenshot with the default values. My values look something like..

http://10.30.10.16/ocsinventory

also, I have disabled the firewall on my server.
KaffiendCommented:
Http 500 is a generic error, so that doesn't help much.

Do you see anything in Apache logs?  Also, is the ocs-ng web console working?
Robert Perez-CoronaSystems AdministratorAuthor Commented:
I looked at the ocsinvenroty-server.conf file in the apache logs. not sure if it was the same one i modified or a different one - perhaps the same. but i changed the the mysql ocsweb password and it all works now.

thanks

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Robert Perez-CoronaSystems AdministratorAuthor Commented:
found the issue.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.