Certificate for Exchange 2010

I have a Exchange 2010 setup, mail1.abc.com (CAS / Hub) and mail2.abc.com (Mailbox).  For exchange webmail, it is mail.abc.com. In public DNS, abc.com and www.abc.com is pointed to our website.

For the certificate in Exchange, which name should I only include mail1.abc.com & mail.abc.com. Do I need to include my domain name abc.com in the certificates ?

Thx
AXISHKAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MASEE Solution Guide - Technical Dept HeadCommented:
In your certificate you need only 2 names which is mail.abc.com (common name) and autodiscover.abc.com.
both the A records should be pointed to your CAS server.
Please check my article how to configure this and certificate requirements
https://www.experts-exchange.com/articles/13676/Out-Of-office-not-working.html

This article is for fixing errors. The same can be used in your case.
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AXISHKAuthor Commented:
Try renew the certificate with mail.abc.com and autodiscover.abc.com. After binding it to Exchange and connect Outlook internally, it prompts for the following :
"There is a problem with the proxy server's security certificate"

I have already run those Exchange powershell mentioned and the name has been point to the mail.abc.com.

Any idea what's missing ? Do I really need to include mecmail1 in the certificate files as inside Outlook setting, it is referring both internal name (mail1) and public name (mail).

Thx

Thx
0
MASEE Solution Guide - Technical Dept HeadCommented:
Please post the screenshot.
You dont need internal FQDN in the certificate.

Thanks
MAS
0
AXISHKAuthor Commented:
Apply wizard certificate and fix the problem, Thx
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.