Solved

strange bios behaviour

Posted on 2016-08-18
35
94 Views
Last Modified: 2016-08-28
i have a HP probook 450 works fine with windows 7.
however the client wants windows 10 - so i installed  a  SSD 500 Gb with the windows 7 image on it and proceeded to set up from flash drive.  it started setup but gave the error when you see the drive and partitons: cannot create partition"
so i rebooted - to delete ALL partitions, except HPTOOLS and RECOVERY and all of a sudden it Always booted into HP diagnostics - whatever key you hit during startup
so i deleted the 2 remining partitions  -  still the same problems - it would NOT boot form disk or usb -  i only got in the HP diagnostics

HOwever, when i installed the disk with a windows 7 or windows 10 (that was upgraded from windows 7) i got a normal boot, and could access the bios in the normal way with all keys

so it looks like there is some bios or boot info on the disk - influencing the bios access

does anybody see this?
does anybody know why it happens ?  or how to fix this (other than installing an already bootable drive that is) ?
0
Comment
Question by:nobus
  • 13
  • 11
  • 4
  • +3
35 Comments
 
LVL 6

Expert Comment

by:Luis Moura
ID: 41760684
0
 
LVL 87

Accepted Solution

by:
rindi earned 250 total points
ID: 41760729
It probably has the diagnostic stuff embedded in the BIOS or another chip on the mainboard. Maybe you can turn it off there somewhere. If it can't find any OS on your internal HD it would automatically start the diags from the BIOS.

The reason why you couldn't create partitions during the installation of Windows 10 was probably because you had booted the USB stick in the wrong mode for the disk's setup. If you boot into EFI mode, the disk you install the OS to has to be a GPT disk, if you boot into standard mode, it has to be an MBR disk. So you will have to check what setting the BIOS is at (UEFI or compatible), and also select the correct USB boot device. Depending on your BIOS configuration, you should see your USB stick twice, as a UEFI USB stick, and as just a USB stick, and then you can choose the correct version to boot from.

If your USB stick isn't setup with UEFI boot capabilities, and your BIOS is setup to only boot UEFI, the stick won't show up as an option to boot from.
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 41760797
Was UEFI on or off. I always have UEFI on for Windows 8.1 and 10, but off for Windows 7.
0
 
LVL 91

Author Comment

by:nobus
ID: 41761116
from what it looks like, it seems to be a bios -not UEFI - bu i am not sure
i took some pics  but hey are not very clear
IMG_0310-800.jpg
IMG_0311-800.jpg
IMG_0314-800.jpg
IMG_0315-800.jpg
IMG_0316-800.jpg
0
 
LVL 90

Assisted Solution

by:John Hurst
John Hurst earned 250 total points
ID: 41761123
Picture 314 suggests it is UEFI.

However, when I installed the disk with ... windows 10 (that was upgraded from windows 7

If the Windows 10 was activated, is it worth it to you to reinstall Windows 10 Fresh from the media creation link?
0
 
LVL 87

Assisted Solution

by:rindi
rindi earned 250 total points
ID: 41761139
The only picture where I can see much is the one with the diagnostics, and there it says "HP PC Hardware Diagnostics UEFI", so to me it is UEFI. It is also a modern laptop with a modern CPU, and those all come with UEFI.
0
 
LVL 87

Expert Comment

by:rindi
ID: 41761146
When you upgrade, it uses the same setup that was used in the previous OS. When you do a clean installation by booting from the installation media, it uses the the method it was booted to. So if it used the EFI boot when you booted the USB stick, it will also require a GPT disk, and if you booted the stick in compatible mode, it will want to install to an MBR disk.

A further difference would be if you tried installing the 32bit version of Windows 10. That can only be installed in compatible mode to an MBR disk and not to a system set to UEFI and a GPT disk.
0
 
LVL 91

Author Comment

by:nobus
ID: 41761249
john every time i tried to use the upgraded version, it started complaing about malware detected - even with only windows and office installed, and you could not pin icons to the task bar, etc... it was totally useless -that could come imo from the bad disk it was copied from - but since i did a facory restore, i thought i would be good to go

good info rindi

i'll get my good camera (thes e were taken with an old smartphone
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 41761255
I just upgraded my Client's Windows 10 machine to 14393.51 (Anniversary plus patches) and it did not complain.

that could come IMO from the bad disk it was copied from

That is likely. Try a truly fresh install:  Keep Nothing.
0
 
LVL 46

Expert Comment

by:noxcho
ID: 41762126
I am having similar problem with Panasonic CF-54 Toughbook machine. In my case the USB stick with Windows 10 created with Media Creation Tool shows first progress window of Windows installation and then just a black screen. If I keep on the HDD the originally installed Windows 10 or just Panasonic diagnostic tools - they boot fine. Still researching this behavior.
0
 
LVL 91

Author Comment

by:nobus
ID: 41762291
in case it helps, here the info page of bios
info
i must say that uefi bios is a lot more complicated than BIOS - and NOT AT ALL easy to use
and very different from 1 pc to another...

noxcho - if you find a solution, be sure to post  it ?
0
 
LVL 16

Expert Comment

by:joinaunion
ID: 41764580
So when you select F9 at boot are you saying you can't select your flash drive? It's normal behavior for hp to goto diagnostic screen if there is no os installed(partition)
0
 
LVL 91

Author Comment

by:nobus
ID: 41764824
joinaunion - how do you install windows then on an empty drive from USB ?
0
 
LVL 46

Expert Comment

by:noxcho
ID: 41764880
Interesting, the installation went well from a DVD drive in my case. And booting from USB is still impossible.
0
 
LVL 91

Author Comment

by:nobus
ID: 41765174
0
 
LVL 16

Expert Comment

by:joinaunion
ID: 41765912
You can't if there is no usb boot selection by default in the bios. What are your options when you tap F8 for boot options?
0
 
LVL 91

Author Comment

by:nobus
ID: 41766403
it boots fine from usb joinaunion, it's only AFTER windows install starts it says "cannot create primary partition"
it seems to be missing usb3 drivers in windows setup imo
0
6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

 
LVL 87

Assisted Solution

by:rindi
rindi earned 250 total points
ID: 41766543
You wouldn't get that far if USB3 were a problem. Your problem is because the disk is either GPT, and you booted the USB stick in normal BIOS mode without EFI, or the disk is MBR, and you booted the stick in EFI mode as I mentioned earlier.
0
 
LVL 46

Expert Comment

by:noxcho
ID: 41766561
And if i ts MBR then it has already some partition on that drive which does not allow the installation wizard convert that drive into GPT if  the machine is set in UEFI now.
Erase the drive completely and try to install the OS this way.
0
 
LVL 91

Author Comment

by:nobus
ID: 41766731
Rindi you can be right there :"Your problem is because the disk is either GPT, and you booted the USB stick in normal BIOS mode without EFI, or the disk is MBR, and you booted the stick in EFI mode as I mentioned earlier. "
i must say i did not lookup the disk format, GPT or MBR

can you tell me how to change the bios setting  for the stick  -or where to look?
that would be helpful

noxcho  - i already did a fresh install; i made a cd from the MCT -and used that
i don't know why that does work on the system, and booting from usb does not though

still many things unclear to me, i'm afraid - but willing to learn
0
 
LVL 87

Expert Comment

by:rindi
ID: 41766755
I have no idea what your BIOS looks like. But I have a PC with an ASUS board that is UEFI, and there in the BIOS I select Advanced, then Boot. And there I have a CSM (Compatibility Support Module) mode which I have enabled. I also have Boot Option Priorities, where I can select what can be booted from. There I can see all the options I can boot from, and if you have a USB device connected that can be booted from either normal or UEFI, you'll see it listed twice, once just as the USB stick, the other it includes UEFI.

I also see the 2 selections when I startup into the BIOS, and then I can drag the one with "UEFI" to the front.

Your laptop BIOS is probably a little different, but it should still have ways of selecting the proper option.

Besides that if you are booting from a USB stick, it has to have been setup properly first. For example if it is formatted in NTFS, UEFI setup won't work. It has to be FAT32.
0
 
LVL 46

Expert Comment

by:noxcho
ID: 41766915
nobus, remember I have had a question concerning multiboot USB stick problem? I wanted to create a multiboot USB stick which would allow me installing different Windows OS from the same stick. And guess what - I cannot. Exactly the same driver problem like yours. I could install only if I create the USB stick with Media Creation Tool for Windows 7. And this was not easy to repeat.
From DVD - it worked always ok. Something is in how the USB stick is created.
0
 
LVL 87

Expert Comment

by:rindi
ID: 41766932
If you use WinSetupFromUSB it is easy to create a USB stick or Disk to boot several OS's. I have one with Windows 7, Windows 10 64 bit and 32 bit (The Windows 7 iso is already a combination of 32 bit and 64 bit), several different tools like paragon backup and recovery, partition manager, rescue kit, and several different Linux Distro's, and the UBCD on it. Since I formatted it in FAT32 (again via WinSetupFromUSB) I get the UEFI and normal options when booting it on a UEFI PC.

http://www.winsetupfromusb.com/
0
 
LVL 91

Author Comment

by:nobus
ID: 41767045
well i'm not sure i have a stick in Fat 32, and one in NTFS

btw - how can icheck if the disk is GPT or mbr?  disk manager shows ntfs partitions
0
 
LVL 87

Expert Comment

by:rindi
ID: 41767066
In diskmanagement right click the disk (not any of the partitions) and select "Properties". Then click on the "Volumes" tab, and in Partition style you will either see "GUID partition Table (GPT)", or "Master Boot Record (MBR)".
0
 
LVL 91

Author Comment

by:nobus
ID: 41767280
nice to know that Rindi
i wonder why it does not show directly in disk management - seems a bit hidden, right?
0
 
LVL 87

Expert Comment

by:rindi
ID: 41767396
Most people don't need to know, or it would just confuse them.
0
 
LVL 91

Author Comment

by:nobus
ID: 41768234
so -i'll resume :
-make the usb3 stick FAT32 - not NTFS
-be sure to look up if didk is GPT - or MBR
-if GPT  - boot in UEFI mode
- if MBR - compatible or MBR mode

is it necessary to use winsetup from usb?  or will other tools doit as well (eg YUMI)

***i wonder why the setup does not check that - or inform you of it; instead it gives out strange errors, like "cannot create primary partition"
0
 
LVL 87

Expert Comment

by:rindi
ID: 41768312
Yes, yes, yes, yes. Besides that, boot the stick using a USB2 port on the PC.

I have only used WinSetupFromUSB. The other tools I haven't used. But WinSetupFromUSB has a big advantage, if an iso file is larger than 4GB, it will automatically split it so it still fits onto the FAT32 file-system. I doubt any of the other tools can do that.
0
 
LVL 91

Author Comment

by:nobus
ID: 41768552
ah so it may never work from an USB 3 port - meaning there is the usb 3 driver missing
in windows install, or from the mobo?
0
 
LVL 87

Expert Comment

by:rindi
ID: 41768578
You'd have to inject the USB3 drivers into install.wim and boot.wim files of your Windows iso. Intel has a tool which can be used to do this for their nuc systems (I think you are participating in a Question here where someone is trying that), but that would only help for those particular drivers. For any others you'd have to do this manually. The link below explains how it is done for Windows 7 iso's, but it would be the same with Windows 10:

http://winaero.com/blog/how-to-install-windows-7-on-a-pc-with-only-usb-3-0-ports/

With some BIOS's you can switch USB3 to legacy USB2 mode. Then you should also be able to install the OS if you only have USB3 ports on the PC.
0
 
LVL 91

Author Comment

by:nobus
ID: 41768872
would that be something like their creator utility ?
https://downloadcenter.intel.com/download/25476/Windows-7-USB-3-0-Creator-Utility

anyhow - made a note of your link
0
 
LVL 87

Expert Comment

by:rindi
ID: 41768899
Yes.
0
 
LVL 91

Author Closing Comment

by:nobus
ID: 41773458
tx everybody for the help
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 41773662
I am always very happy to work with you.
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

If you get continual lockouts after changing your Active Directory password, there are several possible reasons.  Two of the most common are using other devices to access your email and stored passwords in the credential manager of windows.
In this article, I will show you HOW TO: Perform a Physical to Virtual (P2V) Conversion the easy way from a computer backup (image).
The viewer will learn how to successfully download and install the SARDU utility on Windows 7, without downloading adware.
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now