Tileserver -php install error

I have attempted to follow the instructions (via https://www.youtube.com/watch?v=F6MvDvc5m-I) to install TileServer -php on IIS8.

However, when go to tileserver.php I get an error message indicating that there is an error with the 'metadata.json' file. The only reference I can find for the metadata structure is: https://docs.puppet.com/puppet/latest/reference/modules_metadata.html

I'm confused as to why this wouldn't be included in the ZIP package? Also, I noticed in the video that the address loaded is tileserver.domain.com. If a sub-domain or rewrite/direct is necessary (yet not discussed in the video) this is an area I'm not familiar with (just trying to look for hints at a way forward).

Any insight would be appreciated.

Regards,
Christopher SmithAsked:
Who is Participating?
 
Christopher SmithAuthor Commented:
Hello,

I am confirming PHP is installed and operational.

For some reason when I rebooted, the error message is no longer appearing. It was something akin to "metadata.json file not specified or found - check your server settings". However, now the page loads, but only text (see attached) and not the complete page as shown in the tutorial.
Maps-hosted-with-TileServer-php-v2.0.png
0
 
Dan McFaddenSystems EngineerCommented:
Can you post the actual error you are receiving?

Also, can you verify that PHP is installed and functioning correctly?

Dan
0
 
Christopher SmithAuthor Commented:
Small directory issue.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.