Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Exch 2010 database won't mount after power outage

Posted on 2016-08-20
7
Medium Priority
?
130 Views
Last Modified: 2016-08-21
SBS 2011 server.

Problem getting the database mounted.  When starting the IS, it states that not all the log files are present:
"Information Store (9880) Mailbox Database: Database C:\Program Files\Microsoft\Exchange Server\V14\Mailbox\Mailbox Database\Mailbox Database.edb requires logfiles 362190-362212 in order to recover successfully. Recovery could only locate logfiles starting at 362192."

Looking at the log files (and converting decimal to hex), it seems all the log files ARE present from 362190-362211.  362212 is missing. I'm not sure why it says log files were found starting at 362192 because 190 and 191 are there.

I do have a Windows Server Backup from the night before, but I'm not wanting to lose an entire days worth of email.  

There is also "Previous versions" of the "Mailbox Database" folder that was created at noon yesterday, just minutes before the power outage.  Would just replacing the current Mailbox Database folder with the one from Previous Versions (shadow copies?) and starting the Information Store work or is there more than that to it?

What is the best way to repair this, using all the log files that are present?   I'm NOT an Exchange expert so please explain things with some level of detail.  :)

Thanks for anyone's help on this.

UPDATE:  I did an EDEUTIL /MH to get the status...see below.  It says it needs certain log files, and all the log files ARE present.  I then tried ESEUTIL /R /L /D (using the paths to the current log files), and terminated immediately saying it could not find the log files.  What's the deal?  All the log files are right there in the Mailbox Database folder.  Why can't it see them?

Extensible Storage Engine Utilities for Microsoft(R) Exchange Server
Version 14.01
Copyright (C) Microsoft Corporation. All Rights Reserved.

Initiating FILE DUMP mode...
         Database: Mailbox Database.edb


DATABASE HEADER:
Checksum Information:
Expected Checksum: 0x13779f27
  Actual Checksum: 0x13779f27

Fields:
        File Type: Database
         Checksum: 0x13779f27
   Format ulMagic: 0x89abcdef
   Engine ulMagic: 0x89abcdef
 Format ulVersion: 0x620,17
 Engine ulVersion: 0x620,17
Created ulVersion: 0x620,17
     DB Signature: Create time:06/02/2011 16:30:26 Rand:1595930 Computer:
         cbDbPage: 32768
           dbtime: 309061513 (0x126be789)
            State: Dirty Shutdown
     Log Required: 362190-362211 (0x586ce-0x586e3)
    Log Committed: 0-362212 (0x0-0x586e4)
   Log Recovering: 0 (0x0)
  GenMax Creation: 08/19/2016 12:02:51
         Shadowed: Yes
       Last Objid: 7705
     Scrub Dbtime: 0 (0x0)
       Scrub Date: 00/00/1900 00:00:00
     Repair Count: 0
      Repair Date: 00/00/1900 00:00:00
 Old Repair Count: 0
  Last Consistent: (0x55B81,8,1F)  08/01/2016 14:11:40
      Last Attach: (0x55B82,9,86)  08/01/2016 14:11:40
      Last Detach: (0x0,0,0)  00/00/1900 00:00:00
             Dbid: 1
    Log Signature: Create time:06/02/2011 16:30:24 Rand:1614054 Computer:
       OS Version: (6.1.7600 SP 0 NLS ffffffff.ffffffff)

Previous Full Backup:
        Log Gen: 361881-361901 (0x58599-0x585ad) - OSSnapshot
           Mark: (0x585AE,8,16)
           Mark: 08/18/2016 23:00:16

Previous Incremental Backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

Previous Copy Backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

Previous Differential Backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

Current Full Backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

Current Shadow copy backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

     cpgUpgrade55Format: 0
    cpgUpgradeFreePages: 0
cpgUpgradeSpaceMapPages: 0

       ECC Fix Success Count: none
   Old ECC Fix Success Count: none
         ECC Fix Error Count: none
     Old ECC Fix Error Count: none
    Bad Checksum Error Count: none
Old bad Checksum Error Count: none

  Last checksum finish Date: 00/00/1900 00:00:00
Current checksum start Date: 00/00/1900 00:00:00
      Current checksum page: 0


Operation completed successfully in 0.16 seconds.
0
Comment
Question by:Darryl Mylrea
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
7 Comments
 

Author Comment

by:Darryl Mylrea
ID: 41763677
UPDATE2:  

I moved the log files it says were required to another folder, and ran ESEUTIL /ML on them and they showed ALL OK.  I then attempted a soft recovery pointing to the folder of the copied log files and got a checksum error:


Extensible Storage Engine Utilities for Microsoft(R) Exchange Server
Version 14.01
Copyright (C) Microsoft Corporation. All Rights Reserved.

Initiating RECOVERY mode...
    Logfile base name: E00
            Log files: C:\Program Files\Microsoft\Exchange Server\V14\Mailbox\Mailbox Database\COPIES
         System files: C:\Program Files\Microsoft\Exchange Server\V14\Mailbox\Mailbox Database\COPIES
   Database Directory: C:\Program Files\Microsoft\Exchange Server\V14\Mailbox\Mailbox Database

Performing soft recovery...
                      Restore Status (% complete)

          0    10   20   30   40   50   60   70   80   90  100
          |----|----|----|----|----|----|----|----|----|----|
          .X



Operation terminated with error -1018 (JET_errReadVerifyFailure, Checksum error on a database page) after 0.47 seconds.


Is the database file corrupted?  I did use the /s parameter and pointed to the COPIES folder so that it would NOT use the existing E00.chk file as some say that can throw odd errors.

Is it easier just to take the shadow copy of the Mailbox Database folder (includes all the log files and the database store file) from noon (minutes before the outage) and use that to replace the existing one and try to mount the store?  Do I need to do anything before that?
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 41763721
Are you saying that you have a Windows created Volume Shadow Copy?  I don't know if that would work at all if it wasn't backed up using a VSS aware backup application.

Also, you can't just mount a backup database as the primary one -- it would have to be done as a mounted in a recovery store.  You would need to use Windows Backup to do the restore.

More info here:  http://mikepfeiffer.net/2011/07/restoring-mailbox-data-from-a-recovery-database-in-exchange-2010-sp1/
0
 

Author Comment

by:Darryl Mylrea
ID: 41763723
I do use WIndows Server backup, and there was a successful backup the night before.  I'm trying to use that last as we would lose a whole days worth of email.

Why would a shadow copy of the Mailbox folder be a "backup database"?  Isn't it a snapshot in time of the folder?  Since the snapshot is at 12 noon and power went out shortly after that, It seemed logical that if I replace the mailbox store folder and restart services, it would start back up just as if it were noon yesterday.
0
Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 41763746
it would seem logical, if there weren't the very high probability that during those few minutes between when the copy was made and the power went off there were a few hundred changes to the database (or even 2 or 3 changes).

But this is why you have transaction logs.  You can restore last nights backup and then replay the logs with ESEUTIL to bring it up-to-date.

See how here:  https://demazter.wordpress.com/2010/04/29/mailbox-recovery-exchange-2010/
0
 

Author Comment

by:Darryl Mylrea
ID: 41763757
Not concerned with what happened between when the snapshot was saved and when the power went out.  Maybe 1 or 2 or even no new emails.  It's a small office of a handful of employees.

If I stop the services, rename the mailbox database folder and copy the shadow copy version of the folder into place, then restart services, should exchange look like it did at noon yesterday?

I did not do last nights backup since the store was dismounted.
0
 
LVL 27

Accepted Solution

by:
MAS earned 2000 total points
ID: 41763854
Hi,
Please check your database state first.
eseutil /mh “D:\mailboxdatabase\mailboxdatabase.edb”

Open in new window


If the state is dirty shutdown please try to do a soft repair.
Eseutil /r "E00" /l “D:\mailboxdatabase” /d “D:\mailboxdatabase

Open in new window


If that also fails do a hard repair.
eseutil /p “D:\mailboxdatabase\mailboxdatabase.edb”

Open in new window

Note: You will have data loss with hard repair

Check this for details
http://alexvoropaev.jimdo.com/my-articles/exchange/repair-exchange-db-after-dirty-shutdown/

Thanks
MAS
1
 

Author Closing Comment

by:Darryl Mylrea
ID: 41764569
Thank you for your help.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will help to fix the below errors for MS Exchange Server 2013 I. Certificate error "name on the security certificate is invalid or does not match the name of the site" II. Out of Office not working III. Make Internal URLs and Externa…
I don't pretend to be an expert at this, but I have found a few things that are useful. I hope that sharing them here will help others, so they will not have to face some rather hard choices. Since I felt this to be a topic of enough importance and…
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
Suggested Courses

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question