[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2090
  • Last Modified:

Your computer can't connect to the remote computer because your computer or device did not pass the Network Access Protection requirements set by your network administrator.

Hello,

We are running Windows 2012R2.  A few users access their Office PC's from home using the Remote Web Workspace feature.  

Suddenly, this feature is no longer working.  I am also unable to access the server using this feature as the Administrator.

The error message is:
Remote Desktop Connection
Your Computer can't connect to the remote computer because your computer or device did not pass the Network Access Protection requirements set by your network administrator.  Contact your network administrator for assistance.

I have tried this connection from and to various workstations with the same results.  

This is the first time I have encountered this message and am unsure as to how to troubleshoot effectively.  No changes have been recently made.  SSL certificate was renewed a few weeks prior to the issue manifesting.

Any recommendations on how to address would be appreciated.

Thanks in advance.

Regards,
Real-Timer
0
realtimer
Asked:
realtimer
  • 3
  • 3
2 Solutions
 
harryhelpCommented:
Hi,

Have you installed the certificate on the RD Gateway? (you will get this option in the RD Gateway manager)

You can see more info at:
http://serverfault.com/questions/653066/remote-desktop-network-access-protection-issue
0
 
realtimerAuthor Commented:
Thanks - I've checked the instructions but they don't jive.  Different options in SBS 2012 Essentials?
0
 
harryhelpCommented:
Sorry but I typically use Standard/Datacenter. In administrative tools do you see Network Policy Server? If you could send a screenshot of the administrative tools folder, that would be helpful.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
realtimerAuthor Commented:
HarryHelp - your response was correct.

In Windows Essentials, the RD Gateway Manager is not available by default.  It can be made available by running the following command with Admin privileges:
dism /online /Enable-Feature:Gateway-UI

After having done so - I was able to access the UI to install the certificate, and all is working as needed.

Thank you very much!!

Regards,
Rudy
0
 
realtimerAuthor Commented:
Thank you very much for your suggestions!!
0
 
harryhelpCommented:
Glad to hear it's all sorted :-)
0

Featured Post

Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now