NTP Server in VMware

I have configured NTP in VMware vSphere 6. all setting are done as per the guidelines but still that doesn't work. The time showing in "configuration- Time " as in red color. The server is set up in US time zone. When I set up NTP and apply changes it wont take time from NTP server.

when I telnet to the console of the host and type the date : it shows the UTC time - ex. Tue Aug 23 01:41:05 UTC where as the time zone set in server is 7:12 AM.  

The problem I am facing is when ever I reboot the guest machines, it automatically take the UTC time zone from host and I have to change manually. even after I manually set the time in configuration- time menu [ without configuring ntp] it will take UTC time only.

Please help

Sunny
Sunny SebastianAsked:
Who is Participating?
 
Andrew Hancock (VMware vExpert / EE MVE^2)Connect With a Mentor VMware and Virtualization ConsultantCommented:
The reasons it displays in RED, is because there is a difference between Client Time and ESXi host time.

So the computer that is running the Client, has a different time to host.

NTP does NOT recognise time zones. it just syncs the minutes and seconds, but if your host is too far off, it will not sync at all.
0
 
Sunny SebastianAuthor Commented:
Andrew,

First of all thanks for your reply. I used to read many of your VMware suggestions and resolutions and achieved the result as well. I value your comments a lot.

OK what I am saying, as I know ESXi host always will take time UTC. If I set the time from time configuration menu, that will not reflect the time in EXSi host OS - unix. so when I console the host using SSH, and type date, I get a different time - always 5.30 hours behind the UTC. Importantly, when ever client reboots, it take this time by default by passing the time I set manually in "Configuration - Time setting'. I read from your topics and other VMware forums that we can set up NTP services where the host get time sync from a NTP server.

I have two VMs setup in different geographical region. I have configured both ESXi hosts for NTP servers and one get proper response and clearly getting the time from NTP server and a reboot does not change the time for client. Other Exsi set up in US has the problem where it did not get time frm NTP server. I am looking to resolve this problem as my production server time change make huge impact.

Thanks Sunny
0
 
Gary PattersonVP Technology / Senior Consultant Commented:
While it is possible for guests to sync time with the ESXi host, it is not the best practice.  

Best practice, and the one recommended by VMWare, is to set up ESXi hosts and guests to obtain time as NTP clients, and disable VMWare Tools time sync.

Native time synchronization software, such as Network Time Protocol (NTP), is typically more accurate than VMware Tools periodic time synchronization and is therefore preferred. You can use only one form of periodic time synchronization in the vCenter Server Appliance. If you decide to use native time synchronization software, vCenter Server Appliance VMware Tools periodic time synchronization is disabled, and the reverse.

http://pubs.vmware.com/vsphere-60/index.jsp#com.vmware.vsphere.vcsa.doc/GUID-6C202AED-91DE-4D20-B95D-0A71D101312C.html

Example recommended NTP configuration:

External NTP server (pool.ntp.org) provides time to
Your internal NTP server(s) (NTP client and server) provides time to
ESXi host (NTP client)
Guest1 (NTP client)
Guest2 (NTP client)

One recommended configurations uses Cisco IOS routers (or other network edge devices capable of being both an NTP client and server) as the internal NTP server.  In a Windows environment, configure domain controllers as NTP servers (time sync is needed for Kerberos with AD anyway).

Regardless of the design, internal time servers should be redundant and highly available, since they are critical infrastructure.

Goal is to reduce the amount of NTP traffic across the Internet connection, and reduce the load on public NTP servers.

Time zones are then configured on each guest per guest operating system mechanisms.
1
 
Sunny SebastianAuthor Commented:
OK thanks for the article
0
 
frankhelkCommented:
Just to mention: I've written an article about NTP, which might be helpful, too.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.