Solved

Asa VPN Site to Site enable local internet access

Posted on 2016-08-23
4
70 Views
Last Modified: 2016-08-23
Hello experts.
I am new in networking and firewall.
I set up a site to site VPN between 2 Asa 5520. The VPN is working fine and I can access the remote network.
On the second location, the users are not able to browse the web using their local internet connection.
By the concept I think I need to create an access list and assign it to the crypto map but being absolute new to cisco command line I don't know what to do in order to enable the local internet access.
Can anyone, looking at my running configuration, can give me the necessary steps to configure it?

Thanks in advance.

Site A subnet: 192.168.1.0 255.255.255.0
Site A public ip address: 81.150.32.28 (not the real one)

Site A subnet: 192.168.2.0 255.255.255.0
Site A public ip address: 87.81.187.10 (not the real one)


Running Configuration:

Result of the command: "show running-conf"

: Saved
: 
: Serial Number: JMX1243L0Y5
: Hardware:   ASA5520, 3072 MB RAM, CPU Pentium 4 Celeron 2000 MHz
:
ASA Version 9.1(7)4 
!
hostname FIREWALL-02
domain-name exceteragroup.com
enable password n9CBFepzIuUJLxm4 encrypted
names
!
interface GigabitEthernet0/0
 nameif Outside
 security-level 0
 ip address 10.0.0.1 255.255.255.0 
!
interface GigabitEthernet0/1
 nameif Inside
 security-level 100
 ip address 192.168.2.1 255.255.255.0 
!
interface GigabitEthernet0/2
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 management-only
 nameif management
 security-level 100
 ip address 192.168.0.1 255.255.255.0 
!
ftp mode passive
dns domain-lookup Inside
dns server-group DefaultDNS
 name-server 8.8.8.8
 name-server 8.8.4.4
 domain-name exceteragroup.com
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object network internal-lan
 subnet 192.168.1.0 255.255.255.0
object network NETWORK_OBJ_10.0.0.0_24
 subnet 10.0.0.0 255.255.255.0
object network NETWORK_OBJ_192.168.1.0_24
 subnet 192.168.1.0 255.255.255.0
object network NETWORK_OBJ_192.169.1.0_24
 subnet 192.169.1.0 255.255.255.0
object network management
 host 192.168.1.2
object network management-ip
 host 192.168.1.2
object network management-lan
 host 192.168.0.1
object network management-lan-10
 host 192.168.0.1
object network test
 host 192.168.1.77
object network SiteA-Subnet
 subnet 192.168.1.0 255.255.255.0
object network SiteB-Subnet
 subnet 192.168.2.0 255.255.255.0
object network SiteB-Firewall
 host 87.81.197.10
object network SiteA-Firewall
 host 81.150.42.25
access-list Outside_cryptomap extended permit ip 192.169.1.0 255.255.255.0 192.169.1.0 255.255.255.0 
access-list Outside_cryptomap_1 extended permit ip object SiteB-Subnet object SiteA-Subnet 
access-list Inside_access_in extended permit ip object SiteB-Subnet any 
pager lines 24
logging asdm informational
mtu management 1500
mtu Inside 1500
mtu Outside 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
nat (Inside,Outside) source static NETWORK_OBJ_192.168.1.0_24 NETWORK_OBJ_192.168.1.0_24 destination static NETWORK_OBJ_10.0.0.0_24 NETWORK_OBJ_10.0.0.0_24 no-proxy-arp route-lookup
nat (Inside,Outside) source static NETWORK_OBJ_192.169.1.0_24 NETWORK_OBJ_192.169.1.0_24 destination static NETWORK_OBJ_192.169.1.0_24 NETWORK_OBJ_192.169.1.0_24 no-proxy-arp route-lookup
nat (Inside,Outside) source static SiteB-Subnet SiteB-Subnet destination static SiteA-Subnet SiteA-Subnet no-proxy-arp route-lookup
!
object network internal-lan
 nat (any,Outside) dynamic interface
access-group Inside_access_in in interface Inside control-plane
route Outside 0.0.0.0 0.0.0.0 10.0.0.254 1 
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 192.168.0.0 255.255.255.0 management
no snmp-server location
no snmp-server contact
crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANS esp-aes esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-128-MD5-TRANS esp-aes esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-128-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-192-SHA-TRANS esp-aes-192 esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-192-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-192-MD5-TRANS esp-aes-192 esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-192-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-256-SHA-TRANS esp-aes-256 esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-256-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-256-MD5-TRANS esp-aes-256 esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-256-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANS esp-3des esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-3DES-MD5-TRANS esp-3des esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-3DES-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-DES-SHA-TRANS esp-des esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-DES-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-DES-MD5-TRANS esp-des esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-DES-MD5-TRANS mode transport
crypto ipsec ikev2 ipsec-proposal DES
 protocol esp encryption des
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal 3DES
 protocol esp encryption 3des
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES
 protocol esp encryption aes
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES192
 protocol esp encryption aes-192
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES256
 protocol esp encryption aes-256
 protocol esp integrity sha-1 md5
crypto ipsec security-association pmtu-aging infinite
crypto map Outside_map 1 match address Outside_cryptomap_1
crypto map Outside_map 1 set peer 81.150.42.25 
crypto map Outside_map 1 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map Outside_map 1 set ikev2 ipsec-proposal DES 3DES AES AES192 AES256
crypto map Outside_map interface Outside
crypto ca trustpool policy
crypto ikev2 policy 1
 encryption aes-256
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 10
 encryption aes-192
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 20
 encryption aes
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 30
 encryption 3des
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 40
 encryption des
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 enable Outside
crypto ikev1 enable Outside
crypto ikev1 policy 10
 authentication crack
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 20
 authentication rsa-sig
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 30
 authentication pre-share
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 40
 authentication crack
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 50
 authentication rsa-sig
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 60
 authentication pre-share
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 70
 authentication crack
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 80
 authentication rsa-sig
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 90
 authentication pre-share
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 100
 authentication crack
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 110
 authentication rsa-sig
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 120
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 130
 authentication crack
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 140
 authentication rsa-sig
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 150
 authentication pre-share
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 65535
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh stricthostkeycheck
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0
management-access Inside
dhcpd address 192.168.2.100-192.168.2.150 Inside
dhcpd dns 8.8.8.8 8.8.4.4 interface Inside
dhcpd enable Inside
!
threat-detection basic-threat
threat-detection statistics port
threat-detection statistics protocol
threat-detection statistics access-list
threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
webvpn
 anyconnect-essentials
 cache
  disable
group-policy GroupPolicy_81.150.42.25 internal
group-policy GroupPolicy_81.150.42.25 attributes
 vpn-tunnel-protocol ikev1 ikev2 
tunnel-group 81.150.42.25 type ipsec-l2l
tunnel-group 81.150.42.25 general-attributes
 default-group-policy GroupPolicy_81.150.42.25
tunnel-group 81.150.42.25 ipsec-attributes
 ikev1 pre-shared-key *****
 ikev2 remote-authentication pre-shared-key *****
 ikev2 local-authentication pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect sip  
  inspect netbios 
  inspect tftp 
  inspect ip-options 
!
service-policy global_policy global
prompt hostname context 
no call-SiteB reporting anonymous
hpm topN enable
Cryptochecksum:95579f597a37548d8d6452d4a91659b3
: end

Open in new window

0
Comment
Question by:xtremereality
  • 2
  • 2
4 Comments
 
LVL 13

Expert Comment

by:SIM50
ID: 41767559
object network internal-lan
 subnet 192.168.1.0 255.255.255.0
 nat (any,Outside) dynamic interface

object network SiteB-Subnet
 subnet 192.168.2.0 255.255.255.0

access-list Inside_access_in extended permit ip object SiteB-Subnet any

Is this how it is on the ASA? Or did you mix it up when you did editing? Depending what site it is, you need to fix either NAT or ACL.
0
 

Author Comment

by:xtremereality
ID: 41767638
Hi SIM,
This is what is running on the ASA on site B.
0
 
LVL 13

Accepted Solution

by:
SIM50 earned 500 total points
ID: 41767661
If this is site B then NAT change below should fix it.

conf t
object network internal-lan
no nat (any,Outside) dynamic interface
!
object network SiteB-Subnet
 subnet 192.168.2.0 255.255.255.0
nat (Inside,Outside) dynamic interface
!
wr

But I am confused by these lines then on site B. It looks like it belongs on site A since 192.168.1.0/24 is object network SiteA-Subnet.
Plus 10.0.0.0/24 is where your external interface is.
What are you trying to accomplish here?

nat (Inside,Outside) source static NETWORK_OBJ_192.168.1.0_24 NETWORK_OBJ_192.168.1.0_24 destination static NETWORK_OBJ_10.0.0.0_24 NETWORK_OBJ_10.0.0.0_24 no-proxy-arp route-lookup

This looks like a typo in the second octet - 192.169.1.0.
nat (Inside,Outside) source static NETWORK_OBJ_192.169.1.0_24 NETWORK_OBJ_192.169.1.0_24 destination static NETWORK_OBJ_192.169.1.0_24 NETWORK_OBJ_192.169.1.0_24 no-proxy-arp route-lookup
0
 

Author Closing Comment

by:xtremereality
ID: 41767682
Thanks Sim,
this did the trick, I now have to delete a bit of mess I've created trying to solve this issue by myself.
Thanks a lot
0

Featured Post

Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

Join & Write a Comment

Suggested Solutions

This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
Use of TCL script on Cisco devices:  - create file and merge it with running configuration to apply configuration changes
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now