RDS 2008 R2 File Type Associations

I am trying to push file type associations for .TIFs, depending on user group. This is being attempted on a Windows Server 2008 R2 RDS server.

I am using GPP  > Control Panel > Folder Options > Open With preferences. I am using two entries with item-level targeting (one for "is in <groupname>", one for "is not in <groupname>") to apply one of the two entries to the user's preferences.

At first was having an issue with "Access is denied" showing up in the event log, when the system was attempting to apply the preference. The issue ended up being a "UserChoice" key in the HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.tif key. I created another GPP to delete the UserChoice key, inside the .TIF key. This dealt with the "access is denied" issue.

I can now see the GPP changing the "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.tif\OpenWithList\MRUList" value to reflect the preference specified, whenever I do a gpupdate. The problem is that as soon as I double-click on a TIF, explorer.exe modifies the OpenWithList key and it's values, so that the 'system default' viewer for TIFs takes back over. I've tried resetting the system default viewer, and that just changes which program overrides my preferences.

I imagine an HKLM value is overriding the HKCU value, but I have no idea which values are override my preferences, and how to keep them from doing so. I would appreciate any sugguestions.
ccaosupportAsked:
Who is Participating?
 
ccaosupportConnect With a Mentor Author Commented:
I ended up going with registry preferences and manually recreating both the UserChoice key and value, as well as the HKCU\Software\Classes\Application entries for the programs selected. Once I started putting out the UserChoice key and value, the OS started respecting the setting. Abandoning attempts to use GPP "Folder Options".
0
 
ccaosupportAuthor Commented:
Here's a picture of the .TIF OpenWithList extension key just after a gpupdate:

The key before double-clicking a TIF
Here's a picture of the .TIF OpenWithList key just after double-clicking a TIF:

The key after double-clicking a TIF
0
 
yo_beeDirector of Information TechnologyCommented:
I would recommend using Group Policy Preferences to accomplish this.
I have tried the registry approach and never had success.  

Here are the steps:
Step 1: Either add to an exist GPO or create a new one.
Step 2: Open GPO  User Configuration > Preferences > Control Panel Settings > Folder Options
Step 3: Right Click Folder Options > New > OpenWith
 img1Step 4: Configure the new object
Add ext  (e.g. TIF)
Add application
Set to the default (optional)
img2Step 5: Click on the Common Tab and select "Run in logged-on user's Security"
img3Step 6: Set Item Level Targeting (Optional)
img4img5Here is my registry setting after applying.
img6
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
ccaosupportAuthor Commented:
If you read the entire original post, you will see this is already the method I am attempting, that is thus far unsuccessful.
0
 
yo_beeDirector of Information TechnologyCommented:
Glad you were able to get this to work.
I am sorry about the posting.  I am one that normally gets frustrated with people the reply and do not read the entirety of the question as well as all responses.
0
 
ccaosupportAuthor Commented:
Ended up resolving the issue myself, after I decided to abandon my attempts to use GPP Folder Options.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.