• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 95
  • Last Modified:

SQL Connect to Server error.

I just installed SQL Server 2012 and configured it on a server. From the local server, I can connect. However, using SSMS from another server, I cannot connect to the SQL Server I created. I get the error below.

2016-08-23_14-10-24.png
Being that my background is not to strong in SQL, is there anything I can check to troubleshoot this? Do anything need to be looked at from the Network side of things? If so, I can bring it to the attention of my network team. I can ping the new SQL server from the machine I am using SSMS from. I created the SQL server to run in mixed mode. I tried both Windows and SA account but to no avail. Tried by IP and hostname as well.
0
joukiejouk
Asked:
joukiejouk
3 Solutions
 
Brian CroweDatabase AdministratorCommented:
Start by checking the Windows firewall settings on the server that you installed the SQL Server instance on.  Turn off the firewall and see if that helps.  If it does then turn the firewall back on (assuming you want it) and add a rule to allow port 1433 traffic.
0
 
pcelbaCommented:
Execute sp_configure on the SQL Server locally and check the value of "remote access".

If you see 0 as the run_value then issue following instructions:

sp_configure 'remote access', 1
RECONFIGURE

More info: https://msdn.microsoft.com/en-us/library/ms188787.aspx

If you've installed SQL Server as a named instance then you should use both IP address and instance name in the login dialog, e.g.

10.10.10.10\MySQLServer

Windows authentication is OK for domain users. If you don't have domain then create SQL users on the SQL server. Connecting as SA remotely requires another config setting (remote admin connections) but it is not recommended.
0
 
joukiejoukAuthor Commented:
Is there any way I can check from the SQL GUI?
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Anthony PerkinsCommented:
Unfortunately  until you enable TCP/IP you will not be able to use a remote server.  Let me know if you need help with that.
0
 
pcelbaCommented:
What is SQL GUI?

Check it from the SSMS installed on the same machine where the SQL Server is running.
You may use another tool which allows to connect SQL Server locally. BUT if remote access is not enabled you have to do it locally.

You may also follow steps described here: https://support.rackspace.com/how-to/configuring-ms-sql-server-for-remote-access/
and here: http://jeffreypalermo.com/blog/how-to-configure-sql-server-2012-for-remote-network-connections/
0
 
joukiejoukAuthor Commented:
I took the following steps to configure the SQL server, and it seems to work. Here are the steps.

1. Enabled TCP/IP
2016-08-23_21-32-47.png
2. In SQL Server Configuration Manager, I input 1433 for all TCP Port in TCP/IP Properties
2016-08-23_21-27-55.png
3. Most importantly, it did not work until I followed the article: http://jeffreypalermo.com/blog/how-to-configure-sql-server-2012-for-remote-network-connections/ , which was to create a Program rule in Inbound  for the firewall.

You guys are the reason why EE is the best IT resource forum! You guys rock!
1

Featured Post

Become an Android App Developer

Ready to kick start your career in 2018? Learn how to build an Android app in January’s Course of the Month and open the door to new opportunities.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now