Solved

Cisco Routing / Question on LACP

Posted on 2016-08-24
14
100 Views
Last Modified: 2016-08-25
Hello Experts,

Can someone please take a look at my the configuration on my DLSW's 4 & 5 and let me know why DLSW-5 can't ping 172.16.1.1 or DLSW-4, can't ping 172.16.1.2

The interfaces are up and channeling is working fine, see below:

dlsw-4#show ip int brie
Interface              IP-Address      OK? Method Status                Protocol
Ethernet0/0            unassigned      YES manual up                    up      
Ethernet0/1            unassigned      YES manual up                    up      
Ethernet0/2            unassigned      YES unset  up                    up      
Ethernet0/3            unassigned      YES unset  administratively down down    
Ethernet1/0            unassigned      YES unset  administratively down down    
Ethernet1/1            unassigned      YES unset  administratively down down    
Ethernet1/2            unassigned      YES unset  administratively down down    
Ethernet1/3            unassigned      YES unset  administratively down down    
Port-channel1          172.16.1.1      YES manual up                    up      
Vlan1                  unassigned      YES unset  administratively down down    
Vlan100                100.1.1.1       YES manual up                    up      

dlsw-5#show ip int brie
Interface              IP-Address      OK? Method Status                Protocol
Ethernet0/0            unassigned      YES manual up                    up      
Ethernet0/1            unassigned      YES manual up                    up      
Ethernet0/2            unassigned      YES unset  up                    up      
Ethernet0/3            unassigned      YES unset  administratively down down    
Ethernet1/0            unassigned      YES unset  administratively down down    
Ethernet1/1            unassigned      YES unset  administratively down down    
Ethernet1/2            unassigned      YES unset  administratively down down    
Ethernet1/3            unassigned      YES unset  administratively down down    
Port-channel1          172.16.1.2      YES manual up                    up      
Vlan1                  unassigned      YES unset  administratively down down    
Vlan200                200.1.1.1       YES manual up                    up      


Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(RU)         LACP      Et0/0(P)    Et0/1(P)    


The configurations are attached.

Regards
14-38-05--DLSW-4-64.187.124.3-.txt
14-38-13--DLSW-5-64.187.124.3-.txt
0
Comment
Question by:Member_2_7966113
  • 5
  • 5
  • 2
  • +1
14 Comments
 
LVL 29

Expert Comment

by:Predrag Jovic
ID: 41768894
Most likely source interface for ping is VLAN 100, try extended ping

ping       and then press enter

then select source interface po1 for ping

if you turn on routing on both devices you don't need source interface since interface closest to destination will be used for pings
0
 

Author Comment

by:Member_2_7966113
ID: 41768917
LVL,

Thanks for responding,

I have configured the following on both routers

ip routing
ip cef
router eigrp 1
network 0.0.0.0 255.255.255.255
no auto-summary

Now I'm getting the following errors:

*Aug 24 08:59:21.657: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.16.1.2 (Port-channel1) is down: retry limit exceeded
dlsw-4#ping
*Aug 24 08:59:25.119: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.16.1.2 (Port-channel1) is up: new adjacency
dlsw-4#ping
*Aug 24 09:00:44.711: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.16.1.2 (Port-channel1) is down: Interface PEER-TERMINATION received
dlsw-4#ping
*Aug 24 09:00:48.170: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.16.1.2 (Port-channel1) is up: new adjacency
dlsw-4#ping
*Aug 24 09:02:07.743: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.16.1.2 (Port-channel1) is down: Interface PEER-TERMINATION received
*Aug 24 09:02:08.045: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.16.1.2 (Port-channel1) is up: new adjacency
dlsw-4#ping
*Aug 24 09:03:27.624: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.16.1.2 (Port-channel1) is down: retry limit exceeded
0
 
LVL 29

Expert Comment

by:Predrag Jovic
ID: 41768947
There is no need to configure dynamic routing for ping.
# ip routing
is enough.
Since neighbor is flapping in EIGRP looks like your etherchannel is not stable.
Is that GNS3, packet tracer, or real switches? In the case of GNS3 it could be some bug, for packet tracer - occasionally it deletes configuration from the interface that is assigned to etherchannel :) .
0
MIM Survival Guide for Service Desk Managers

Major incidents can send mastered service desk processes into disorder. Systems and tools produce the data needed to resolve these incidents, but your challenge is getting that information to the right people fast. Check out the Survival Guide and begin bringing order to chaos.

 

Author Comment

by:Member_2_7966113
ID: 41768957
OK,

Let me remove EIGRP

Regards
0
 

Author Comment

by:Member_2_7966113
ID: 41769002
Its GNS3
0
 
LVL 29

Expert Comment

by:Predrag Jovic
ID: 41769035
Gns3 is bugy. Delete all and try again. 😊
0
 

Author Comment

by:Member_2_7966113
ID: 41769057
Will it work on Cisco IOU?
0
 
LVL 29

Expert Comment

by:Predrag Jovic
ID: 41769077
Not sure.
0
 
LVL 29

Expert Comment

by:Predrag Jovic
ID: 41769180
The thing is, if you configured properly etherchannel - through Po1 interface everything should work, and most likely it is working (since router was occasionally able to establish neighbor relationship between EIGRP neighbors through etherchannel - that mean two way communication). Looks like traffic between devices is burst by nature for some reason, packets are coming  and then stop, and then all over again. Not sure what can be done about it, but if both router "see" that LACP is properly working - communication between routers work properly (EIGRP establishes neighbor relations), but it is unstable for some reason.
0
 
LVL 46

Accepted Solution

by:
Craig Beck earned 250 total points
ID: 41769614
Try with IOU version i86bi-linux-l2-adventerprisek9-15.2d

Also, try with a static Etherchannel to rule out a LACP bug.
0
 
LVL 16

Assisted Solution

by:Michael Ortega
Michael Ortega earned 250 total points
ID: 41769685
I guess it's possible, but why would you assign your port-channel an IP?

Also, what traffic are you trying to allow over this port-channel? Default VLAN1?

The only other VLAN I see configured is VLAN200 on DLSW-5 and VLAN100 on DLSW-4.

What exactly are you trying to allow through this port-channel?

The typical configuration I would see on a port-channel is something like this (assuming the VLAN you wanted to traverse the port-channel was VLAN10):

DLSW-5
interface Port-channel1
 switchport trunk allowed vlan 10
 switchport mode trunk
!
interface Ethernet0/0
 switchport trunk allowed vlan 10
 switchport mode trunk
 channel-group 1 mode active
!
interface Ethernet0/1
 switchport trunk allowed vlan 10
 switchport mode trunk
 channel-group 1 mode active

DLSW-4
interface Port-channel1
 switchport trunk allowed vlan 10
 switchport mode trunk
!
interface Ethernet0/0
 switchport trunk allowed vlan 10
 switchport mode trunk
 channel-group 1 mode active
!
interface Ethernet0/1
 switchport trunk allowed vlan 10
 switchport mode trunk
 channel-group 1 mode active

MO
1
 
LVL 46

Expert Comment

by:Craig Beck
ID: 41769985
@Michael - L3 Port-channel is common.  It is used where you want to allow multiple links to be aggregated but don't want to use a VLAN and SVI.  Your config above doesn't include any L3 configuration.
0
 

Author Closing Comment

by:Member_2_7966113
ID: 41770004
Craig, this was the correct solution. Michael, the reason for this type of setup was because I was following a lab
0
 
LVL 16

Expert Comment

by:Michael Ortega
ID: 41770069
@Craig Beck

Sorry, I didn't mean to indicate that it was uncommon, period. I meant that it wasn't common to see it in a layer 2 application and I simply assumed that's all we were talking about since there weren't any other details in the attached configs to suggest otherwise. That's precisely why I was asking about "what" traffic needed to traverse the etherchannel/port-channel.

I saw the comment about EIGRP being added to the mix, but I wasn't sure how that fit into the whole picture, which it didn't appear that it did.

MO
0

Featured Post

Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
When speed and performance are vital to revenue, companies must have complete confidence in their cloud environment.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

696 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question