• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 103
  • Last Modified:

robocopy

Oh dear experts

I want robocopy this


robocopy.exe E:\Program Files\Microsoft SQL Server\MSSQL12.LIPSA\MSSQL\Backup\  f:\Bases\  /e /r:0 /w:0

do not work
please you guys!
0
Ernesto
Asked:
Ernesto
  • 3
  • 2
2 Solutions
 
Joe Winograd, Fellow&MVEDeveloperCommented:
Assuming that the paths are correct on E; and F:, the problem is probably that there are spaces in the E; folder name, so you need quotes around it. In other words:
robocopy.exe "E:\Program Files\Microsoft SQL Server\MSSQL12.LIPSA\MSSQL\Backup\"  f:\Bases\  /e /r:0 /w:0

Open in new window

Regards, Joe
0
 
ErnestoAuthor Commented:
says no destination??
regards
0
 
Bill PrewCommented:
Robocopy doesn't like a backslash at the end of a quoted path, try this:

robocopy.exe "E:\Program Files\Microsoft SQL Server\MSSQL12.LIPSA\MSSQL\Backup"  "f:\Bases"  /e /r:0 /w:0

Open in new window

~bp
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
ErnestoAuthor Commented:
Oh you guys
tsm!!
regards
0
 
Joe Winograd, Fellow&MVEDeveloperCommented:
The syntax of robocopy is:
ROBOCOPY source destination [file [file]...] [options]

So if it says no destination, that likely means there's no F: drive, because even if \Bases\ doesn't exist, it would create the folder on the F: drive — if there is one!

Please post a screenshot of the command prompt where you are issuing the robocopy.
0
 
Joe Winograd, Fellow&MVEDeveloperCommented:
> Robocopy doesn't like a backslash at the end of a quoted path

Bill,
Robocopy is perfectly fine with a backslash at the end:

robocopy with backslashes
The quotes were the problem, not the backslashes! Regards, Joe

Update: Oops! Turns out that backslashes are ok at the end of non-quoted paths but are not ok at the end of quoted paths. Talk about weird! My apologies, Bill, you are correct. That said, my comment about the quotes was at least half of the problem — and half of the solution. :)

So note that this also works:
robocopy.exe "E:\Program Files\Microsoft SQL Server\MSSQL12.LIPSA\MSSQL\Backup"  f:\Bases\  /e /r:0 /w:0

Open in new window

That is, a backslash at the end of f:\Bases\ — but no quotes! Cheers, Joe
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now