Changing $PATH variable - OS X

I am trying to update my $Path variable.  However, I am getting the message the executable needs to be in the PATH.

I used this command to update the path
echo 'export PATH=/Users/rjw/Documents/Python' >>~/.bash_profile

Open in new window


But when you look at echo $PATH you get the following without my path above.

export PATH=${PATH}:~/android-sdk-mac/tools
export PS1="rjw "
export PATH="/usr/local/mysql/bin:$PATH"
alias ll='ls -lahG'
export PATH=/usr/local/mysql/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/Users/rjw/android-sdk-mac/tools:/usr/local/mysql/bin

export PATH=/usr/local/mysql/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/Users/rjw/android-sdk-mac/tools:/usr/local/mysql/bin:/usr/local/mysql/bin

export PATH=/usr/local/mysql/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/Users/rjw/android-sdk-mac/tools:/usr/local/mysql/bin:/usr/local/mysql/bin

##
# Your previous /Users/rjw/.bash_profile file was backed up as /Users/rjw/.bash_profile.macports-saved_2016-01-13_at_10:05:16
##

# MacPorts Installer addition on 2016-01-13_at_10:05:16: adding an appropriate PATH variable for use with MacPorts.
export PATH="/opt/local/bin:/opt/local/sbin:$PATH"
# Finished adapting your PATH environment variable for use with MacPorts.


##
# Your previous /Users/rjw/.bash_profile file was backed up as /Users/rjw/.bash_profile.macports-saved_2016-07-26_at_16:54:01
##

# MacPorts Installer addition on 2016-07-26_at_16:54:01: adding an appropriate PATH variable for use with MacPorts.
export PATH="/opt/local/bin:/opt/local/sbin:$PATH"
# Finished adapting your PATH environment variable for use with MacPorts.


##
# Your previous /Users/rjw/.bash_profile file was backed up as /Users/rjw/.bash_profile.macports-saved_2016-07-26_at_17:07:46
##

# MacPorts Installer addition on 2016-07-26_at_17:07:46: adding an appropriate PATH variable for use with MacPorts.
export PATH="/opt/local/bin:/opt/local/sbin:$PATH"
# Finished adapting your PATH environment variable for use with MacPorts.


##
# Your previous /Users/rjw/.bash_profile file was backed up as /Users/rjw/.bash_profile.macports-saved_2016-07-26_at_17:13:45
##

# MacPorts Installer addition on 2016-07-26_at_17:13:45: adding an appropriate PATH variable for use with MacPorts.
export PATH="/opt/local/bin:/opt/local/sbin:$PATH"
# Finished adapting your PATH environment variable for use with MacPorts.
# Setting PATH for Python 3.5
# The original version is saved in .bash_profile.pysave
PATH="/Library/Frameworks/Python.framework/Versions/3.5/bin:${PATH}"
export PATH

Open in new window


I uninstalled macports if that is the problem and went to homebrew instead.
sharingsunshineAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

serialbandCommented:
This is more of a linux and bash question than just OS X.

After you ran your command, did you open a new Terminal window?  Did you reload your Terminal.  You current window won't load the .bash_profile until you've done something to reload it.

You can load it without restarting your terminal with the built-in source command:
source .bash_profile

You can start a new bash instance
bash

or if you want to reload your single instance,
exec bash


Your path command is also wrong.  You will replace all paths with just your home folder.
You really need
echo 'export PATH=$PATH:/Users/rjw/Documents/Python' >>~/.bash_profile

It also looks like macports added it's own path after yours, so the 2nd PATH setting won.

What are the current contents of your .bash_profile?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sharingsunshineAuthor Commented:
that's what I needed.  The path is in and working.  Thanks for the help.

I had closed the terminal window and then restarted it but that didn't do it.  But using  source .bash_profile and changing to your path made it work.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Mac OS X

From novice to tech pro — start learning today.