FREENAS 9.3 - Can't join AD

Hi everyone. I'm going crazy trying to join my FREENAS server to windows 2008 AD service. I've tried almost everything with no luck. I always get this message:
Unable to find domain controllers for innovateperu.local.
and the log shows:  
FreeNAS_ActiveDirectory_Base.get_SRV_records: no SRV records for _ldap._tcp.dc._msdcs.innovateperu.local found, fail!
I have attached some screenshots of my FREENAS configuration

My local domain is: innovateperu.local
Ludwig DiehlSystems ArchitectAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Adam BrownSr Solutions ArchitectCommented:
Check your Active Directory DNS zones to make sure the MSDCS folder/Forward Lookup Zone is there and that there is a valid SRV record under _TCP.DC folder.
Have you considered upgrading to the latest stable release (9.10.1 has probably been out for a few months now).

There are quite a few AD joining bugs in 9.3.
Ludwig DiehlSystems ArchitectAuthor Commented:
Thx for your replies. I have tried host -a _ldap._tcp.dc._msdcs.innovateperu.local. I get response...
About migrating version. This server is in production environment and holds my VM so I cannot restart it. Is there any other approach?
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

In your first screenshot enable verbose logging. This will log under /var/logs/messages. Does anything come up with errors? What happens if you run:

host -t srv _ldap._tcp.innovateperu.local

Open in new window

Also have a look at their troubleshooting KB on not being able to join the domain.

I would also look at spinning up 2 new VM's. 1 running FreeNAS 9.3 and 1 running the latest release. Can either of these join the domain?
Ludwig DiehlSystems ArchitectAuthor Commented:
See the attached image for results from host command.
By the way I did try what FreeNAS suggests.
Yeah, I would definitely try spin up a new VM to test joining a newer version to your AD environment. I can only assume its some sort of bug in FreeNAS 9.3.
Ludwig DiehlSystems ArchitectAuthor Commented:
thanks anyway. I will try that.
I would suggest you to create a computer object with "FREENAS" name in some OU and on this OU give create computer object object permissions to FREENAS computer object. I think this will work.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ludwig DiehlSystems ArchitectAuthor Commented:
freenas as a computer object exists from the beginning. That was the first thing I did when trying to join it to my domain
However as mentioned earlier, did you add permissions on the OU where FREENAS computer object exists.
Ludwig DiehlSystems ArchitectAuthor Commented:
Thank you all for your help. I could finally join my domain. You would laugh if I told u that the computer object "FREENAS" was disabled in my AD! lol. After enabling it again it could join the AD with no prob.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Active Directory

From novice to tech pro — start learning today.