Solved

phpPgAdmin problem

Posted on 2016-08-27
14
384 Views
Last Modified: 2016-08-29
I use the following url to access my phpPgAdmin installed within xampp:

http://localhost:8080/phpPgAdmin/

This was working perfectly on my windows machine until today
The url now gives me :
http://localhost:8080/phpPgAdmin/
The requested URL /phpPgAdmin/ was not found on this server.

Can some one please tell me where the port 8080 is defined for the phpPgAdmin
I cannot find it anywhere
again, the install is using xampp
0
Comment
Question by:doctorbill
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 7
14 Comments
 
LVL 83

Assisted Solution

by:Dave Baldwin
Dave Baldwin earned 500 total points
ID: 41773173
It is not defined for 'phpPgAdmin', port 8080 is defined for Apache and XAMPP.  If you type in just http://localhost:8080/ , you should still see the XAMPP main page.   'phpPgAdmin' is a PHP program that runs under PHP on Apache and uses the same port as everything else on the server.

The error message is telling you that either the 'phpPgAdmin' directory spelling has changed or perhaps the 'index.php' that is used to dispatch the code is missing or renamed.
0
 

Author Comment

by:doctorbill
ID: 41773174
xampp is runnign as port: 888
0
 
LVL 83

Assisted Solution

by:Dave Baldwin
Dave Baldwin earned 500 total points
ID: 41773186
Then try http://localhost:888/phpPgAdmin/ .  Apache / XAMPP runs PHP and 'phpPgAdmin' so they should be on the same port.  They are on every installation that I have.  PHP and 'phpPgAdmin' are not able to independently receive requests on a different port.

Apache is running the network service where the port is defined.  It passes requests on to the different programs like 'phpPgAdmin' that are running on the server.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 

Author Comment

by:doctorbill
ID: 41773209
Already tried this:
http://localhost:888/phpPgAdmin/index.php

I get:
Object not found!
error 404

If I try the pgAdmin 111 GUI it cannot connect to the server on 5433
0
 
LVL 83

Assisted Solution

by:Dave Baldwin
Dave Baldwin earned 500 total points
ID: 41773216
Ok, this shouldn't be this difficult.  It never has been here.

Try http://localhost:8080/  and tell what you get.
Try http://localhost:888/  and tell me what you get.
0
 
LVL 83

Assisted Solution

by:Dave Baldwin
Dave Baldwin earned 500 total points
ID: 41773217
Port 5433 should be the port for PostGreSQL.
0
 

Author Comment

by:doctorbill
ID: 41773225
http://localhost:8080:
This site can’t be reached
localhost refused to connect.
Did you mean http://localhost-8080.com/?
Search Google for localhost 8080
ERR_CONNECTION_REFUSED

http://localhost:888/xampp/:
This gets me to xampp control panel
0
 

Author Comment

by:doctorbill
ID: 41773234
This is working:
http://localhost:888/phpPgAdmin-5.1/

UN: postgres
PW: what should the default pw be
0
 
LVL 83

Accepted Solution

by:
Dave Baldwin earned 500 total points
ID: 41773484
In my install, there wasn't a default password.  This page tells about it: https://www.postgresql.org/message-id/4D958A35.8030501@hogranch.com  Since you are on Windows, you don't need to use the 'sudo' command to become an 'administrator' though you may need to be using an Administrator account.
0
 

Author Comment

by:doctorbill
ID: 41773895
There looked to be a lot of problems with my installs
I have now reinstalled the database servers and postgre phpPgAdmin (there was nothing important in the previous databases) and all looks good now

One final question:
Have you needed to export a set of mysql database tables using phpMyAdmin on windows and import them into postgres using the phpPgAdmin software
I get errors when doing this
I was wondering if you know of a good converter to use
0
 
LVL 83

Assisted Solution

by:Dave Baldwin
Dave Baldwin earned 500 total points
ID: 41773960
I did that once a couple of years ago when I first set up my test box.  I do remember struggling with it but not the details of fixing it.  I think I found out I did it wrong once I got it working.
0
 

Author Closing Comment

by:doctorbill
ID: 41773981
Solved
0
 
LVL 83

Expert Comment

by:Dave Baldwin
ID: 41774115
Good to hear, glad to help.
0
 

Author Comment

by:doctorbill
ID: 41774398
Always a pleasure working with you
1

Featured Post

Salesforce Made Easy to Use

On-screen guidance at the moment of need enables you & your employees to focus on the core, you can now boost your adoption rates swiftly and simply with one easy tool.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If your site has a few sections that need to be secure when data is transmitted between the server and local computer, such as a /order/ section for ordering or /customer/ which contains customer data, etc it would of course be recommended to secure…
In Solr 4.0 it is possible to atomically (or partially) update individual fields in a document. This article will show the operations possible for atomic updating as well as setting up your Solr instance to be able to perform the actions. One major …
The viewer will learn how to look for a specific file type in a local or remote server directory using PHP.
This tutorial will teach you the core code needed to finalize the addition of a watermark to your image. The viewer will use a small PHP class to learn and create a watermark.

630 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question