IIS Application pool identity

Erik Bjers
Erik Bjers used Ask the Experts™
on
Server is Windows 2012 R2 fully up to date

I am trying to set the identity of an app pool to use an AD account (requirement by the software vendor) but IIS keeps telling me I have an incorrect password.  I have verified the password for the account used is correct.

The account has the following rights
Allow login as; service and batch
Deny login; interactive (locally) and via remote desktop

The account is not a member of administrators

Any ideas of where to look or permissions I may need to check?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Hi

Please use command line to set identity app pool to user account

 
Please refer below link to resolve your issue.

https://technet.microsoft.com/en-us/library/cc771170(v=ws.10).aspx

http://forums.iis.net/t/1213147.aspx?How+I+can+run+IIS+app+pool+by+domain+account+
Erik BjersPrincipal Systems Administrator

Author

Commented:
Hello Sushil,

This worked and let me set the identity but after that the App Pool would not start anymore.
Make sure configure user have the permission on the below mention folders.

%windir%\system32\inetsrv\
%windir%\inetpub
Principal Systems Administrator
Commented:
Seems someone decided to shorten the service account name so IIS was correct the account name I was using was incorrect.

Interestingly enough setting it from cmd allowed me to set the user even though it technically did not exist.

Anyway I now used the correct shortened account name and all is good.
Erik BjersPrincipal Systems Administrator

Author

Commented:
The problem was due to another admin on my team shortening an account name and while Sushil's response helped me eventually identify the problem it was not the actual solution.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial