We help IT Professionals succeed at work.
Get Started

Can't read files on external usb drive files. Access Denied.

imij11 asked
Last Modified: 2016-09-21
I have laptop that recently updated to Windows 10. Everything works fine except for the fact I can't read or write files on any USB removable media. Flash drive, Phone, External HD. I have access to the drives and I can actually create folders but If I try to open an existing file or copy it off of the drive I get the message "Access Denied" or Administrator access required. I can read the media in other PC's though.

I have tried formatting a new USB drive and I made sure that the GP wasn't denying access to the USB removable media but to no avail. I have tried different profiles both local and domain as well but I still can't figure out why I can't open files on USB media.  I

I also tried using TAKEOWN command but it doesn't work on a FAT file system.

Anyone have any ideas what could be causing this?
I attached a screenshot of what is happening.
Watch Question
IT Product Manager
Top Expert 2009
This problem has been solved!
Unlock 1 Answer and 11 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE