?
Solved

HP 650 suddenly not recognizing USB mouse

Posted on 2016-08-30
13
Medium Priority
?
122 Views
Last Modified: 2016-09-01
Recently i bought Gigatech USB 3D optical mouse. It worked for days perfectly and then suddenly for unknown reason it stopped working, "USB device not recognized".
 
I tried the mouse on other laptop, works perfectly. Last 4 days i went through hell trying to get it working on my HP 650 to no avail. I reinstalled windows 4 times (!!) 32 and 64 bit, same error.
 
I tried uninstalling USB root hubs and all the devices under USB tab in device manager and restarting the laptop.  Mouse got recognized number of times under various names "USB input device", "USB optical mouse" and "HID compliant device", each time working for few seconds to few minutes while freezing all the time and then stopping to work completely, including the led light under the mouse.
 
I tried unplugging all other usb devices, no good, copying files from File repository folder into Inf folder, no good, taking out the battery and letting it sit for 5-10min, no good.
 
Other usb devices i use, WiFi antenna and keyboard work fine in whatever port i plug them in, but mouse keeps getting not recognized whatever i do and like i said even when it does for few seconds it keeps freezing and dies.
 
It worked perfectly for days and than this, i have no idea of the cause or the solution, please help if you have any idea.
0
Comment
Question by:Niksa Stanojevic
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 3
  • 2
  • +1
13 Comments
 
LVL 3

Expert Comment

by:Donna
ID: 41777482
You can try this:
Specify com port.


1. Go to Start...Programs...3dxonnexion...3dxware...(right click) on "Start Driver" go to "properties".

2. Edit the "Target" line.

Old Line:
"C:\Program Files\3Dconnexion\3DxWare\3DxSrv.exe" -searchWarnDlg

New line:
"C:\Program Files\3Dconnexion\3DxWare\3DxSrv.exe" -com 1


3. save configuration

4. Start driver.

If that doesn't work, which it likely won't, try the clean uninstall from the bottom of the page here:
http://www.3dconnexion.com/forum/viewtopic.php?t=1823
0
 
LVL 3

Expert Comment

by:Donna
ID: 41777483
...and if your OS isn't seeing it at all, you can try this;

Try unplugging your device, then plug directly into the computer holding down both the number 1 and number 2 buttons on your device at the same time. Then release the buttons and access the Jet Demo. See if the device is recognized by the operating system at this time. You may test in the Jet Demo (Start, All Programs, 3Dconnexion, 3Dconnexion 3DxWare, Demos)

This may help your operating system re-discover your device.
0
 

Author Comment

by:Niksa Stanojevic
ID: 41777484
Donna, i don't have 3Dconnexion mouse but regular Gigatech optical USB mouse.
0
Migrating Your Company's PCs

To keep pace with competitors, businesses must keep employees productive, and that means providing them with the latest technology. This document provides the tips and tricks you need to help you migrate an outdated PC fleet to new desktops, laptops, and tablets.

 
LVL 92

Expert Comment

by:nobus
ID: 41777548
to test if the problem is hard or software, try booting from a live cd, like Knoppix :
http://www.knopper.net/knoppix-mirrors/index-en.html      

if it works then -  it should work with windows;

i believe the problem to be hardware; did you test with other usb ports ? try them all
test it with NO other usb devices connected
0
 

Author Comment

by:Niksa Stanojevic
ID: 41777556
nobus, like i wrote above i tried it with no other devices plugged in and in all 3 USB ports like thousand times already, no good. when i delete usb hubs i sometimes get it to work for few seconds or even minutes but it starts freezing and then stops working. this is very strange considering it worked for days like a charm and it only happens to this mouse, while all other usb devices work fine.
0
 
LVL 47

Expert Comment

by:noxcho
ID: 41777612
A dumb question - have you replaced the battery in the mouse? I have here a MS wireless mouse which behaves similar when the voltage in its battery is low.
If this is not the case - any chance to try another mouse on the same machine?
If reinstalling Windows does not help then the problem is not in Windows or USB drivers. Somewhere else. Either in the mouse itself or in PC hardware where it refuses to work.
0
 
LVL 92

Expert Comment

by:nobus
ID: 41777877
you never said you tried it in all usb ports, sorry; that's why i asked
is the mouse wireless?  then try with a wired one
or test by booting from the Knoppix cd
0
 

Author Comment

by:Niksa Stanojevic
ID: 41778515
Mouse is not wireless, no battery in it. I checked the power rating for the each USB port and it doesn't exceede the rated 500mA.  Unfortunatelly i don't have another mouse to try but i got a feeling it would work fine since all other USB devices work in all the ports while this mouse does not work in any.
0
 

Author Comment

by:Niksa Stanojevic
ID: 41778541
MY GOD...it is the loose contact inside the mouse, i just noticed when i move the cable exiting the mouse left and right it lights on and off as i move it. it worked flawlessly for days, that's why i didn't suspect it to be a physical problem, moreover it worked fine on other laptop when i tried it for a short time.

sorry for taking your time,  i'll have to take apart the mouse and try to fix it. thank you for your efforts to help me.
0
 
LVL 47

Accepted Solution

by:
noxcho earned 2000 total points
ID: 41778870
Well, mouse or hardware...
0
 

Author Closing Comment

by:Niksa Stanojevic
ID: 41778932
and the oscar goes to :)
0
 
LVL 92

Expert Comment

by:nobus
ID: 41779305
i suggested :  to test if the problem is hard or software, try booting from a live cd, like Knoppix

so - no oscar for me??
0
 

Author Comment

by:Niksa Stanojevic
ID: 41780967
nobus, your suggestion makes sense but below part from noxcho is right on the spot making the live cd boot not necessary.

"If reinstalling Windows does not help then the problem is not in Windows or USB drivers. Somewhere else. Either in the mouse itself or in PC hardware where it refuses to work."
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A quick guide on how to use Group Policy to create a custom power plan and set it active on Windows 7.
Arrow Electronics was searching for a KVM  (Keyboard/Video/Mouse) switch that could display on one single monitor the current status of all units being tested on the rack.
In this Micro Tutorial viewers will learn how to use Boot Corrector from Paragon Rescue Kit Free to identify and fix the boot problems of Windows 7/8/2012R2 etc. As an example is used Windows 2012R2 which lost its active partition flag (often happen…
The viewer will learn how to successfully download and install the SARDU utility on Windows 7, without downloading adware.
Suggested Courses

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question