Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Cisco 800 - Port Forwarding only from one WAN IP

Posted on 2016-08-31
3
Medium Priority
?
128 Views
Last Modified: 2016-09-08
Hi Team

How do I configure on a Cisco router with a port forwarding rule restricted to a specific WAN IP?
Rather than everyone on the internet can RDP, but only coming from one WAN.

Thanks
0
Comment
Question by:goraek
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 14

Expert Comment

by:SIM50
ID: 41777978
I think it is something like below.

external NAT ip - 192.168.1.100
internal IP - 192.168.2.100
-------------------------------
ip access-list extended CLIENT
permit ip host 192.168.1.1 host 192.168.1.100

route-map CLIENT-RMAP permit 10
 match ip address CLIENT

ip nat inside source static 192.168.2.100 3389 192.168.1.100 3389 route-map CLIENT-RMAP

to verify: sh ip nat translations
0
 
LVL 2

Author Comment

by:goraek
ID: 41779243
Thanks but how do I restrict a WAN IP (home) for example? I want 58.58.58.58 (home public IP) to only RDP to the host 192.168.2.100.
0
 
LVL 47

Accepted Solution

by:
Craig Beck earned 2000 total points
ID: 41781583
If you have the security bundle features on the router you can use the firewall, or you can use an ACL on the WAN interface to drop all RDP apart from the specific IP you need.

For example...

ip access-list extended WAN-to-LAN
 permit tcp host 58.58.58.58 host any eq 3389
 deny tcp host any any eq 3389
 permit ip any any
!
int Dialer0  (or whatever your WAN interface is)
 ip access-group WAN-to-LAN in
!

Open in new window

0

Featured Post

[Webinar] Lessons on Recovering from Petya

Skyport is working hard to help customers recover from recent attacks, like the Petya worm. This work has brought to light some important lessons. New malware attacks like this can take down your entire environment. Learn from others mistakes on how to prevent Petya like worms.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you’re involved with your company’s wide area network (WAN), you’ve probably heard about SD-WANs. They’re the “boy wonder” of networking, ostensibly allowing companies to replace expensive MPLS lines with low-cost Internet access. But, are they …
Let’s face it: one of the reasons your organization chose a SaaS solution (whether Microsoft Dynamics 365, Netsuite or SAP) is that it is subscription-based. The upkeep is done. Or so you think.
In this video we outline the Physical Segments view of NetCrunch network monitor. By following this brief how-to video, you will be able to learn how NetCrunch visualizes your network, how granular is the information collected, as well as where to f…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…
Suggested Courses

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question