VMs disappeard

We have Windows Server 2012 R2 that has 2 Virtual Machines inside running Win 7 Pro sp1. They were working fine until last week when I opened Hyper-V manager, there was no VM listed. Tried to connect to them by right clicking on Hyper-V manager --> connect to server but I get an error message : "An error occurred while attempting to connect to server "servername". Check that the Virtual Machine Management Service is running and that you are authorized to connect to the server". So I checked the services and found that VMMS doesn't start.

so far I have tried disabling Firewall, made an exception on Anti-Virus, Restarted Windows Management Instrumentation and none of them made any changes.

Do you guys have any ideas how to resolve this issue?

Many thanks
PaoloBroggiAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Reboot and try again.
PaoloBroggiAuthor Commented:
I've done it so many times. no changes.

Do you have any other ideas?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hyper-V

From novice to tech pro — start learning today.