• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 149
  • Last Modified:

Invalid password trying to cannect to Unix server

I added a 2nd administrator level user profile to a Windows 7 Pro work group computer and tried to map a drive to a SAMBA share on a SCO Unix server. This is the same thing I've done before on the other computers in the office, and it's always taken mere seconds to do.
1. Open Windows Explorer
2. Click Tools/Map network drive
3. Select the drive letter
4. Browse to the correct share and click OK
5. Check Connect using different credentials
6. Click Finish
7. Enter User name as domain\name
8. Enter the password and click OK
The result is "The specified network password is not correct."...except it is.

The other user profile on this computer has the same drive mapping and works perfectly.

A terminal emulation program used on both profiles connects perfectly to the server using the same credentials.

I created a 3rd user profile in case the 2nd was corrupt, and had the same failure.

While Googling I've seen the procedure below, but I'm reluctant to make changes because the current settings work for the other profile:
1. Run: gpedit.msc
2. Console Root -> Local Computer Policy -> Computer Configuration -> Windows Settings -> -> Security Settings -> Local Policies ->Security Options
3. When you're there change the following policies
    Microsoft network client: Send unencrypted password to third-party SMB server: Switch it to "Enabled".
    Network security: LAN Manager authentication level: Select the option: Send LM & NTLM - use NTLMv2 session security if negotiated.

I've also seen some procedures having to do with settings changes on the Unix box.

The Unix server was install YEARS ago by another consultant, and I know very little about Unix. I have root access to it and have had to make changes to it over the years...directed by someone who knows they're doing. I say all this because if the solution requires changes to server, the solution should come with detailed instruction on how to get where I should be going!

Thank you!

Mark
0
markperl1
Asked:
markperl1
1 Solution
 
vivigattCommented:
Try to change the authentication settings (NTLM etc).
If it works, then you know that the problem comes from here.
AFAICR,  only very recent versions of samba can use NTLMv2.
See :
https://kb.iu.edu/d/atvt

You may also have a character in the password that is legit for Windows but not for Samba/Unix (although I can't figure out what character(s) it could be).

But if your Samba server does not use the same user/password directory as the Computer (IOW, if they are not member of the same AD domain), it is very likely that the user/password exists on the Windows machine but not on the Samba machine. If that is the case, you "just" have to add the user(s) to the Samba machine, making sure that they use the same name and password.
See
http://www.cyberciti.biz/faq/adding-a-user-to-a-samba-smb-share/
0
 
markperl1Author Commented:
I went ahead and changed the security policy authentications settings and it worked!

Vivigatt, thank you for your encouragement!

Mark
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now