Solved

Language appearing as ? in excel csv

Posted on 2016-08-31
8
40 Views
Last Modified: 2016-09-24
Hey All,

I was trying to save an excel document with other language information(Eg, French etc), and saved it as a .csv file.
When I try to reopen the file, the place where I have used different language , appears as a '?'? Why do you suppose this is happening?

Regards,
T
0
Comment
Question by:TiazfaD
  • 3
  • 3
  • 2
8 Comments
 
LVL 84

Assisted Solution

by:oBdA
oBdA earned 250 total points (awarded by participants)
ID: 41779321
You've probably saved it as "CSV (MS-DOS) (*.csv)", which uses Code page 437.
Use "CSV (Comma delimited) (*.csv)" instead, which uses ISO 8859-1 (a few lines above - the entries are not ordered by name).
0
 
LVL 18

Assisted Solution

by:xtermie
xtermie earned 250 total points (awarded by participants)
ID: 41779357
Or try saving it as CSV, UTF-8
0
 

Author Comment

by:TiazfaD
ID: 41779513
Hi oBdA!

How do I check for .csv which used Code page 437 ?
I tried saving the file as CSV (Comma delimited), but gave the same result..

Hi xtermie!

Where do I see the option for UTF-8?


Thanks in advance,
T
0
Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

 
LVL 84

Assisted Solution

by:oBdA
oBdA earned 250 total points (awarded by participants)
ID: 41779537
You can't check this; the file is saved as a bunch of bytes, and the code page determines which meaning (that is, which character) the bytes >127 represent. csv is a plain text file, so there's no meta data stored which code page was used when saving.
When you want to save this csv, always use "Save As", make sure the correct format is selected, and overwrite the original file. Do not use "Save", this will default to "CSV (MS-DOS) (*.csv)", even if you had it already saved as "CSV (Comma delimited) (*.csv)".
I tested with some French characters ("_éâè_"), and it worked just fine when using "Save as" and reopening.
Hex dump when saved as "CSV (Comma delimited) (*.csv)":
5F E9 E2 E8 5F 0D 0A	_éâè_..

Open in new window

Hex dump when saved as "CSV (MS-DOS) (*.csv)":
5F 82 83 8A 5F 0D 0A	_‚ƒŠ_..

Open in new window


HxD - Freeware Hex Editor and Disk Editor
https://mh-nexus.de/en/hxd/
0
 
LVL 18

Assisted Solution

by:xtermie
xtermie earned 250 total points (awarded by participants)
ID: 41779729
Try saving as Unicode text
0
 

Author Comment

by:TiazfaD
ID: 41783543
Hey Thanks oBdA and xtermie!

I actually have a requirement for saving the file in a csv format for using it elsewhere, that's why..

I am not having any luck saving the file as CSV delimited, and  currently clueless on how to go about this actually. Do you guys suppose, I need a language interface pack as mentioned below: ?

http://www.ehow.com/how_5736884_change-language-microsoft-excel.html

Regards,
T
0
 
LVL 84

Accepted Solution

by:
oBdA earned 250 total points (awarded by participants)
ID: 41785633
This is a limitation of the file format; interface languages for Excel won't change anything.
"I am not having any luck saving the file as CSV delimited" is not a helpful statement for troubleshooting.
Have you compared hexdumps when saved as "CSV (MS-DOS) (*.csv)" and "CSV (Comma delimited) (*.csv)", and if so, what were the exact results?
Does the "Text Import Wizard" pop up when you open the saved file? If not, you saved it as DOS csv.
Did you follow my advice about using "Save as" only, and absolutely no other "Save" dialog at all?
1. Create a test sheet with some French characters.
2. Go to "File > Save as", change the "Save as type:" dropdown box to "CSV (Comma delimited) (*.csv)", save as C:\Temp\Book1.csv.
3. Click "Save", click "OK" on the "The selected file type does not support workbooks that contain multiple sheets" dialog, click "Yes" on the "Book1.csv may contain features that are not compatible with csv ..." dialog.
4. Close the workbook, clicking Don't Save!
5. Open the file again, follow the "Text Import Wizard", and the French characters should show up correctly.

Finally, note that the "correct" way to save the file is determined by "elsewhere", not by being able to reopen it in Excel. "Elsewhere" decides which encoding it will use to open the file.

Other options for import/export:
Import or export text (.txt or .csv) files
https://support.office.com/en-us/article/Import-or-export-text-txt-or-csv-files-5250ac4c-663c-47ce-937b-339e391393ba
0
 
LVL 18

Expert Comment

by:xtermie
ID: 41813581
Good comments and recommendations provided by experts
0

Featured Post

NAS Cloud Backup Strategies

This article explains backup scenarios when using network storage. We review the so-called “3-2-1 strategy” and summarize the methods you can use to send NAS data to the cloud

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article explains how to prepare an HTML email signature template file containing dynamic placeholders for users' Azure AD data. Furthermore, it explains how to use this file to remotely set up a department-wide email signature policy in Office …
Do you use a spreadsheet like Microsoft's Excel?  Have you ever wanted to link out to a non excel file on your computer or network drive?  This is the way I found to do it!
This Micro Tutorial will demonstrate in Microsoft Excel how to add style and sexy appeal to horizontal bar charts.
This Micro Tutorial will demonstrate how to create pivot charts out of a data set. I also added a drop-down menu which allows to choose from different categories in the data set and the chart will automatically update.

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question