Windows 10 Socket error 10013 with Firewall & Defender disabled

I have a small server process that I've run for years on XP through Win 8.1. However, when I try to run it on Windows 10 I get the subject socket error. I think I know why but I don't know how to solve it. Both the Firewall and Defender are disabled, so they are not the problem.

The server process, of course, wants to use port 80 but, unlike the other windows versions, Win 10's kernel (ntoskrnl.exe) grabs the port when booting, so it is not available. How do I resolve this? I clearly can't stop the kernel process.
jclancyAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
jclancyConnect With a Mentor Author Commented:
Appreciate the responses but, no, no other AV or security program is running.

Problem SOLVED:

I just found the solution thanks to an Apache site (https://www.devside.net/wamp-server/wamp-apache-wont-start-on-windows-10). It confirmed that another Windows unit was glomming Port 80, in this case it was the IIS / World Wide Web Publishing Service (W3SVC) service which apparently is automatically turned ON by Win 10 even if you don't install or use it. Disabling the service bypassed the socket error and the server process is now running.
0
 
JohnBusiness Consultant (Owner)Commented:
I have not seen that error on any of my Windows 10 machines.

Please look at this Microsoft article below:

http://answers.microsoft.com/en-us/windows/forum/windows_7-networking/socket-10013-error-when-trying-to-connect-some/2cc71cb6-24b2-4b63-8f60-32bb444eb8fd?auth=1

Quote from the article: "A socket error 10013 can be caused by antivirus or firewall software. Basically, a needed socket connection is being denied. Socket error 10013 is a message which implies that a port is blocked and/or unreachable"
0
 
jclancyAuthor Commented:
I saw this before I posted. Look again at my subject line: both the Firewall and Defender were disabled and I still got the socket error because the kernel has grabbed Port 80.

You are likely not running anything competing for Port 80.
0
Get 10% Off Your First Squarespace Website

Ready to showcase your work, publish content or promote your business online? With Squarespace’s award-winning templates and 24/7 customer service, getting started is simple. Head to Squarespace.com and use offer code ‘EXPERTS’ to get 10% off your first purchase.

 
jclancyAuthor Commented:
BTW, the server dies this way also when run as administrator, so it doesn't appear to be a permissions issue.
0
 
JohnBusiness Consultant (Owner)Commented:
Windows 10 is much more secure. Check if you have aggressive AV installed like McAfee or Kaspersky because that can cause issues as well
0
 
jclancyAuthor Commented:
It works.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.