Solved

Help Desk Support Engineer

Posted on 2016-09-01
5
49 Views
Last Modified: 2016-09-12
We have Exchange 2007, previously we could have outlook clients external to the office connect and access emails I believe using Outlook anywhere. All of a sudden this no longer works, I used tectconnectivity.microsoft.com to test Outlook connectivity, it passes all tests except the last (see screenshot).connectivity test results.
After doing some research I tested telnet to port 6001, 6002, 6004 to the Exchange server, 6002 and 6004 work however 6001 fails, I assume this is where the issue lies?

I've tried disabling Windows Firewall and IPv6 on the nic neither of which made any difference.

Any help or troubleshooting steps would be appreciated.
0
Comment
Question by:scraftaus
  • 3
5 Comments
 
LVL 25

Expert Comment

by:-MAS
ID: 41781049
Hi scraftaus,
FYI tor testing connectivity from outside you need only 443(i.e.HTTPS) port open in your firewall (to the Exchange server). You should have IIS enabled on the 3rd party certificate.
Did you check the authentication in IIS?
Did you see this registry entry?

If none of them works. Disable Outlook anywhere, Remove RPCoHTTP feature from server manager.
Restart the server and install again. Enable outlookanywhere.

MAS
0
 
LVL 5

Expert Comment

by:Mdlinnett
ID: 41781130
I've had to Disable / Re-enable Outlook Anywhere before to restore the functionality as well...
0
 

Author Comment

by:scraftaus
ID: 41785507
Hi All,
Thanks for the replies.

MAS:
I have checked IIS Authentication and those registries both ok. I have not yet attempted to remove RPCoHTTP.

Mdlinnett:
I attempted to do so, waited for the logs to confirm it had been disabled/enabled each time however it didn't make any difference.

I have however found the following which may help:
Based of this post: https://www.experts-exchange.com/questions/24587053/Exchange-2007-Outlook-Anywhere-not-Working-RPC-HTTPS-RPC-S-SERVER-UNAVAILABLE-error.html

I've attached the output of 'netstat -ano', I've also cut down a lot of what seems irrelevant in the txt file.

At the moment I can telnet to the IPv4 address of the Mail server on Port 6002 and 6004 but not 6001. The netstat shows what is listening for those ports.

From my understanding 6001 should be listened to by the store.exe process (in my case the PID is 13468)
Port 6002 should be max.exe (PID 6280)
I'm not sure what 6004 should be however for me it is lsass.exe (PID 508).

My main concern from the Netstat output is the following:
The IPv4 address (192.168.3.17) isn't listening on either port 6001, 6002 or 6004.
Also there supposedly is '::' listening on those three ports.
lastly '::1' is listening to 6004.

Now like I said I tried disabling IPv6 in the Nic but it didn't seem to make a difference. What I noticed however is in the Nic's IPv6 properties it has a preferred DNS address set to '::1', I can also ping this address.

I believe this means that IPv6 is somehow interfering with this. I've tried removing that '::1' address from IPv6 preferred DNS and disabling IPv6 both did make a difference (Note I did not restart the server in between).

I guess what we want to happen is only have either 0.0.0.0 or 192.168.3.17 listening to ports 6001, 6002 and 6004.

Thanks in advanced.
0
 

Accepted Solution

by:
scraftaus earned 0 total points
ID: 41788803
Hi All,

Thanks for your input, we resolved the issue by disabling IPv6 and restarting the Exchange Server.
0
 

Author Closing Comment

by:scraftaus
ID: 41793926
Through own research found the resolution.
0

Featured Post

NAS Cloud Backup Strategies

This article explains backup scenarios when using network storage. We review the so-called “3-2-1 strategy” and summarize the methods you can use to send NAS data to the cloud

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A safe way to clean winsxs folder from your windows server 2008 R2 editions
Find out what you should include to make the best professional email signature for your organization.
how to add IIS SMTP to handle application/Scanner relays into office 365.
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question