Solved

GPO Drive Map Preference not working Windows 2012 R2 / Windows 10

Posted on 2016-09-02
3
89 Views
Last Modified: 2016-09-11
I am struggling with creating a Drive Map Preference. Everything seemed to work fine in the Windows 7 world when I was testing, but in Windows 10 is it not letting me create the Drive Map.

Troubleshooting steps so far:

Fix for Windows Update
In the delegation tab of each gpo make sure that 'authenticated users have read permissions and also that 'domain computers' has read permissions too. this should put the gpo right again.

Applied GPO Always wait for network computer startup and logon
PolicyAlways wait for the network at computer startup and logon
Category PathComputer Configuration\Administrative Templates\System\Logon\

Using gpupdate /force

https://blogs.technet.microsoft.com/askds/2009/01/07/using-group-policy-preferences-to-map-drives-based-on-group-membership/

I can map the drive manually with no problem



I'm just a little stumped as to what the problem could be? Is there a permission setting that GPO uses that the user doesn't use that would cause the GPO drive map to fail?

I ran GPRESULTS /H and RSOP.MSC and noticed that I didn't see the User Preference for Drive Mapping in the RSOP.MSC

I'm thinking it's something stupid that I am missing here...
0
Comment
Question by:Member_2_7965052
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 

Accepted Solution

by:
Member_2_7965052 earned 0 total points
ID: 41781640
I think I may have solved my own issue...WOW!

http://anonit.blogspot.com/2013/11/group-policy-preferences-drive-mapping.html

Apparently if you put a trailing slash in the GPO, it will not map the drive. I was going nutso trying to figure this out.
2
 
LVL 37

Assisted Solution

by:Mahesh
Mahesh earned 500 total points
ID: 41783628
generally with drive map GPP you face issues if you don't select "Run in logged user security context" checkbox in GPP item properties\common tab
0
 

Author Closing Comment

by:Member_2_7965052
ID: 41793230
I ended up solving my own problem. I gave an assist though I already had that solution figured out as well.
0

Featured Post

Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Active Directory security has been a hot topic of late, and for good reason. With 90% of the world’s organization using this system to manage access to all parts of their IT infrastructure, knowing how to protect against threats and keep vulnerabil…
Auditing domain password hashes is a commonly overlooked but critical requirement to ensuring secure passwords practices are followed. Methods exist to extract hashes directly for a live domain however this article describes a process to extract u…
In this Micro Tutorial viewers will learn how they can get their files copied out from their unbootable system without need to use recovery services. As an example non-bootable Windows 2012R2 installation is used which has boot problems.
This tutorial will walk an individual through the process of installing of Data Protection Manager on a server running Windows Server 2012 R2, including the prerequisites. Microsoft .Net 3.5 is required. To install this feature, go to Server Manager…

630 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question