Microsoft Edge

Jegajothy vythilingam
Jegajothy vythilingam used Ask the Experts™
on
My OS is win 10 pro 64 bit and I have a business essential account for office 365.  I have the languages, English, Spanish, Thailand and Sanskrit installed.  Thus, I can select any of these languages to display in that language.  All of a sudden my browser seems to display only in Spanish, even though English has been selected.  And it is only for the Microsoft Edge browser.  Hope the experts can please suggest a fix for this. thank u.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Marco GasiFreelancer
Top Expert 2010

Commented:
Just leave Edge and use Firefox or Chrome.
JohnBusiness Consultant (Owner)
Most Valuable Expert 2012
Expert of the Year 2018
Commented:
Check both Region and Language in Control Panel. Edge adheres to standards and that should work.

Make sure your machine is at Version 1067 Build 14393.105 first.

Author

Commented:
in response to John, I checked the Region and Language and it shows "Ingles (Estados Unidos)" but I am still seeing sometimes in Spanish.
how do I check the Version 1067 .....
the start items shows in Spanish.
in response to Marco, the reason is, I hear that Edge has better security features than the other 2.
Thank u.
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

JohnBusiness Consultant (Owner)
Most Valuable Expert 2012
Expert of the Year 2018

Commented:
To check version, click on Settings, Notifications, scroll down and About. That will tell you.
Business Consultant (Owner)
Most Valuable Expert 2012
Expert of the Year 2018
Commented:
In Windows 10, IE 11 is as secure as Edge. The concepts from EMET (Microsoft Security) have been included in IE 11 in Windows 10.

Author

Commented:
Thank u for the solutions, it has been resolved.  The trick was to delete the other languages first and leave the English one, and this worked.  Thank u.
JohnBusiness Consultant (Owner)
Most Valuable Expert 2012
Expert of the Year 2018

Commented:
I think we assisted you. Can you please close the question.?

Author

Commented:
thank u the problem has been resolved.
JohnBusiness Consultant (Owner)
Most Valuable Expert 2012
Expert of the Year 2018

Commented:
Thanks for following up and I always appreciate helping you.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial