Solved

'Oracle.ManagedDataAccess.Client' could not be loaded

Posted on 2016-09-02
4
770 Views
Last Modified: 2016-09-09
I have this issue that when I have my code deployed to Development server.  Everything works but when I publish that to testing server.  It bug out. with following message.

"
The Entity Framework provider type 'Oracle.ManagedDataAccess.EntityFramework.EFOracleProviderServices, Oracle.ManagedDataAccess.EntityFramework, Version=6.121.2.0, Culture=neutral, PublicKeyToken=89b483f429c47342' registered in the application config file for the ADO.NET provider with invariant name 'Oracle.ManagedDataAccess.Client' could not be loaded. Make sure that the assembly-qualified name is used and that the assembly is available to the running application. See http://go.microsoft.com/fwlink/?LinkId=260882 for more information.
"

Anyone experienced similar issue?  I tried couple solution from the internet without success.  

<?xml version="1.0" encoding="utf-8"?>
<!--
  For more information on how to configure your ASP.NET application, please visit
  http://go.microsoft.com/fwlink/?LinkId=301880
  -->
<configuration>
  <configSections>
    <!-- For more information on Entity Framework configuration, visit http://go.microsoft.com/fwlink/?LinkID=237468 -->
    <section name="entityFramework" type="System.Data.Entity.Internal.ConfigFile.EntityFrameworkSection, EntityFramework, Version=6.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" />
    <sectionGroup name="applicationSettings" type="System.Configuration.ApplicationSettingsGroup, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
      <section name="DocuSignL360App.Properties.Settings" type="System.Configuration.ClientSettingsSection, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" />
    </sectionGroup>
    <section name="oracle.manageddataaccess.client" type="OracleInternal.Common.ODPMSectionHandler, Oracle.ManagedDataAccess, Version=4.121.2.0, Culture=neutral, PublicKeyToken=89b483f429c47342" />
  <!-- For more information on Entity Framework configuration, visit http://go.microsoft.com/fwlink/?LinkID=237468 --></configSections>
  <connectionStrings>
    <add name="DefaultConnection" connectionString="Data Source=(LocalDb)\v11.0;AttachDbFilename=|DataDirectory|\aspnet-DocuSignL360App-20160525104950.mdf;Initial Catalog=aspnet-DocuSignL360App-20160525104950;Integrated Security=True" providerName="System.Data.SqlClient" />
    <add name="DocuSignL360AppContext" connectionString="Data Source=(localdb)\v11.0; Initial Catalog=DocuSignL360AppContext-20160525123717; Integrated Security=True; MultipleActiveResultSets=True; AttachDbFilename=|DataDirectory|DocuSignL360AppContext-20160525123717.mdf" providerName="System.Data.SqlClient" />
    <add name="DocuSignL360App.Properties.Settings.OsiBankConnectionString" connectionString="DATA SOURCE=mydatasource/oltp;PASSWORD=Password123;PERSIST SECURITY INFO=True;USER ID=ESTATEMENTSPROVIDER" />
  </connectionStrings>
  <appSettings>
    <add key="webpages:Version" value="3.0.0.0" />
    <add key="webpages:Enabled" value="false" />
    <add key="ClientValidationEnabled" value="true" />
    <add key="UnobtrusiveJavaScriptEnabled" value="true" />
  </appSettings>
  <system.web>
    <authentication mode="None" />
    <compilation debug="true" targetFramework="4.5.2" />
    <customErrors mode="Off"></customErrors>
    <httpRuntime targetFramework="4.5.2" />
  </system.web>
  <system.webServer>
    <modules>
      <remove name="FormsAuthentication" />
    </modules>
  </system.webServer>
  <runtime>
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
      <dependentAssembly>
        <assemblyIdentity name="Microsoft.Owin.Security" publicKeyToken="31bf3856ad364e35" />
        <bindingRedirect oldVersion="0.0.0.0-3.0.1.0" newVersion="3.0.1.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Microsoft.Owin.Security.OAuth" publicKeyToken="31bf3856ad364e35" />
        <bindingRedirect oldVersion="0.0.0.0-3.0.1.0" newVersion="3.0.1.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Microsoft.Owin.Security.Cookies" publicKeyToken="31bf3856ad364e35" />
        <bindingRedirect oldVersion="0.0.0.0-3.0.1.0" newVersion="3.0.1.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Microsoft.Owin" publicKeyToken="31bf3856ad364e35" />
        <bindingRedirect oldVersion="0.0.0.0-3.0.1.0" newVersion="3.0.1.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Newtonsoft.Json" culture="neutral" publicKeyToken="30ad4fe6b2a6aeed" />
        <bindingRedirect oldVersion="0.0.0.0-8.0.0.0" newVersion="8.0.0.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="System.Web.Optimization" publicKeyToken="31bf3856ad364e35" />
        <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="1.1.0.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="WebGrease" publicKeyToken="31bf3856ad364e35" />
        <bindingRedirect oldVersion="0.0.0.0-1.5.2.14234" newVersion="1.5.2.14234" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="System.Web.Helpers" publicKeyToken="31bf3856ad364e35" />
        <bindingRedirect oldVersion="1.0.0.0-3.0.0.0" newVersion="3.0.0.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="System.Web.Mvc" publicKeyToken="31bf3856ad364e35" />
        <bindingRedirect oldVersion="1.0.0.0-5.2.3.0" newVersion="5.2.3.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="System.Web.WebPages" publicKeyToken="31bf3856ad364e35" />
        <bindingRedirect oldVersion="1.0.0.0-3.0.0.0" newVersion="3.0.0.0" />
      </dependentAssembly>
      <dependentAssembly>
        <publisherPolicy apply="no" />
        <assemblyIdentity name="Oracle.ManagedDataAccess" publicKeyToken="89b483f429c47342" culture="neutral" />
      </dependentAssembly>
    </assemblyBinding>
  </runtime>
  <entityFramework>
    <defaultConnectionFactory type="System.Data.Entity.Infrastructure.SqlConnectionFactory, EntityFramework" />
    <providers>
      <provider invariantName="System.Data.SqlClient" type="System.Data.Entity.SqlServer.SqlProviderServices, EntityFramework.SqlServer" />
    </providers>
  </entityFramework>

  <applicationSettings>
    <DocuSignL360App.Properties.Settings>
      <setting name="StrPassWord" serializeAs="String">
        <value>mypassword</value>
      </setting>
      <setting name="StrUserName" serializeAs="String">
        <value>mypassword</value>
      </setting>
      <setting name="CUDLUrl" serializeAs="String">
        <value>https://dp.cudl.com/CUDLConnect/CUDLConnect.asmx</value>
      </setting>
      <setting name="DocumentsFolder" serializeAs="String">
        <value>~/Documents/Forms/
</value>
      </setting>
      <setting name="EmailAlertTo" serializeAs="String">
        <value>myemail@gmail.com</value>
      </setting>
      <setting name="EmailAlertCC" serializeAs="String">
        <value>myemail@gmail.com</value>
      </setting>
      <setting name="EmailFrom" serializeAs="String">
        <value>myemail@gmail.com</value>
      </setting>
      <setting name="DocuSignUserName" serializeAs="String">
        <value>myemail@gmail.com</value>
      </setting>
      <setting name="DocuSignPassWord" serializeAs="String">
        <value>mypassword</value>
      </setting>
      <setting name="DocuSignIntegratorKey" serializeAs="String">
        <value>myintegrationkeyhashvalue</value>
      </setting>
      <setting name="DocuSignDemoUrl" serializeAs="String">
        <value>https://demo.docusign.net/restapi</value>
      </setting>
      <setting name="DocuSignBrandID" serializeAs="String">
        <value>mydocusignbrandidhashvalue</value>
      </setting>
      <setting name="APIServiceSoap" serializeAs="String">
        <value>https://www.docusign.net/api/3.0/api.asmx</value>
      </setting>
    </DocuSignL360App.Properties.Settings>
  </applicationSettings>
  <system.data>
    <DbProviderFactories>
      <remove invariant="Oracle.ManagedDataAccess.Client" />
      <add name="ODP.NET, Managed Driver" invariant="Oracle.ManagedDataAccess.Client" description="Oracle Data Provider for .NET, Managed Driver" type="Oracle.ManagedDataAccess.Client.OracleClientFactory, Oracle.ManagedDataAccess, Version=4.121.2.0, Culture=neutral, PublicKeyToken=89b483f429c47342" />
    </DbProviderFactories>
  </system.data>
 
</configuration>
0
Comment
Question by:eli411
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
4 Comments
 
LVL 2

Accepted Solution

by:
eli411 earned 0 total points
ID: 41782330
Found the solution -- going to Visual Studio --> Tools -->Nuget Package Manager -- > Nuget Package Manager for solution --> search for Oracle Entity Framework  and install it.
0
 
LVL 2

Author Closing Comment

by:eli411
ID: 41782331
Found  the solution myself.
0
 
LVL 13

Expert Comment

by:Cedric Obinna A.
ID: 41782520
Hello eli411,

Where did you install the Oracle Entity Framework, on the Development Server or on the Testing Server?
0
 
LVL 2

Author Comment

by:eli411
ID: 41791689
It is install through Visual studio so when the codes are publish to server, all the packages will load to the server.
1

Featured Post

MS Dynamics Made Instantly Simpler

Make Your Microsoft Dynamics Investment Count  & Drastically Decrease Training Time by Providing Intuitive Step-By-Step WalkThru Tutorials.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

More often than not, we developers are confronted with a need: a need to make some kind of magic happen via code. Whether it is for a client, for the boss, or for our own personal projects, the need must be satisfied. Most of the time, the Framework…
Entity Framework is a powerful tool to help you interact with the DataBase but still doesn't help much when we have a Stored Procedure that returns more than one resultset. The solution takes some of out-of-the-box thinking; read on!

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question