?
Solved

SBS 2008 DNS server suddenly stops working.... any ideas?

Posted on 2016-09-03
9
Medium Priority
?
74 Views
Last Modified: 2016-09-14
I have SBS 2008 server.  DNS just stops working randomly.  Rebooted - DNS still not working.  Any ideas?
  What should I check next?
0
Comment
Question by:Xetroximyn
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
9 Comments
 
LVL 5

Accepted Solution

by:
Mdlinnett earned 1000 total points
ID: 41783568
This is a known issue with SBS 2008 > http://www.shogan.co.uk/sbs-2008/dns-for-tlds-not-working-on-sbs-2008-when-using-root-hints/

I have previously added the reg key AND specified other DNS Servers such as those offered by the ISP or Google (8.8.8.8 / 8.8.4.4)
0
 
LVL 17

Assisted Solution

by:Sajid Shaik M
Sajid Shaik M earned 1000 total points
ID: 41783585
check the event viewer first...
0
 

Author Comment

by:Xetroximyn
ID: 41783855
check the event viewer first...
Check it for what?    

@Mdlinnett
Are you sure this is related?   I havn't changed anything with DNS recently.... and my problem is not only with resolving external IP's which seems to be what this article is about.  It's also not resolving it's own internal domains.  (Also FYI, I already have google's DNS set as my 2 forwarders, did that long long ago)

This is causing problems because people can't resolve our own internal server IP's, and also some people cant access shares on the SBS server. (i'm guessing DNS related but not sure why some people can access shares and others can not)
0
Are You Ready for GDPR?

With the GDPR deadline set for May 25, 2018, many organizations are ill-prepared due to uncertainty about the criteria for compliance. According to a recent WatchGuard survey, a staggering 37% of respondents don't even know if their organization needs to comply with GDPR. Do you?

 
LVL 5

Assisted Solution

by:Mdlinnett
Mdlinnett earned 1000 total points
ID: 41783977
Sure, if it's internal DNS that is affected as well then that's something altogether different.

When DNS stops working, can the Server still resolve names to IP addresses?  Ie, could it be down to the DNS Server addresses being handed out by DHCP?

Did you use the wizard to configure the Server detail?

Have you tried running the fix my network Wizard?

What does the Best Practices Analyser say?
0
 

Author Comment

by:Xetroximyn
ID: 41784040
I finally had time to call dell.... it seems some weird stuff was going on....  From the SBS server we could not ping the gateway address.  

Our servers all go into an 8 port gigabit switch, and that switch plugs directly into the firewall.  I could ping both ways from sbs server to another server but the SBS server could not ping the gateway.... not sure how that could even happen.

Anyway - dell guy cleaned up some settings, reinstalled the TCPIP stack, such that we rebooted and the IP address has to be set for the server again.  

so far things seem to be working (fingers crossed)
0
 
LVL 17

Expert Comment

by:Sajid Shaik M
ID: 41784103
nice to hear that issue is resolved.. and thanks for posting
0
 

Author Comment

by:Xetroximyn
ID: 41786529
OK so this is very strange.... things worked fine for a bit - then same thing happened... SBS could not ping gateway/firewall.   This time I had someone move it from the switch it was on to be directly connected to the firewall and it could ping the firewall again.  

This seems really strange to me...
first time
reboot server - does not fix
fix up some dns settings, and reinstall tcp stack, reboot, set static IP again - things work
(This makes me suspect something on the server itself)

second time
just move it from the switch it was plugged into and move it to firewall and it works....
(this makes me thing something wrong with switch, but if that is the case, how did the first fix ever work?)


Any ideas?
0
 
LVL 5

Assisted Solution

by:Mdlinnett
Mdlinnett earned 1000 total points
ID: 41786636
How are you setting the static ip again?

Is ipv6 enabled?

SBS = use the Wizards
0
 

Author Comment

by:Xetroximyn
ID: 41787108
IP address was set via adapter ipv4 properties - nothing else was touched (ipv6 is still enabled)

All has been good ever since we plugged it directly into firewall (fingers crossed)

Still the whole thing is a bit disconcerting....
0

Featured Post

The Eight Noble Truths of Backup and Recovery

How can IT departments tackle the challenges of a Big Data world? This white paper provides a roadmap to success and helps companies ensure that all their data is safe and secure, no matter if it resides on-premise with physical or virtual machines or in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Had a business requirement to store the mobile number in an environmental variable. This is just a quick article on how this was done.
Group policies can be applied selectively to specific devices with the help of groups. Utilising this, it is possible to phase-in group policies, over a period of time, by randomly adding non-members user or computers at a set interval, to a group f…
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…
Suggested Courses

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question