Solved

Traffice routed through Fortigate VPN does not reach hosts on another VPN

Posted on 2016-09-04
3
111 Views
Last Modified: 2016-09-05
Three key points:
1) Branch (Fortigate 60c with FortiOS 5.2)
2) Headquarters (Fortigate 100d with FortiOS 5.2)
3) Third-party office (unknown device)

Current status:
1) Branch and Headquarters are linked through an IPsec Tunnel ("Branch-To-Headquarters Tunnel") that works fine. Branch hosts are able to communicate with Headquarters hosts.
2) Headquarters and Third-party office are linked through an IPsec Tunnel ("Headquarters-To-3rdParty Tunnel") that works fine. Headquarters hosts are able to communicate with Third-party office hosts.

Now, I need that Branch hosts are able to communicate with Third-party office hosts through the existing tunnels, so, I have done the following:
1) Create a static route on Branch, to route all traffic to 3rd party hosts trough "Branch-To-Headquarters Tunnel"
2) I confirmed that the requests are being received, accepted on the Headquarters firewall.

However, I don't get a reply back from 3rd party.

I'm suspecting about two possible causes:
1) traffic is not being routed from Headquarters to 3rd party (I don't think so, since I only have one static route that works when communicating from Headquarters through 3rd party)
2) There's something related to NAT that is not working as expected (for instance: 3rd party is waiting from requests from Headquarters' subnet, but requests are being received from Branch's subnet). If that's the case...how can I instruct Fortigate to "treat requests originating from Branch Office, as if they were originated in Headquarters" so the 3rd party firewall would accept them?

Please refer to the attached image for clarification.

Any help on this?

Thanks,
IssueWithRouting.png
0
Comment
Question by:dsuy
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 37

Accepted Solution

by:
bbao earned 500 total points
ID: 41783919
by default the subnet at the 3rd party is not known by the branch, hence the Fortigate 60D should add a static route to forward corresponding traffic to the HQ, otherwise the traffic to 172.1.1.0 subnet will be sent to the Internet by default.

therefore the following route need to be added at 60D:

From: 192.168.2.0/24
To: 172.1.1.0/24
Gateway: 192.168.1.1

nothing else need to be changed. just one more route to be added on the 60D at the branch.
0
 

Author Comment

by:dsuy
ID: 41784724
Thanks, that's what I had done by creating a PBR, but it didn't work. I then created a Static Route and it started to work.
0
 

Author Closing Comment

by:dsuy
ID: 41784726
Marking as solution
0

Featured Post

Save the day with this special offer from ATEN!

Save 30% on the CV211 using promo code EXPERTS30 now through April 30th. The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Secure VPN Connection terminated locally by the Client.  Reason 442: Failed to enable Virtual Adapter. If you receive this error on Windows 8 or Windows 8.1 while trying to connect with the Cisco VPN Client then the solution is a simple registry f…
OpenVPN is a great open source VPN server that is capable of providing quick and easy VPN access to your network on the cheap.  By default the software is configured to allow open access to your network.  But what if you want to restrict users to on…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question