PowerShell Get-Help

Posted on 2016-09-05
Last Modified: 2016-09-07
I am trying  to run get-help about_*, it returns about_CimSession only

I like to check all about help files through command line

Thank you

There is my ps version
Name                           Value
----                           -----
PSVersion                      5.0.10586.494
PSCompatibleVersions           {1.0, 2.0, 3.0, 4.0...}
BuildVersion                   10.0.10586.494
CLRVersion                     4.0.30319.42000
WSManStackVersion              3.0
PSRemotingProtocolVersion      2.3
Question by:jzrobbie
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
  • +1
LVL 84

Expert Comment

ID: 41784650
Since your command should work just fine, start with an elevated Shell (both 32bit and 64bit) and

Open in new window

Then try the Get-Help again.

Author Comment

ID: 41784665
@oBdA, tried to update again, it sill couldn't get about help file.
LVL 84

Expert Comment

ID: 41784682
* Did you run Update-Help in an elevated prompt?
* Did you get error messages from Update-Help?
* Can you get help for other topics, for example Get-Help *Item*?
When running Update-Help more than once on the same day, use the -Force switch.
Is Your AD Toolbox Looking More Like a Toybox?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.


Author Comment

ID: 41785388
* Did you run Update-Help in an elevated prompt?
-Yes, on both 32 & 64 bit

* Did you get error messages from Update-Help?

* Can you get help for other topics, for example Get-Help *Item*?
-I have no issues to get help with normal cmdlets but about files
When running Update-Help more than once on the same day, use the -Force switch.
I have tried -Force switch again , it is still no luck.

There is what I got when I put Get-Help about_*
PSScreen_About.PNGThis stopped working after I upgraded from PSv2 to V5, not sure whether it is the issue.
LVL 40

Expert Comment

ID: 41785426
Did you install WMF 4.0 before 5.0?  That is a requirement.  I'm not sure if it could cause your issue, or whether the install would even succeed without it, but just want to be thorough.

What do you see if you run something like the following?
get-help -category helpfile

Author Comment

ID: 41785599
No, i upgraded from ps2.0.
There is the result I run get-help -category helpfile
PS C:\windows\system32> get-help -category helpfile

Name                              Category  Module                    Synopsis
----                              --------  ------                    --------
default                           HelpFile                            SHORT DESCRIPTION
about_ActiveDirectory             HelpFile                            The Active Directory m
about_ActiveDirectory_Filter      HelpFile                            Describes the syntax a
about_ActiveDirectory_Identity    HelpFile                            The Active Directory m
about_ActiveDirectory_ObjectModel HelpFile                            Describes the object m
about_BITS_Cmdlets                HelpFile                            Provides background in
about_CimSession                  HelpFile                            Describes a CimSession

Open in new window

LVL 40

Accepted Solution

footech earned 500 total points
ID: 41786479
Go ahead and uninstall WMF 5.0, then install WMF 4.0 and then 5.0.  Then run Update-Help again and see if the issue is corrected.

Author Comment

ID: 41787181
It worked!!!
I need to run update-help -force.
Thank you. Do you know what was the problem?
LVL 40

Expert Comment

ID: 41788370
Not exactly.  But as you stated it stopped working after your upgrade, making sure that you followed the installation steps seemed like a good place to start.
LVL 70

Expert Comment

ID: 41788380
Probably an incomplete / damaged help file stopped processing others, "breaking the chain".

Featured Post

Why You Need a DevOps Toolchain

IT needs to deliver services with more agility and velocity. IT must roll out application features and innovations faster to keep up with customer demands, which is where a DevOps toolchain steps in. View the infographic to see why you need a DevOps toolchain.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Force Stop Domino Service in Windows using windows script 37 80
Powershell script. 6 48
Powershell WPF, Redirection Issue 2 27
import-csv powershell 8 23
A quick Powershell script I wrote to find old program installations and check versions of a specific file across the network.
Previously, on our Nano Server Deployment series, we've created a new nano server image and deployed it on a physical server in part 2. Now we will go through configuration.
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question