VMWare Fusion for Mac starts up after video downloads

I want videos to default to open in VLC for Mac. However, no matter what I do they always try to open in Windows Media Player.

This is what I do to try to fix it:
(To make movies open in VLC by default): I right-click on one movie, then choose Get Info. I select "Open With", then "VLC", then "Change All".

I've done this. See screenshot1
screenshot1



But it still sticks to Windows Media player. Weird.

See this screenshot:
screenshot2


Any ideas what's wrong?

Thanks!
screenshot1.jpg
screenshot1.jpg
LVL 1
greghollAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

greghollAuthor Commented:
Fixed it, Gerwin Jansen
0
Eoin OSullivanConsultantCommented:
The associations between applications and file extensions doesn't always fully resolve.

If it is only one application on VMWare Fusion you want to disassociate .. try the following 2 commands in terminal.

They force OSX to rebuild its index of what applications are associated with which file extensions

sudo /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user

Open in new window


then

killall Finder

Open in new window

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
strungCommented:
Inside Fusion, open the Virtual Machine Library window – Window menu > Virtual Machine Library, or press CMD+SHIFT+L.

Select the VM and click the Settings button.

Click the Applications icon, and then select the Default Applications tab.

Uncheck Open your Mac files and web links using Windows applications and close the window.
0
greghollAuthor Commented:
Both were great help. Thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
MultiMedia Applications

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.