• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3657
  • Last Modified:

sql management studio 2012 restore database "No ok button"

If I try to restore a database from a brand installation of SQL Server 2012 Management Studio on my laptop, the OK, Cancel, Help buttons are missing - hence I can't restore any of my databases.

Laptop Problem
On my desktop I have no problems.

Desktop - No Prolem
What do I need to do to get the OK button to show?

Thanks in advance for any help
2 Solutions
Check the options selection in the left pane. There it indicates where the db/log files should be stored.
The path from the backup might not exist on the system where it is being restored.

The progress indicator, says it is done.
LJGAuthor Commented:
Thanks Arnold for the response.

I think you are talking about the files tab instead of the Option tab.  In the file tab the db & log files are being "Restore As" has the correct folder , db name and log name.

The problem is as soon as you click "Restore Database" the form comes up without the OK Cancel buttons.  I would think, but not sure, this points to not being anything I enter into the form, but some setting someplace else.

Again any help is appreciated.
I see, files has the info of where to store the tikes, as soon as you accept/ok that the restore takes place, thus the progress is done.
What state do you want the database to be when done, options is likely to have the selectors in which state the db should be on completion, recovery with,live, or in recovery where you can replay/restore any subsequent transaction log backups, ......

Ok in any of the other selections will trigger the restore process.
Build your data science skills into a career

Are you ready to take your data science career to the next step, or break into data science? With Springboard’s Data Science Career Track, you’ll master data science topics, have personalized career guidance, weekly calls with a data science expert, and a job guarantee.

Nakul VachhrajaniTechnical Architect, Capgemini IndiaCommented:
Try performing a "Reset" by going to Windows –> Reset window layout option.

NOTE: Using the “Reset Window Layout” clears out customizations to the default window positions and sizes and takes the SSMS back to the default state.
Jason clarkDBA FreelancerCommented:
Try use "Script" button to get the T-SQL script for the action and execute the SQL script in a "Query Window" or you can try to change screen resolution.
LJGAuthor Commented:
Thanks so much Nakul & Jason

Both of you had good answers and I am now able to move forward thanks to the two of you (1 spent a day trying to solve this).
Nakul --> Reset window layout option.
                 In SSMS if you pick Windows / Reset Window Layout - it will solve the problem.
                 Another solve for me was to move my laptop resolution from 1280X720 to 1920X1080

Jason --> Use the "Script" Button
                 This is a solve that worked great and gave me some knowledge I needed.

Thanks for solving my problem.
LJGAuthor Commented:
Thanks so much - you guys saved my rear end.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now