Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

VLAN and switchport trunk question

Posted on 2016-09-06
6
Medium Priority
?
61 Views
Last Modified: 2016-09-07
There is Cisco 8-port catalyst 3560C and someone configured to connect a Ruckus R500. When I did a sh run in the switch, I found there was a line below and did not see list of vlans. why it was configured?

VLAN internal allocation policy ascending

Also, when I did sh vlan, there were list of default vlans plus vlans that was configured and interfaces g0/2 to g/08 was on default vlan 1. and did not find interface g0/1 assigned to any vlan

But when I did sh run int g0/1, the following was shown.
switchport trunk encapsulation dot1q
switchport mode trunk

Could someone please help to share your comment on why the switch configured?

Below is the configuration:
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
!
!
interface Port-channel1
 description G0/9-G0/10
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/1
 description connect to Ruckus R500
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/2
!
interface GigabitEthernet0/3
!
interface GigabitEthernet0/4
!
interface GigabitEthernet0/5
!
interface GigabitEthernet0/6
!
interface GigabitEthernet0/7
!
interface GigabitEthernet0/8
!
interface GigabitEthernet0/9
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode on
!
interface GigabitEthernet0/10
switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode on
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan100
 ip address 182.16.0.5 255.255.255.0
!
ip classless
ip http server
ip http secure-server
!
ip sla enable reaction-alerts
!
snmp-server community TESTING
!
privilege interface level 5 shutdown
privilege interface level 5 no shutdown
privilege interface level 5 description
privilege configure level 5 interface
privilege exec level 5 configure terminal
privilege exec level 5 configure
privilege exec level 5 show running-config interface
!
line con 0
 login local
line vty 0 4
 login local
line vty 5 15
 login local
0
Comment
Question by:techy98
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
6 Comments
 
LVL 17

Expert Comment

by:max_the_king
ID: 41786338
Hi,
VLAN internal allocation policy ascending
it is a default configuration for cisco switch, leave as it is

g0/1
is configured as a trunk port, so it does not belong to any vlan, it just let vlans pass through on the uplink

g0/9 and g0/10
are configured in port-channel, e.g. they form a unique 2Gb channel

vlan100
ha a public ip address, it may communicate with the router

vlan1
is in shutdown for security reasons

hope this helps
max
0
 

Author Comment

by:techy98
ID: 41787245
Thanks Max. but I still wonder...
usually output of show run will also show list of vlan but not this switch.
when I use show vlan, there is output of list of all vlan icluding default ones. is there any configuration that related?
0
 
LVL 17

Expert Comment

by:max_the_king
ID: 41787542
Hi,
the output of
show vlan
will always give you info which you cannot find on show run ... any cisco switch

you can sort output by doing:
sh vlan brief
sh vlan database
sh vlan ?

max
0
Q2 2017 - Latest Malware & Internet Attacks

WatchGuard’s Threat Lab is a group of dedicated threat researchers committed to helping you stay ahead of the bad guys by providing in-depth analysis of the top security threats to your network.  Check out our latest Quarterly Internet Security Report!

 

Author Comment

by:techy98
ID: 41787576
Thanks max for ypur further explanation and patient.
now i understood “vlan internal allocation policj asending” is for all cisco switch.
but I still cannot figure out why only this switch does not show list of vlan in show run.
I cross checked other switches, like 2690, in their output of show run, they have list of vlan.
for example,

!
vlan internal allocation policy ascending
!
vlan 101
name finance dept
!
vlan 102
name administration dept

I just try to learn more if there is something I am not aware.
0
 
LVL 17

Accepted Solution

by:
max_the_king earned 2000 total points
ID: 41787670
Hi,
the explanation is here: http://www.cisco.com/c/en/us/support/docs/switches/catalyst-2940-series-switches/109304-manage-vlandat.html

Viewing VLAN Information

In order to display all the VLAN configurations, the VLAN ID, name, and so forth, that are stored in the binary vlan.dat file, you must issue the show vlan command.
You can display the VTP information, the mode, domain, and so forth, with use of the show vtp status command.
The VLAN information and the VTP information are not displayed in the show running-config command output when the switch is in the VTP server/client mode. This is normal behavior of the switch.
Switch#show run | include vlan
vlan internal allocation policy ascending
Switch#

Switch#show run | include vtp
Switch#
Switches that are in VTP transparent mode display the VLAN and VTP configurations in the show running-config command output because this information is also stored in the configuration text file.
Switch#show run | include vlan
vlan internal allocation policy ascending
vlan 1
 tb-vlan1 1002
 tb-vlan2 1003
vlan 20-21,50-51
vlan 1002
 tb-vlan1 1
 tb-vlan2 1003
vlan 1003
 tb-vlan1 1
 tb-vlan2 1002
vlan 1004
vlan 1005

Switch#show run | include vtp
vtp domain cisco
vtp mode transparent

max
0
 

Author Closing Comment

by:techy98
ID: 41787698
Max, thanks so much! it`s much clear and do help me learning.
0

Featured Post

Q2 2017 - Latest Malware & Internet Attacks

WatchGuard’s Threat Lab is a group of dedicated threat researchers committed to helping you stay ahead of the bad guys by providing in-depth analysis of the top security threats to your network.  Check out our latest Quarterly Internet Security Report!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

There’s a movement in Information Technology (IT), and while it’s hard to define, it is gaining momentum. Some call it “stream-lined IT;” others call it “thin-model IT.”
Considering cloud tradeoffs and determining the right mix for your organization.
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …

609 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question