Please insert a disk into Removable Disk (N:).

I get File Explorer popping up with this message every few seconds.

I have nothing except my wireless mouse receiver in any of my USB slots.   I have moved the mouse receiver to a different USB slot but it still complains about N.

I am using Windows 10.

I have tried rebooting.

Any ideas please?  This is getting rather annoying now.

Colin BrazierAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

☠ MASQ ☠Commented:
Do you have a built-in card reader?
Does Explorer show N: under My Computer?
James EdwardsCommented:
If you're absolutely sure N: shouldn't be there....

Right-click the start button.  Select 'Disk Management'.

When the window opens, check for N: in the list of drives/devices.  if present, right-click and select 'delete volume'.

I suspect nothing will show in there though as it's asking for a disk that is NOT present.  In that case, check in Device Manager for disks.  You may have one listed with a faulty driver.

After that, I would start considering SSD memory card slots if this is a laptop.  Is it?
FOXActive Directory/Exchange EngineerCommented:
Computer Management>Disk Management.  Right-Click the drive in Question and change the drive letter
CompTIA Security+

Learn the essential functions of CompTIA Security+, which establishes the core knowledge required of any cybersecurity role and leads professionals into intermediate-level cybersecurity jobs.

James EdwardsCommented:
Also, run MSConfig and for testing purposes, untick 'load startup items'.  Restart.  If the issue is cleared, then systematically go through the Start Up Group items on the Startup' tab, re-enabling one at a time until you find the culprit.  Unless one sticks out like a sore thumb, in which case go for that 1st.
Drive N: in Windows 7 was for the Microsoft Virtual program.  Look in add/remove programs and uninstall if you are not using
Colin BrazierAuthor Commented:
Thanks all.

It does show up in File Explorer, does this screenshot help at all?
Disk N properties - hardware
General properties: 0 space used; 0 space free.

N does show in Disk Management, as 2nd screenshot shows.Disk Mgmt
I do have two other USB slots in use - the wired printer and wired keyboard.
Colin BrazierAuthor Commented:
Changed drive letter to P, same problem. Only with P!
Colin BrazierAuthor Commented:
I can't find Microsoft Virtual program in my list of programs.
☠ MASQ ☠Commented:
Have you used a card reader recently? - the one built into your Pixma printer?  Windows thinks it's still in use.

To fix (unless there's a hardware fault) ideally you'll need to insert a card in the reader designated N: (or now "P:"!)
then change the designated drive letter - try Z:

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Colin BrazierAuthor Commented:
Have you recently used one of your card readers

Good point.  I have never used the one in the printer (didn't know there was one!) and the Sandisk drive is an internal HDD.  But, I have used a USB card reader quite a lot and probably didn't eject it the proper way at some stage.
☠ MASQ ☠Commented:
Ahh - you caught me out editing my last post when I worked out the SanDisk was an SSD :)
See if the error still appears if you restart with the printer unplugged
If it does then yes Windows has a temp file path to/on the removable card on the now missing card reader - I should have been more circumspect in my first post "do you now or have you ever owned a removable card reader ..." :)

Plug the card reader back in put a card in N/P and that should help you clear it.
Colin BrazierAuthor Commented:
Yeah fooled me too, SanDisk have diversified.

Have restarted with the printer unplugged.  OK so far........
Colin BrazierAuthor Commented:
Yup, guess it's fixed.  Printer back in and all OK.

Colin BrazierAuthor Commented:
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.