Solved

Exchange 2013 Reinstall/Repair

Posted on 2016-09-07
29
73 Views
Last Modified: 2016-09-26
Is there a way to reinstall or repair exchange 2013 without losing everything?

One of our engineers installed direct access on a customers server trying to get VPNs setup, however since he installed it, then uninstalled it the exchange is down, accessing /ecp and /owa shows 404 errors, can I do a full repair or a reinstall without losing everything or doing everything from scratch?
0
Comment
Question by:GarveyJ
  • 18
  • 9
  • 2
29 Comments
 
LVL 41

Expert Comment

by:Amit
ID: 41787804
Yes, you can recover the server back again. Can you share the design, is it a stand alone or part of DAG? Check my article, which I wrote for 2010.

https://www.experts-exchange.com/articles/18110/How-To-Recover-Failed-Mailbox-Sever-In-Exchange-2010-DAG-Environment.html
0
 
LVL 1

Author Comment

by:GarveyJ
ID: 41787812
Its a standalone exchange 2013 server installation with everything on one box - it is in a live environment and everything is down at the moment, I have a backup of the .edb should i just uninstall exchange and reinstall?
0
 
LVL 24

Expert Comment

by:-MAS
ID: 41787830
0
 
LVL 1

Author Comment

by:GarveyJ
ID: 41787866
That link is assuming that I'm installing exchange on a new server - so surely to follow this instructions using the same WIndows 2012 box I would need to uninstall first?

Regards
0
 
LVL 41

Expert Comment

by:Amit
ID: 41787891
Don't install or uninstall anything. Answer below question:

1) Is current server up and running? If up, what you see in logs and services section?
2) Do you have Exchange Setup?
3) What level of rights your ID having in current environment. As you need Admin level access to Server.
0
 
LVL 1

Author Comment

by:GarveyJ
ID: 41787900
the current server is up and running, exchange services are all running but nothings working - cant get ecp or owa

I have the exchange setup located on a seperate server drive which I am in the process of copying exchange too.

Thanks for your assistance so far.
0
 
LVL 1

Author Comment

by:GarveyJ
ID: 41787901
By copying exchange too, I meant I am making an additional backup of the .edb and .log files
0
 
LVL 41

Expert Comment

by:Amit
ID: 41787909
You can keep the copy, however it is not required. Lets do some basic checks. Run below command and share the result
test-servicehealth
0
 
LVL 1

Author Comment

by:GarveyJ
ID: 41787919
[PS] C:\Windows\system32>test-servicehealth
Creating a new session for implicit remoting of "Test-ServiceHealth" command...


Role                    : Mailbox Server Role
RequiredServicesRunning : True
ServicesRunning         : {IISAdmin, MSExchangeADTopology, MSExchangeDelivery, MSExchangeIS,
                          MSExchangeMailboxAssistants, MSExchangeRepl, MSExchangeRPC, MSExchangeServiceHost,
                          MSExchangeSubmission, MSExchangeThrottling, MSExchangeTransportLogSearch, W3Svc, WinRM}
ServicesNotRunning      : {}

Role                    : Client Access Server Role
RequiredServicesRunning : True
ServicesRunning         : {IISAdmin, MSExchangeADTopology, MSExchangeMailboxReplication, MSExchangeRPC,
                          MSExchangeServiceHost, W3Svc, WinRM}
ServicesNotRunning      : {}

Role                    : Unified Messaging Server Role
RequiredServicesRunning : True
ServicesRunning         : {IISAdmin, MSExchangeADTopology, MSExchangeServiceHost, MSExchangeUM, W3Svc, WinRM}
ServicesNotRunning      : {}

Role                    : Hub Transport Server Role
RequiredServicesRunning : True
ServicesRunning         : {IISAdmin, MSExchangeADTopology, MSExchangeEdgeSync, MSExchangeServiceHost,
                          MSExchangeTransport, MSExchangeTransportLogSearch, W3Svc, WinRM}
ServicesNotRunning      : {}



[PS] C:\Windows\system32>
0
 
LVL 41

Expert Comment

by:Amit
ID: 41787927
Services looks fine. Hence I will not recommend reinstallation. What exactly your engineer did, did he change any setting on IIS? Did you restarted the server? If not restart it.
0
 
LVL 1

Author Comment

by:GarveyJ
ID: 41787930
he installed direct access then uninstalled it, after a server restart nothing works, i cant get on /owa or /ecp links they all say 400 bad request
0
 
LVL 41

Expert Comment

by:Amit
ID: 41787942
I suggest you to restart this server and check again. Please check the article related to error you are seeing from MS.

https://support.microsoft.com/en-in/kb/2988444

If you have option to open case with MS, go ahead and open it.
0
 
LVL 1

Author Comment

by:GarveyJ
ID: 41787945
I have restarted the server a few times to no avail, I have read and worked through a few articles including the one you mentioned which is why I was looking at repair/reinstall - would that still work using the same server?
0
 
LVL 41

Expert Comment

by:Amit
ID: 41787962
I personally will focus on fixing root cause. However, if you want to go with repair option, you can give a try. Remember, it is a recover server exercise. Before you can move forward, check two more items.

1) What happen when you launch outlook? What error you are getting.
2) Test OWA and ecp via exrca.com, see what error you are seeing.
0
Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

 
LVL 1

Author Comment

by:GarveyJ
ID: 41788190
outlook cannot connect to server, I cant access ecp or owa, the event logs are few and far between and just say service issues, even though the services are fine.

basically the owa and ecp have all went cocked up somewhere along the way and I need to put them all back, It isn't working the usual way so I'm thinking that a full reinstall of exchange will be the best and simplest solution, everything was working up until this morning.

I just dont know how to reinstall exchange on the sa,me box, can I just do a removal and then reinstall it and put the database back in? or will it cock up all my AD etc?

Can i just remove one part of exchange that handles the owa/ecp and reinstall that?

Regards

J
0
 
LVL 1

Author Comment

by:GarveyJ
ID: 41788218
outlook error message: Task 'Microsoft Exchange Server' reported error (0x8004011d): 'The server is not available. Contact your administrator is this condition persists.
0
 
LVL 41

Expert Comment

by:Amit
ID: 41788271
It seems something got corrupted on network setting. Are you sure, that tool is removed properly. Can you check services and see if anything related to VPN tool is running.

Next to your question how to reinstall it. In this case, you just need to reset computer account in AD. Join it back to Domain. Then launch cmd in admin mode. Browse to exchange setup bin folder and Run:

Setup /m:RecoverServer /IAcceptExchangeServerLicenseTerms

That will reinstall the Exchange back to normal. Don't need to restore DB. As your server is up, it will be mounted automatically. Make sure you update rollup also, which is currently present on server. Don't install higher or lower version. If you have doubt on version run below command from EMS.
GCM exsetup |%{$_.Fileversioninfo}

However, I still don't think it is Exchange issue, as you are able to launch EMS.
0
 
LVL 1

Author Comment

by:GarveyJ
ID: 41788309
Should i disable all the mailboxes before I uninstall exchange or not? If I uninstall exchange it wont delete the AD users will it?
0
 
LVL 1

Author Comment

by:GarveyJ
ID: 41788313
I understand that but obviously before i install exchange I have to remove the current installation, will that remove all my users from AD?
0
 
LVL 1

Author Comment

by:GarveyJ
ID: 41788315
Also, I know exchange is running and the EMS is fine but all of the IIS information is gone so i'm thinking the quickest way to get it back is to reinstall exchange - I have tried for 7 hours today to get them back other ways with no luck.
0
 
LVL 41

Expert Comment

by:Amit
ID: 41788323
No need to disable user or remove Exchange. If you remove Exchange from environment, all user will be gone. That will be nightmare. You need to just use recover command. If you have never done this before, then you need to get MS to help you out.
0
 
LVL 1

Author Comment

by:GarveyJ
ID: 41788365
When I run Setup /m:RecoverServer /IAcceptExchangeServerLicenseTerms I get the message:

C:\Users\administrator\Downloads\cu12>Setup /m:RecoverServer /IAcceptExchang
eServerLicenseTerms

Welcome to Microsoft Exchange Server 2013 Cumulative Update 12 Unattended Setup
Copying Files...
File copy complete. Setup will now collect additional information needed for
installation.
Languages
Mailbox role: Transport service
Mailbox role: Client Access service
Mailbox role: Unified Messaging service
Mailbox role: Mailbox service
Management tools
Client Access role: Client Access Front End service
Client Access role: Front End Transport service
The following server roles are already installed: BridgeheadRole,
 ClientAccessRole, MailboxRole, UnifiedMessagingRole, FrontendTransportRole,
 AdminToolsRole, CafeRole.

The Exchange Server setup operation didn't complete. More details can be found
in ExchangeSetup.log located in the <SystemDrive>:\ExchangeSetupLogs folder.
0
 
LVL 1

Author Comment

by:GarveyJ
ID: 41788371
here is the log file:

[09/07/2016 18:07:09.0903] [0] **********************************************
[09/07/2016 18:07:10.0020] [0] Starting Microsoft Exchange Server 2013 Setup
[09/07/2016 18:07:10.0020] [0] **********************************************
[09/07/2016 18:07:10.0022] [0] Local time zone: (UTC+00:00) Dublin, Edinburgh, Lisbon, London.
[09/07/2016 18:07:10.0022] [0] Operating system version: Microsoft Windows NT 6.2.9200.0.
[09/07/2016 18:07:10.0025] [0] Setup version: 15.0.1178.4.
[09/07/2016 18:07:10.0026] [0] Logged on user: EJM\administrator.
[09/07/2016 18:07:10.0173] [0] Command Line Parameter Name='mode', Value='RecoverServer'.
[09/07/2016 18:07:10.0173] [0] Command Line Parameter Name='iacceptexchangeserverlicenseterms', Value=''.
[09/07/2016 18:07:10.0173] [0] Command Line Parameter Name='sourcedir', Value='C:\Users\administrator.EJM\Downloads\cu12'.
[09/07/2016 18:07:10.0357] [0] RuntimeAssembly was started with the following command: '/m:RecoverServer /IAcceptExchangeServerLicenseTerms /sourcedir:C:\Users\administrator.EJM\Downloads\cu12'.
[09/07/2016 18:07:10.0361] [0] The registry key, HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0, wasn't found.
[09/07/2016 18:07:10.0361] [0] The registry key, HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ExchangeServer\v14, wasn't found.
[09/07/2016 18:07:10.0367] [0] Copying Files...
[09/07/2016 18:07:10.0372] [0] Starting copy from C:\Users\administrator.EJM\Downloads\cu12\Setup\ServerRoles\Common to C:\Windows\Temp\ExchangeSetup.
[09/07/2016 18:07:14.0398] [0] Finished copy from C:\Users\administrator.EJM\Downloads\cu12\Setup\ServerRoles\Common to C:\Windows\Temp\ExchangeSetup.
[09/07/2016 18:07:14.0414] [0] File copy complete. Setup will now collect additional information needed for installation.
[09/07/2016 18:07:14.0420] [0] Assembly dll file location is C:\Windows\Temp\ExchangeSetup\Microsoft.Exchange.Setup.Console.dll
[09/07/2016 18:07:19.0606] [0] Setup is choosing the domain controller to use
[09/07/2016 18:07:19.0837] [0] The MSExchangeADTopology has a persisted domain controller: EJMSVR.EJM.local
[09/07/2016 18:07:21.0439] [0] PrepareAD has been run, and has replicated to this domain controller; so setup will use EJMSVR.EJM.local
[09/07/2016 18:07:21.0440] [0] Setup is choosing a global catalog...
[09/07/2016 18:07:21.0487] [0] Setup has chosen the global catalog server EJMSVR.EJM.local.
[09/07/2016 18:07:21.0495] [0] Setup will use the domain controller 'EJMSVR.EJM.local'.
[09/07/2016 18:07:21.0496] [0] Setup will use the global catalog 'EJMSVR.EJM.local'.
[09/07/2016 18:07:21.0498] [0] Exchange configuration container for the organization is 'CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=EJM,DC=local'.
[09/07/2016 18:07:21.0503] [0] Exchange organization container for the organization is 'CN=EJM,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=EJM,DC=local'.
[09/07/2016 18:07:21.0524] [0] Setup will search for an Exchange Server object for the local machine with name 'EJMSVR'.
[09/07/2016 18:07:21.0703] [0] Exchange Server object found : 'CN=EJMSVR,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=EJM,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=EJM,DC=local'.
[09/07/2016 18:07:21.0796] [0] The following roles have been unpacked: BridgeheadRole ClientAccessRole MailboxRole UnifiedMessagingRole FrontendTransportRole AdminToolsRole CafeRole
[09/07/2016 18:07:21.0799] [0] The following datacenter roles are unpacked:
[09/07/2016 18:07:21.0803] [0] The following roles are installed: BridgeheadRole ClientAccessRole MailboxRole UnifiedMessagingRole FrontendTransportRole AdminToolsRole CafeRole
[09/07/2016 18:07:21.0807] [0] The local server has some Exchange files installed.
[09/07/2016 18:07:21.0822] [0] Server Name=EJMSVR
[09/07/2016 18:07:21.0840] [0] Setup will use the path 'C:\Users\administrator.EJM\Downloads\cu12' for installing Exchange.
[09/07/2016 18:07:21.0844] [0] Setup will discover the installed roles from server object 'CN=EJMSVR,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=EJM,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=EJM,DC=local'.
[09/07/2016 18:07:21.0845] [0] 'BridgeheadRole' is installed on the server object.
[09/07/2016 18:07:21.0845] [0] 'ClientAccessRole' is installed on the server object.
[09/07/2016 18:07:21.0845] [0] 'MailboxRole' is installed on the server object.
[09/07/2016 18:07:21.0846] [0] 'UnifiedMessagingRole' is installed on the server object.
[09/07/2016 18:07:21.0846] [0] 'CafeRole' is installed on the server object.
[09/07/2016 18:07:21.0846] [0] 'FrontendTransportRole' is installed on the server object.
[09/07/2016 18:07:21.0850] [0] The installation mode is set to: 'DisasterRecovery'.
[09/07/2016 18:07:22.0805] [0] An Exchange organization with name 'EJM' was found in this forest.
[09/07/2016 18:07:22.0807] [0] Active Directory Initialization status : 'True'.
[09/07/2016 18:07:22.0807] [0] Schema Update Required Status : 'False'.
[09/07/2016 18:07:22.0807] [0] Organization Configuration Update Required Status : 'False'.
[09/07/2016 18:07:22.0808] [0] Domain Configuration Update Required Status : 'False'.
[09/07/2016 18:07:22.0809] [0] The locally installed version is 15.0.1178.4.
[09/07/2016 18:07:22.0810] [0] Exchange Installation Directory : 'C:\Program Files\Microsoft\Exchange Server\V15'.
[09/07/2016 18:07:22.0863] [0] Setup will run from path 'C:\Windows\Temp\ExchangeSetup'.
[09/07/2016 18:07:22.0881] [0] DisasterRecoveryModeDataHandler has 14 DataHandlers
[09/07/2016 18:07:22.0882] [0] RootDataHandler has 1 DataHandlers
[09/07/2016 18:07:22.0882] [0]      Languages
[09/07/2016 18:07:22.0882] [0]      Mailbox role: Transport service
[09/07/2016 18:07:22.0882] [0]      Mailbox role: Client Access service
[09/07/2016 18:07:22.0882] [0]      Mailbox role: Unified Messaging service
[09/07/2016 18:07:22.0882] [0]      Mailbox role: Mailbox service
[09/07/2016 18:07:22.0882] [0]      Management tools
[09/07/2016 18:07:22.0882] [0]      Client Access role: Client Access Front End service
[09/07/2016 18:07:22.0882] [0]      Client Access role: Front End Transport service
[09/07/2016 18:07:22.0895] [0] Validating options for the 7 requested roles
[09/07/2016 18:07:22.0896] [0] The server cannot be recovered because Setup has detected that Exchange server roles are already installed.
[09/07/2016 18:07:22.0925] [0] The following server roles are already installed: BridgeheadRole, ClientAccessRole, MailboxRole, UnifiedMessagingRole, FrontendTransportRole, AdminToolsRole, CafeRole.
[09/07/2016 18:07:22.0926] [0] CurrentResult console.ProcessRunInternal:90: 1
[09/07/2016 18:07:22.0929] [0] CurrentResult launcherbase.maincore:90: 1
[09/07/2016 18:07:22.0929] [0] CurrentResult console.startmain:52: 1
[09/07/2016 18:07:22.0930] [0] CurrentResult SetupLauncherHelper.loadassembly:452: 1
[09/07/2016 18:07:22.0930] [0] The Exchange Server setup operation didn't complete.  More details can be found in ExchangeSetup.log located in the <SystemDrive>:\ExchangeSetupLogs folder.
[09/07/2016 18:07:22.0930] [0] CurrentResult main.run:235: 1
[09/07/2016 18:07:22.0930] [0] CurrentResult setupbase.maincore:396: 1
[09/07/2016 18:07:22.0932] [0] End of Setup
[09/07/2016 18:07:22.0932] [0] **********************************************
0
 
LVL 1

Author Comment

by:GarveyJ
ID: 41788379
basically it cant do it because exchange is installed, but if I cant uninstall exchange without wiping out my AD then does that mean I have to get a new server just to reinstall exchange?
0
 
LVL 41

Expert Comment

by:Amit
ID: 41788408
Did you reset the Exchange server AD object in AD.
0
 
LVL 1

Author Comment

by:GarveyJ
ID: 41788442
yep, followed the instructions to a T
0
 
LVL 1

Accepted Solution

by:
GarveyJ earned 0 total points
ID: 41810183
Just to let you all know, I followed various guides online on how to manually rebuild the iis part of exchnage and also upgraded my exchange to roll up 13 from 12, I got errors for the first 7 tries when installing the update but fixes each one and tried again and 48 hours later the installation worked and everything is up and running.

thanks for your assistance.
0
 
LVL 1

Author Closing Comment

by:GarveyJ
ID: 41815730
I explained what I did to fix the issue.
0
 
LVL 24

Expert Comment

by:-MAS
ID: 41815749
Glad to know it is fixed and thanks for sharing the solution.

MAS
0

Featured Post

Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Exchange 2010 fails to send outgoing email 7 49
exchange, outlook 7 38
Exchange on iphone 16 40
Clearwell e-discovery compatible with Enterprise Vault 11.0.1+ 2 16
OfficeMate Freezes on login or does not load after login credentials are input.
This article lists the top 5 free OST to PST Converter Tools. These tools save a lot of time for users when they want to convert OST to PST after their exchange server is no longer available or some other critical issue with exchange server or impor…
In this Micro Tutorial viewers will learn how they can get their files copied out from their unbootable system without need to use recovery services. As an example non-bootable Windows 2012R2 installation is used which has boot problems.
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

930 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now