Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 98
  • Last Modified:

Exchange Server 2010 and Outlook 2010 - Foward emails

I need to have a rule that will forward emails that are sent to a specific email address.  I have setup a new mail box in exchange, and connected the mailbox on a PC.  I can send and receive emails, I can forward an email to my Gmail account, but when I setup a rule to forward the email to my gmail account, I see it get sent out in the sent folder but I never see it get to my gmail account.
Any suggestions would be helpfull?

I have GFI Mail essentials scanning inbound and outbound emails, it actually show the message being sent out.
0
Scott Johnston
Asked:
Scott Johnston
  • 4
  • 2
  • 2
  • +1
2 Solutions
 
Adam BrownSr Solutions ArchitectCommented:
It is probably being blocked by gmail's filters. You will want to white list your address in gmail
0
 
FOXActive Directory/Exchange EngineerCommented:
Create a contact in Exchange for the gmail account.  In Exchange set up forwarding from the email account in question to the exchange contact that is the gmail account.
0
 
Scott JohnstonSystems ConsultantAuthor Commented:
I can already forward manually to my gmail account and it works perfectly, I have tried this by opening the mail in outlook and then clicking forward, the email will forward fine.

I can see the rule email that was forwarded in the GFI logs and the manually forwarded email in the GFI logs are both being sent with a Scan Result of OK.

My confusion is why can i forward a email manually but when the rule is trying to forward the email it gets lost?
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
gilnovSystems AdministratorCommented:
Try a redirect rather than a forward rule in Outlook.
0
 
gilnovSystems AdministratorCommented:
As for why this is happening, examine the message headers of a manually forwarded email vs one forwarded by the rule. There are going to be indicators in headers that the message was forwarded by rule rather than by a human and outbound spam filter may be bagging such messages. I'm not familiar with GFI Mail Essentials, but many companies consider it a violation to automatically forward messages to addresses outside the recipient domain. Maybe this is a default configuration in GFI.
0
 
Scott JohnstonSystems ConsultantAuthor Commented:
SOLVED:

All of this is because of the Microsoft exchange.
Since the 2010 version the process by which we have forward emails will not allow automatic forwarding unless configured by the admin.
"Forwarding messages outside your organization

By default, Microsoft Exchange Server accounts (starting with Exchange Server 2010) can’t use rules to forward messages to email addresses outside your organization. This setting helps prevent confidential and private organizational information from being disclosed."


Follow these instructions:
Create Forward Mailboxes in Exchange Server 2010
Tip:Create Forward Mailboxes in Exchange Server 2010


Say you have custom recipients, such as a mail-enabled user who has an alias in your organization but not an Exchange mailbox and all the messages to that alias are forwarded to the user’s external e-mail address. Custom recipients like this don’t typically receive mail from users outside the organization because a custom recipient doesn’t have an e-mail address that resolves to a specific mailbox in your organization. At times, though, you might want external users, applications, or mail systems to be able to send mail to an address within your organization and have Exchange forward that message to an external mailbox.

1. Using the Exchange Management Console, create a mail-enabled contact for the user. Name the contact Alert User Name, such as Alert William Stanek. Be sure to establish an external e-mail address for the contact that refers to the user’s Internet address.

2. Using the Exchange Management Console, create a mailbox-enabled user account in the domain. Name the account with the appropriate display name, such as Z William Stanek. Be sure to create an Exchange mailbox for the account, but don’t grant any special permission to the account. You might want to restrict the account so that the user can’t log on to any servers in the domain.

3. Using the Exchange Management Console, access the Properties dialog box for the user’s mailbox.

4. On the Mail Flow Settings tab, select Delivery Options and then click Proper¬ties.

5. In the Delivery Options dialog box, select the Forward To check box and then click Browse.

6. In the Select Recipient dialog box, select the mail-enabled contact you cre¬ated earlier and then click OK three times.You can now use the user account to forward mail to the external mailbox.
0
 
Scott JohnstonSystems ConsultantAuthor Commented:
FOX, you were correct, it would of helped to add in more details in your suggestion.

Thank you
0
 
Scott JohnstonSystems ConsultantAuthor Commented:
FOXLUV I gave you the entire point total, but your solution was brief and would of saved me a lot of time if you had a bit more detailed information.
0
 
FOXActive Directory/Exchange EngineerCommented:
Pardon, me for not explaining thoroughly as I was on my ft job. I wanted to get you up and running asap, that is why I suggested exactly what to do.
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 4
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now