Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Crazy font shrinkage with Firefox

Posted on 2016-09-08
11
Medium Priority
?
125 Views
Last Modified: 2016-09-14
One of my users (the boss, in fact) was surprised that while using Firefox with our internal site the fonts on <select> drop-down suddenly reduced in size, see selectSmall image. Normally, the are larger, see selectNormal image. I checked this on my workstation and mine appear correct. Likewise for other workstations in the office. We are both using Windows 7, and Firefox 28.0.2. The .css for the page specifies.
select { font-size: 14pt; font-family: arial }

Open in new window

Does anyone have any idea what could be wrong?
selectSmall.jpg
selectNormal.jpg
0
Comment
Question by:jmarkfoley
  • 5
  • 2
  • 2
  • +2
11 Comments
 
LVL 14

Expert Comment

by:ThomasMcA2
ID: 41789948
Looking at just that screen print, all of the fonts are smaller, not just the drop-down.

What is the zoom percentage in FF? It is usually shown in the status bar at the bottom of the FF window.

If that percentage has been reduced, just hit Ctrl and the plus key to increase it.
0
 
LVL 10

Expert Comment

by:ecarbone
ID: 41789987
Press Control+0 (zero) to restore the view back to 100%.  (Command-0 on a Mac)

They may have accidentally pressed Control+- or had their finger on the Control key while using the scroll wheel on their mouse.
1
 
LVL 30

Expert Comment

by:Dr. Klahn
ID: 41790533
Side note:  That version of Firefox is "mature" (current is up around 47) and should probably be replaced with a more recent version at least in the early version 30 range.  There have been numerous security problems corrected in Firefox over the last few years.

Note that versions 30 and up have a somewhat different look-and-feel from older versions.  The "Classic Theme Restorer" plug-in can help with this; and the "Zoom Page" plug-in makes it easier to deal with page scaling.  Surprisingly, on my system Firefox looks better at 80% scale.  There is considerable interaction between the default font size and the scaling, and it took a while to find a combination that looks good.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 1

Author Comment

by:jmarkfoley
ID: 41791295
Thanks for the replies!

ThomasMcA2:
Looking at just that screen print, all of the fonts are smaller, not just the drop-down.
No, in real life the fonts are the same. The apparently difference is that the screen-capture was done on two different machines which rendered the JPGs slightly different in size. If you'll notice, the names in the drop-down go to nearly the right edge of the box in selectNormal.jpg whereas they only extend about 3/4 of the way across the box in selectSmall.jpg. I probably should have scaled both images to be the same size so as not to throw everyone off.

In any case, CTRL-0 had no effect.

Dr. Klahn:
Side note:  That version of Firefox is "mature" (current is up around 47) and should probably be replaced with a more recent version at least in the early version 30 range.  There have been numerous security problems corrected in Firefox over the last few years.
All our workstations have Firefox set to automatically update, which they do regularly. Once again, I've fat-fingered typing on a critical piece of information. Our current version is 48.0.2, not 28.0.2.
0
 
LVL 10

Expert Comment

by:ecarbone
ID: 41791337
So you're both using the same version of Firefox.
What about the OS? Are you both using Windows? (or is one using a Mac and one is using Windows)?

If Control+zero has no effect, check the following:

1. In Firefox, enter "about:config" into the address bar. Using the Search box at the top of that page, search for "font.minimum-size" and change the value to 0.

2. Tap once on the Alt key to make the menu bar appear temporarily. Click on View > Zoom and select "Reset". Also make sure "Zoom Text Only" is not selected

3. Go to Options > Content > Fonts and see if the default font is the same on both browsers. Also compare the settings in the "Advanced" section (on that same page)
0
 
LVL 1

Author Comment

by:jmarkfoley
ID: 41792109
ecarbone:
Expert Comment 2016-09-09 at 10:21:42ID: 41791337
So you're both using the same version of Firefox.
What about the OS? Are you both using Windows? (or is one using a Mac and one is using Windows)?
Yes, same version of Firefox (48.0.2), both/all using Windows 7.
If Control+zero has no effect, check the following:

1. In Firefox, enter "about:config" into the address bar. Using the Search box at the top of that page, search for "font.minimum-size" and change the value to 0.
There are a bunch of "font.minumim-size.xx where 'xx' is a language suffix, e.g. .ar, .el .he. There is no .en. The only one set to non-zero is font.minimum-size.th. These settings are the same on both computers. I've not messed with anything here.
2. Tap once on the Alt key to make the menu bar appear temporarily. Click on View > Zoom and select "Reset". Also make sure "Zoom Text Only" is not selected
Did that, "Zoom Text Only" was not set.
3. Go to Options > Content > Fonts and see if the default font is the same on both browsers. Also compare the settings in the "Advanced" section (on that same page)
Default font is same on both computers: Times New Roman, 16.

I also uninstalled and reinstalled Firefox. No change.
0
 
LVL 30

Accepted Solution

by:
Dr. Klahn earned 2000 total points
ID: 41792113
I also uninstalled and reinstalled Firefox. No change.


Were the users' Firefox (hidden) individual preference folders were also deleted?
0
 
LVL 1

Author Comment

by:jmarkfoley
ID: 41792190
Were the users' Firefox (hidden) individual preference folders were also deleted?
I wasn't asked that when doing the uninstall, but I doubt it. It seems like favorites, etc. reappeared after I reinstalled. How would I delete hidden preferences?
0
 
LVL 1

Author Comment

by:jmarkfoley
ID: 41795340
I found the hidden folders in C:\Users\username\AppData\Roaming\Mozilla\Firefox\Profiles and C:\Users\username\AppData\Local\Mozilla\Firefox\Profiles. I removed Firefiox, then removed (renames, actually) those folders, reinstalled Firefox and voilla! fonts are back to normal.
0
 

Expert Comment

by:Tammy Coffin
ID: 41797594
We have recently come across this same issue after one of our users upgraded to the latest version of Firefox. It seems there is a bug in the upgrade which is causing this. I tested it on my PC and uninstalling and deleting the local and roaming profiles fixes it, however the user would then loose all their history, favorites, remembered passwords etc. Is there any way of preserving this, or fixing it without loosing that information, or is there a way of finding out if Firefox plan to do a new release to fix the bug?
0
 
LVL 1

Author Comment

by:jmarkfoley
ID: 41797868
Yes, you can save bookmarks. I was able to. Go here to find out where your profiles are stored: https://support.mozilla.org/en-US/kb/profiles-where-firefox-stores-user-data#w_how-do-i-find-my-profile. Then here for restoring bookmarks: https://support.mozilla.org/en-US/kb/restore-bookmarks-from-backup-or-move-them. I did the manual backup.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article demonstrates how to create a simple responsive confirmation dialog with Ok and Cancel buttons using HTML, CSS, jQuery and Promises
Q&A with Course Creator, Mark Lassoff, on the importance of HTML5 in the career of a modern-day developer.
The viewer will receive an overview of the basics of CSS showing inline styles. In the head tags set up your style tags: (CODE) Reference the nav tag and set your properties.: (CODE) Set the reference for the UL element and styles for it to ensu…
How to create a custom search shortcut to site-search Experts Exchange using Google in the Firefox browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch your Bookmark Menu: Press 'Ctrl +…

963 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question